Datei-Rechte bei Gruppe auf "Unknown" gesetzt - wie ändern?

Diskutiere mit über: Datei-Rechte bei Gruppe auf "Unknown" gesetzt - wie ändern? im Mac OS X Forum

  1. 2nd

    2nd Thread Starter MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    Registriert seit:
    25.07.2004
    Huhu,

    habe schon wieder eine Frage (langsam wird es inflationär :D):

    In meiner iTunes Musik Bibliothek hat iTunes heute eine Musikrichtung selbstständig nach dem Abspielen des Tracks geändert: Von Hip Hop auf Hip-Hop.

    Nach etwas Recherche im Forum liegt das wohl an den falsch gesetzten Rechten der Tracks auf der Platte.

    Eigentümer bin ich (Lesen & Schreiben), bei Gruppe steht da "Unknown" -> das läßt sich leider nicht ändern, springt sofort zurück. Früher stand da "Admin".

    Warum kann ich die Gruppenrechte nicht ändern??? Geht auch nicht mit dem Root-Account, habe ich gerade probiert.

    Hilfe!

    Frank
     
  2. der_Kay

    der_Kay MacUser Mitglied

    Beiträge:
    1.693
    Zustimmungen:
    7
    Registriert seit:
    02.09.2004
    auch in der shell nicht?
    Code:
    cd <da, wo Deine Tracks liegen>
    sudo chmod 666 *.mp3
    
    und eventuell:
    Code:
    id
    sudo chown <Dein Kontenname>:<Deine Gruppe> *.mp3
    
     
  3. 2nd

    2nd Thread Starter MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    Registriert seit:
    25.07.2004
    Danke erstmal Kay. Aber ich bin Shell-Dau. Ok, ich habe schonmal davon gehört :D

    Problem: Die Musik liegt auf einem anderen Volume (externe Platte namens "volksmusik") in einem Order namens "_rock'n'roll" und dort fein säuberlich Ordner einsortiert, die wie die Interpreten heissen.

    D. h. ich muss alle mp3s in den Unterordnern mit ändern, 2 Probleme:

    Wie komme ich auf das andere Volume?
    Wie kann ich alles in den unterverzeichnissen mit inkludieren?

    Danke,

    Frank
     
  4. Gerundium

    Gerundium MacUser Mitglied

    Beiträge:
    1.997
    Zustimmungen:
    69
    Registriert seit:
    22.10.2005
    Hast du denn die Einstellung "Zugriffsrechte auf diesem Volume ignorieren" (oder so ähnlich) deaktiviert? Das findest du in der Information zu dem Volume.
     
  5. 2nd

    2nd Thread Starter MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    Registriert seit:
    25.07.2004
    YES - Du bist mein Mann :D

    Das war es und nun kann ich alles ändern. So was einfaches hihi. Danke Danke Danke!

    Noch eine Verständnisfrage: Wenn ich auf einer externen Platte Daten habe, die differenziert mit Rechten ausgestattet sind und ich stöpsele die Platte an einen beliebigen Mac - dann kann jeder immer auf die Daten zugreifen? Oder wie ist das zu verstehen? Was bedeutet denn diese Option?

    Frank
     
  6. Gerundium

    Gerundium MacUser Mitglied

    Beiträge:
    1.997
    Zustimmungen:
    69
    Registriert seit:
    22.10.2005
    Genau, wenn du die Platte an einen anderen Rechner anschließt, dann werden automatisch die Zugriffsrechte ignoriert. Einerseits ist es so möglich, auf den Inhalt zuzugreifen - was man im Rahmen der Benutzung einer mobilen Festplatte auch erwartet -, andererseits werden Konflikte umgangen, die durch identische UIDs entstehen können.

    Welche Platte wie zu behandeln ist, das merkt sich der betreffende Mac dann.
     
Die Seite wird geladen...
Ähnliche Themen - Datei Rechte bei Forum Datum
Keine Rechte für eine .command Datei Mac OS X 28.12.2011
Ordner und Dateien löschen Mac OS X 08.04.2010
gemeinsam genutzte Datei ändert ständig Rechte Mac OS X 09.12.2009
Dateirechte ändern chmod Mac OS X 24.10.2009
Datei aus dmg-Image entfernen - fehlende Rechte Mac OS X 18.10.2009

Diese Seite empfehlen

Benutzerdefinierte Suche