Canon LPB-660 mittels CUPS installieren - klappt nicht...

Diskutiere mit über: Canon LPB-660 mittels CUPS installieren - klappt nicht... im Utilities und Treiber Forum

  1. Joke

    Joke Thread Starter MacUser Mitglied

    Beiträge:
    4
    Zustimmungen:
    0
    Registriert seit:
    11.03.2006
    Canon LBP-660 mittels CUPS installieren - klappt nicht...

    Hallo Freunde,

    vor wenigen Tagen habe ich es geschafft, nach der Anleitung von MrFX meinen Konika Minolta Magicolor 2300W unter Tiger zum Laufen zu bringen - Super Sache!

    Voller Freude ging ich nun meinen Canon LBP-660 S/W Laserdrucker mit Centronics Schnittstelle an. Ich bekomme das leider nicht in den Griff. Der Drucker wird über ein USB/Centronics Wandler brav von Tiger erkannt, das simple Zuweisen der PPD reicht aber für ein Funktionieren wohl nicht aus.

    Ich ging schon mehrmals mit dem Treiber von www.linuxprinting.org ins Rennen. Die Anleitung mit all den "make" und "make install" usw führen im Terminalfenster leider nur zu ellenlangen Fehlerlisten.

    Beispiel ANFANG:

    iMac:~/documents/lbp660 heinz$ make
    gcc -O2 -s lbp660.c -o lbp660
    lbp660.c:25:47: error: sys/io.h: No such file or directory
    lbp660.c: In function 'get_bitmap':
    lbp660.c:162: warning: incompatible implicit declaration of built-in function 'memset'
    lbp660.c: In function 'out_packet':
    lbp660.c:232: warning: pointer targets in passing argument 1 of 'sprintf' differ in signedness
    lbp660.c: In function 'compress_bitmap':
    lbp660.c:249: warning: pointer targets in passing argument 1 of 'fgets' differ in signedness
    lbp660.c:259: warning: pointer targets in passing argument 1 of 'fgets' differ in signedness
    lbp660.c:262: warning: pointer targets in passing argument 1 of 'sscanf' differ in signedness
    lbp660.c: In function 'errorexit':
    lbp660.c:410: warning: incompatible implicit declaration of built-in function 'exit'
    lbp660.c: In function 'main':
    lbp660.c:949: warning: incompatible implicit declaration of built-in function 'strcpy'
    make: *** [lbp660] Error 1

    Beispiel ENDE

    Diese Meldungen sagen mir leider nicht viel (außer, dass sie nicht gerade positiv sind) Ist dieser Treiber eventuell nur für Linux geeignet?
    Leider habe ich keine Ahnung von Unix und Linux - ich bin aber schon stolz, dass ich den Konica Minolta zum Laufen gebracht habe...

    Falls mir jemand mit einer Anleitung zur Hand gehen könnte, wäre mir sehr geholfen!

    Joke
     
Die Seite wird geladen...
Ähnliche Themen - Canon LPB mittels Forum Datum
Mac neu installiert - Datensicherung auch mittels Migrationsassistent nicht mehr möglich Utilities und Treiber 13.12.2015
Suche Netzwerküberwachungstool mittels Ping für Mac Utilities und Treiber 07.11.2015
Canon IP 4600 druckt verzerrt Utilities und Treiber 10.05.2015
Treiber für Canon MF8300 Serie Utilities und Treiber 30.10.2014
Canon Drucker ip 4850 Papierschacht Utilities und Treiber 05.10.2014

Diese Seite empfehlen

Benutzerdefinierte Suche