Canon IP 4000 über Samba?

Dieses Thema im Forum "Peripherie" wurde erstellt von elocin, 13.11.2005.

  1. elocin

    elocin Thread Starter MacUser Mitglied

    Beiträge:
    19
    Zustimmungen:
    0
    MacUser seit:
    13.11.2005
    Hallo,

    ich habe jetzt seit kurzem ein Ibook und habe bisher verzweifelt versucht, meinen Drucker (Canon Pixma IP 4000), der an einem Win2K-PC hängt, über das Netzwerk zu aktivieren.
    Direkt über usb funktioniert er.

    Ich habe alle möglichen Einstellungen versucht (smb://Arbeitsgruppe/PC-Name/Druckername) ausprobiert. Auf dem Windows-PC ist er freigegeben.
    Bei der Druckereinrichtung am Mac kann ich ihn auswählen.

    Da es keine Gimp-Treiber gibt (zumindest hat bei mir keiner funktioniert) habe ich bei Printfab einen Treiber heruntergeladen. Den kann ich auch auswählen, der Drucker bringt mir aber immer noch die Fehlermeldung, dass der Logon gescheitert ist, bzw. dass er keine Verbindung zu samba bekommt und es in 60s wieder probiert - ohne Erfolg.

    Hat hier jemand den IP 4000 über ein Netzwerk zum Laufen gebracht?

    Was für einen Treiber müßte ich verwenden, damit es geht?

    Ich habe keinen Plan mehr, was ich noch versuchen soll. Unter der Forumssuche bin ich auch schon alle Beiträge durch, was aber leider in diesem Fall nicht geholfen hat. :(

    Lieben Gruss, elocin
     
  2. Tom1337

    Tom1337 MacUser Mitglied

    Beiträge:
    86
    Zustimmungen:
    0
    MacUser seit:
    15.10.2005
    Ich habe einen IP5000 den ich auch nicht zum laufen bringe. Scheint wohl ein generelles Problem bei Canon zu sein :(...
     
  3. ThoRic

    ThoRic MacUser Mitglied

    Beiträge:
    2.602
    Zustimmungen:
    179
    MacUser seit:
    13.02.2005
    Im aktuellen Gutenprint ist der iP4000 dabei. Steht leider nirgendwo - is aber so ;-)

    Es kommt was raus, schön ist es aber nicht. Also reine Textausdrucke gehen, aber richtung Fotodruck hab ich noch niochts passables auf die Reihe gebracht.
     
  4. MrFX

    MrFX MacUser Mitglied

    Beiträge:
    7.352
    Zustimmungen:
    77
    MacUser seit:
    26.09.2003
    Moin!

    Der Printfab-Treiber funktioniert einwandfrei übers Netzwerk.

    Ich denke mal, daß etwas mit deiner Windows-Freigabe nicht stimmt.

    MfG
    MrFX
     
  5. elocin

    elocin Thread Starter MacUser Mitglied

    Beiträge:
    19
    Zustimmungen:
    0
    MacUser seit:
    13.11.2005
    Jetzt habe ich den Gutenprint-Treiber probiert und bei Windows 2000 wirklich allen Zugriff auf meinen Drucker gestattet.
    Es geht immer noch nicht.

    Kann es sein, dass es mit Win2K nicht funktioniert (nur mit WinXP)?

    Muss man einen speziellen Druckerport freigeben, den mein Router blockieren könnte? (Nur so ne Idee)

    Ich bekomme übrigens weiterhin ein Logon Failure.
     
  6. Pred

    Pred MacUser Mitglied

    Beiträge:
    1.477
    Zustimmungen:
    74
    MacUser seit:
    27.08.2005
    Hat bei mir auch nicht geklappt, aber andersherum geht es imo. Also Drucker am Mac, über Netzwerk in WinXP drucken.
     
  7. MrFX

    MrFX MacUser Mitglied

    Beiträge:
    7.352
    Zustimmungen:
    77
    MacUser seit:
    26.09.2003
    Moin!

    Hm, dann läuft irgendwas falsch bei dir... wie richtest du denn den Drucker unter OSX ein? Versuch doch mal, alles manuell einzugeben, etwa nach der hier beschriebenen Methode (also mit Login+Passwort):

    http://ifelix.co.uk/tech/3009.html

    Ist zwar für XP, aber die Mac-Einrichtung sollte identisch sein.

    Was für ein OSX hast du?

    Bei 10.4 ist die Einrichtung minimal anders.

    MfG
    MrFX
     
  8. elocin

    elocin Thread Starter MacUser Mitglied

    Beiträge:
    19
    Zustimmungen:
    0
    MacUser seit:
    13.11.2005
    @MrFx ich habe OS X 10.4.x. Die Anleitung habe ich genau befolgt, jedoch mit dem gleichen Ergebnis. :(

    Wenn ich den Drucker automatisch über das Einrichtungsprogramm auswähle, dann zeigt er mir als Pfad nur den Namen der Arbeitsgruppe an.
    Ich habe diesen in smb://guest@Computername/Druckername umgeändert, jedoch ohne Erfolg. Er kann sich immer noch nicht anmelden.
    Statt guest habe ich außerdem den Namen meines Ibooks, sowie den meines PCs gewählt - kein Erfolg.

    Stimmt der Pfad nicht? Wie finde ich die netzinterne IP-Adresse meines PCs raus? Vielleicht geht das eher als der Computername?
     
  9. MrFX

    MrFX MacUser Mitglied

    Beiträge:
    7.352
    Zustimmungen:
    77
    MacUser seit:
    26.09.2003
    Moin!

    Die solltest du sehen, wenn du auf dem Schreibtisch die Eigenschaften der Netzwerkumgebung aufrufst, dann die Ethernetverbindung anklickst und dort bei Eigenschaften nachschaust.

    Gib doch auch mal das Passwort mit an, also so:

    smb://user:password@IP_DES_WINDOWSRECHNERS/DRUCKERFREIGABE

    Evtl. geht es auch nicht, wenn du dich per Gast anmeldest...

    Ich denke mal, daß es nur ein Sicherheits-/Zugrifssbeschränkungsproblem von Windows ist.

    MfG
    MrFX
     
  10. elocin

    elocin Thread Starter MacUser Mitglied

    Beiträge:
    19
    Zustimmungen:
    0
    MacUser seit:
    13.11.2005
    Es geht!!! :D

    @MrFX: Danke für die Unterstützung. Es lag wohl wirklich an Windows.

    Ich habe einen neuen Hauptnutzer mit PW eingerichtet.
    Die Geräte-URL habe ich dann wie du beschrieben hast eingegeben. Das ging nur nicht mit dem Einrichtungstool vom Mac, da man dort nur den Ort eingeben konnte und nicht die URL.
    Mithilfe von http://localhost:631 konnte ich aber die Url korrigieren.

    Der Gutenprint-Treiber ist nicht so doll. Das Farbrad wird verschoben dargestellt. Aber Text scheint okay zu sein. Eben wie schon von ThoRic beschrieben.
     
Die Seite wird geladen...