Bind9, Debian 3.1 Sarge konfigurieren. Domainfactory, Hetzner

Diskutiere mit über: Bind9, Debian 3.1 Sarge konfigurieren. Domainfactory, Hetzner im Mac OS X Server, Serverdienste Forum

  1. sevY

    sevY Thread Starter Gast

    Hi zusammen,

    nachdem ich nun einige Tutorials durchgearbeitet habe und nicht weiter komme, frage ich euch…

    Ich habe ca. 160 Domains bei Domainfactory liegen, die später auf einen Hetzner Rootserver laufen sollen, auf dem ich sysCP zum Verwalten benutze.

    Die Domainfactory Nameserver lauten:

    ns.namespace4you.de.
    ns2.namespace4you.de.

    So habe ich dann mit meiner IP zusammen die default.zone angelegt:

    Code:
    $TTL 1W
    @ IN SOA ns root (
    2005040500 ; serial
    8H ; refresh
    2H ; retry
    1W ; expiry
    11h) ; minimum
    
    IN NS ns.namespace4you.de.    //Domainfactory 1st NS
    
    IN NS ns
    IN MX 10 mail
    
    IN A 213.239.xxx.xxx
    IN MX 10 mail
    
    * IN A 213.239.xxx.xxx
    IN  MX  10 mail
    
    ns IN A 213.239.xxx.xxx
    
    mail IN A 213.239.xxx.xxx
    IN MX 10 mail
    
    ergibt den Fehler: namedrndc: connect failed: connection refused

    In der named.conf steht:

    Code:
    /etc/bind/syscp_bind.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
    
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
    
    // From the release notes:
    //  Because many of our users are uncomfortable receiving undelegated answers
    //  from root or top level domains, other than a few for whom that behaviour
    //  has been trusted and expected for quite some length of time, we have now
    //  introduced the "root-delegations-only" feature which applies delegation-only
    //  logic to all top level domains, and to the root domain.  An exception list
    //  should be specified, including "MUSEUM" and "DE", and any other top level
    //  domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };
    
    allow-transfer {
          62.146.83.50;
    
     }
    include "/etc/bind/named.conf.local";
    
    In der named.conf.options steht:

    Code:
    options {
            directory "/var/cache/bind";
    
            // If there is a firewall between you and nameservers you want
            // to talk to, you might need to uncomment the query-source
            // directive below.  Previous versions of BIND always asked
            // questions using port 53, but BIND 8.1 and later use an unprivileged
            // port by default.
    
            // query-source address * port 53;
    
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
    
            // forwarders {
            //      0.0.0.0;
            // };
    
            auth-nxdomain no;    # conform to RFC1035
    
    };
    
    Und das in der named.conf.local…

    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    

    Was mache ich nun falsch?


    Viele Grüße

    Yves
     

Diese Seite empfehlen

Benutzerdefinierte Suche