Bin Ratlos: 96% CPU Aktivität

Dieses Thema im Forum "Mac OS X" wurde erstellt von greasy pete, 07.02.2005.

  1. greasy pete

    greasy pete Thread Starter MacUser Mitglied

    Beiträge:
    180
    Zustimmungen:
    0
    MacUser seit:
    23.01.2005
    Bei meinem 1 Woche alten G5, 1,8 single:

    Das System wird manchmal ohne Grund plötzlich sehr langsam. Ich habe in der Aktivitäts Anzeige dann überprüft: der Prozess "Finder" nutzt 96% der CPU, bleibt auch so oben, obwohl alle Programme beendet sind.

    Beende ich nun den Prozess "Finder" ist die CPU Aktivität wieder knapp über Null. Alles OK, kann weiter arbeiten. Bis plötzlich wieder der Effekt auftritt.

    Ich habe jetzt mal versucht herauszufinden wann dieser Effekt eintritt: Ich habe grosse Dateimengen von Jpg´s von meiner Externen Festplatte in eigene Ordner unter Bilder kopiert. Wenn ich nun als einziges geöffnetes Programm im Finder, einen dieser Ordner anwähle, steigt die CPU Auslastung auf 96% und bleibt so hängen, auch wenn ich zurückblättere oder alle Bilder in der Vorschau geladen sind. Solange bis ich den Prozess von Hand beende.

    Seltsam ist, dass es nur bei bestimmten Ordnern auftritt, die Anzahl und grösse der Bilder scheinen dies nicht zu beeinflussen, so passiert es beispielsweise bei einem grösseren Ordner nicht, CPU Auslastung 5% er lädt alle Bilder in die Finder Vorschau. Bei einigenm bestimmten auch kleineren Ordner dagegen passiert es wieder.

    Was passiert da? Was kann ich machen?

    Gruß Peter
     
  2. grabmeru

    grabmeru MacUser Mitglied

    Beiträge:
    590
    Zustimmungen:
    3
    MacUser seit:
    02.05.2003
    Möglicherweise ein Cache-Problem. Lies mal hier (weiß nicht, ob es noch stimmt - bezog sich auf 10.2):

    http://www.macosxhints.com/article.php?story=2003101415481414
     
  3. hertzchen

    hertzchen MacUser Mitglied

    Beiträge:
    1.993
    Zustimmungen:
    21
    MacUser seit:
    20.09.2004
    jipp - ich würd mal die finder prefernences löschen und neu booten

    >users>your account>library>prefernces> dort die datei com.apple.finder.plist
     
  4. greasy pete

    greasy pete Thread Starter MacUser Mitglied

    Beiträge:
    180
    Zustimmungen:
    0
    MacUser seit:
    23.01.2005
    Uii, es hat funktioniert !!
    Ich neige mein Haupt in Ehrfurcht :)

    Habe jetzt mal den Test gemacht und wie wild alle Bilder Ordner durchblättert, nix passiert!! Ist wieder alles in Ordnung.

    Kannst Du mir als Laien jetzt noch in verständlichen Worten erklären was da wie und warum passiert ist? kopfkratz

    Gruß Peter
     
  5. hertzchen

    hertzchen MacUser Mitglied

    Beiträge:
    1.993
    Zustimmungen:
    21
    MacUser seit:
    20.09.2004
    fein :)

    wie mein vorredner schon sagte, ist vermutlich im cache schiefgelaufen...

    cache ungefähr sowas wien gedächtnis - und ebenso wie in diesem funzt da nicht immer alles - cache merkt sich, wo die finder fenster sind, welche arbeitsläufe du bevorzugst, welche dateien häufig genutzt werden etc. das gedächtnis vom finder hast du gerade gelöscht und er hat es beim booten neu angelegt - will ja auch nicht blöd sterben son finder...

    frohes weiteres schaffen...

    ps. prefernces löschen - nur im notfall - hift bei macken dieser art oder wenn die fenster nicht stimmen odder das dock spinnt - symbole vertauscht etc. > aber nur wenn dummheit vom user ausgeschlossen anwenden...hehe

    ansonsten - frohes schaffen - ist auch nur ein mensch son mac :D
     
  6. greasy pete

    greasy pete Thread Starter MacUser Mitglied

    Beiträge:
    180
    Zustimmungen:
    0
    MacUser seit:
    23.01.2005
    Muss es nochmal sagen: Grosse DANKE, jetzt weiss ich wie ein Mac wirklich läuft. Möchte nicht wissen, wie of ich in den letzten Tagen ohne zu wissen diese hohe CPU Auslastung hatte und mich wunderte wie langsam der Mac doch ist :)


    Ist es möglich, dass ich darum die "Ruhezustandsprobleme" (Siehe PMG5 Forum) hatte, also der Rechner sich aufgehangen hat beim Versuch in den Ruhezustzand zu gehen, wärend Finder die CPU blockierte?

    Gruß Peter
     
  7. hertzchen

    hertzchen MacUser Mitglied

    Beiträge:
    1.993
    Zustimmungen:
    21
    MacUser seit:
    20.09.2004
    ich möcht dich mal sehen, wenn du mit 350 aktentaschen voll arbeit ins bettchen geschickt wirst und sollst die äuglein zu machen :D
     
  8. Luzz

    Luzz MacUser Mitglied

    Beiträge:
    704
    Zustimmungen:
    0
    MacUser seit:
    10.03.2003
    @hertzblau.net

    Auch von mir vielen Dank für den Tipp. War schon drauf und dran, Mac OS X neu aufzusetzen, um dieses Problem der Super-Auslastung des Finders, das übrigens erst seit dem Update auf 10.3.8 gestern auftrat, zu beheben. Jetzt habe ich wieder beruhigende 15 - 20 %. :D
     
  9. macmaniac_at

    macmaniac_at MacUser Mitglied

    Beiträge:
    3.586
    Zustimmungen:
    103
    MacUser seit:
    26.09.2004
    Zugriffsrechte reparieren kann u.U. da auch Abhilfe schaffen. Würde ich in jedem Fall zuerst probieren, da sonst alle Symbolleisteneinstellungen und Schriftgrößeneinstellungen verloren gehen, wenn die plist gelöscht wird.

    Bei mir trat früher 10.3.5-7 das Problem beim Aktivieren der Objektinfos auf.

    Das System muß aber ned neu gestartet werden, nur weil man die plist gelöscht hat. Den Finder neu zu starten reicht auch aus ;)
     
  10. GigoloArt

    GigoloArt MacUser Mitglied

    Beiträge:
    309
    Zustimmungen:
    0
    MacUser seit:
    21.01.2003
    Unglaublich! Ich hatte das Problem auch, so bald 10.3.8 hochgefahren war, war die CPU-Auslastung bei 100%. Ohne Anwendung etc ..

    Dann habe ich deinen Ratschlag befolgt und alles war wieder ok!

    Danke! Wollte schon fast neuinstallieren, nachdem "Finder neustarten" schon nicht geklappt hat.
     
Die Seite wird geladen...

Diese Seite empfehlen