Benutzer spurlos verschwunden !!!

Diskutiere mit über: Benutzer spurlos verschwunden !!! im Mac OS X Forum

  1. Katheta

    Katheta Thread Starter MacUser Mitglied

    Beiträge:
    171
    Zustimmungen:
    0
    Registriert seit:
    23.08.2003
    so jetzt wird komisch.
    Ich habe auf meinem MacBookPro bis gestern prima und glücklich gearbeitet.
    Nachdem allerdings dem guten Stück der Saft ausgegangen ist, und ich nach einem Neustart mittels BootCamp in Windows gearbeitet habe, tritt nun folgendes Problem auf.....

    Wenn ich OSX wieder starten will, kommt der Anmeldescreen (den ich nie aktiviert habe) und ich tippe brav meinen Namen und Passwort ein.
    Aber OSX sacht: NEIN - falsch - Nein - nein.

    Schade dachte ich mir - dann startest du mal von CD (bzw. DVD) und überprüfst alle Rechte etc. und setzt das Passwort einfach wieder zurück. Wird schon klappen.

    Pustekuchen - Wenn ich das Passwort zurück setzten will, kann ich in der üblichen Liste nicht einen einzigen Benutzer sehen - werder admin noch meine Wenigkeit. Alle wech ?!

    Hat jemand eine Idee wie ich mich wieder ganz normal auf meinem System anmelden kann ?!


    Besten Dank

    K.
     
  2. xr2-worldtown

    xr2-worldtown MacUser Mitglied

    Beiträge:
    3.362
    Zustimmungen:
    131
    Registriert seit:
    29.12.2005
    Start mal von CD und öffne das Festplattendienstprogramm. Dort kannst du dann die Rechte reparieren lassen. Wenn du Glück hast, bringt es was. ;)
     
  3. Katheta

    Katheta Thread Starter MacUser Mitglied

    Beiträge:
    171
    Zustimmungen:
    0
    Registriert seit:
    23.08.2003
    Naja - das hab ich ja geschrieben, dass ich genau das schon gemacht habe. Hat gar nix gebracht :-(
     
  4. xr2-worldtown

    xr2-worldtown MacUser Mitglied

    Beiträge:
    3.362
    Zustimmungen:
    131
    Registriert seit:
    29.12.2005
    Sorry, das hab ich wohl überlesen. :(
     
  5. Gerundium

    Gerundium MacUser Mitglied

    Beiträge:
    1.997
    Zustimmungen:
    69
    Registriert seit:
    22.10.2005
    Die Benutzer sind mit Sicherheit noch da. Es hat den Anschein, als wäre deine NetInfo-Datenbank defekt. Mir ist nicht bekannt, wie man die Datenbank reparieren kann. Dennoch lässt sich das Problem lösen. Die Frage ist: Wie sehr bist du dem Terminal zugetan?

    Auf jeden Fall ist ein Backup deiner Daten sinnvoll. Dazu schließt du dein Book mittels Target-Disk-Modus an einen anderen Mac an und sicherst dann die Daten auf den diesen Mac. So präpariert laufen alle folgenden Aktionen ungenierter.
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Wenn man ein funktionsfähiges Backup der Netinfo Datenbank hat, kann man si im Single User Modus reparieren (bzw. zurücksichern).
    Mit den periodic Jobs wird die Netinfo Datenbank täglich gesichert (alte Backups werden dabei überschrieben).

    Das Backup befindet sich in der Datei "/var/backups/local.nidump".
    Es empfielt sich, ein Kopie dieser Datei an einen anderen Ort zu verschieben, um das tägliche Überschreiben zu verhindern.

    Du könntest nun in den SU-Modus booten und nachsehen, ob Du ein solches Backup hast und wie alt es ist (hoffentlich nicht mit der defekten Datenbank bereits überschrieben).
     
  7. design11

    design11 MacUser Mitglied

    Beiträge:
    1.123
    Zustimmungen:
    48
    Registriert seit:
    09.01.2005
    Danke für den wertvollen Tip!!
    Wo finde ich die betreffende Datei? Über Ablage>Suche bin ich unter keinem der Worte fündig geworden. Oder erst ab Tiger (habe 10.3.9) ?
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Das war auch unter 10.3 und früher schon so.

    Die Datei ist allerdings nur für root lesbar.
    Mir ist nicht ganz klar, wie Du nach "Ablage > Suche" kommst, wenn Du Dich nicht anmelden kannst.

    Wenn Du in den Single User Modus bootest, kannst Du folgendes eingeben, um zu sehen, ob ein backup da ist und wie alt es ist.
    Code:
    ls -la /var/backups/local.nidump
    HTH
     
  9. Katheta

    Katheta Thread Starter MacUser Mitglied

    Beiträge:
    171
    Zustimmungen:
    0
    Registriert seit:
    23.08.2003
    Ok das Backup ist da - und das ganze Ding ist vom 28.06.06.
    Also alt genung um noch zu funktionieren - wie bekomme ich es denn nu zurück gesichert !?
     
  10. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Hier gibt es eine ältere Anleitung.
    Den Schritt Nummer 8 musst Du ersetzen durch das Kommando
    Code:
    sh /etc/rc
    Vierl Erfolg!
     
Die Seite wird geladen...

Diese Seite empfehlen

Benutzerdefinierte Suche