Autovervollständigung bei Excel

Diskutiere mit über: Autovervollständigung bei Excel im Office Software Forum

  1. McMuhaus

    McMuhaus Thread Starter MacUser Mitglied

    Beiträge:
    556
    Zustimmungen:
    16
    Registriert seit:
    22.12.2003
    Wie kann ich es bei Excel erreichen, dass Excel, wenn ich z.B. E13 schreibe, automatisch die Namen die mit der Nummer verbunden sind angezeigt werden?
    Es ist etwas schwierig zu erklären. Aber kann man nicht irgendwo eingeben, dass Excel mit bestimmten Nummern oder Zeichenfolgen, bestimmte Namen verbindet, dass wenn man die Nummer schreibt, die Namen eingefügt werden.
    Geht das?

    Gruß
     
  2. mackay

    mackay MacUser Mitglied

    Beiträge:
    2.436
    Zustimmungen:
    7
    Registriert seit:
    05.01.2003
    Moin
    du kannst so etwas über AutoKorrektur anlegen :)

    aber ob das der eleganteste Weg ist, weiß ich nicht :D

    Kay ;)
     
  3. Jabba

    Jabba MacUser Mitglied

    Beiträge:
    4.465
    Zustimmungen:
    109
    Registriert seit:
    21.11.2003
    Hallo, ääh, Du! (den Nick lass ich mal, das kannst Du mit Deinem Busenkumpel Lynni ausmachen... :D)

    Du meinst Auto-Ersetzen. Willst Du z.B. in Zelle A1 den Wert "E13" eingeben und dieser soll dann in derselben Zelle A1 durch den Namen X ersetzt werden?
    Schwierig.
    a. VBA Makro
    b. mackays Lösung, ist aber sehr umständlich, und führt bei vielen Ersetzungen zwangsweisen zu unerwünschten Erstzungen innerhalb anderer Begriffe.

    Vorschlag:
    Arbeite mit einer Hilfs-Spalte.
    A1 die Eingabe "E13" und in A2 steht das Ergebnis.
    Wie:
    Du benutzt in der Zelle A2 die Formel SVERWEIS, die zeigt Dir den "E13" entprechenden Namen an.
    Bedingung:
    Du MUSST einmal eine Tabelle mit allen Entsprechungen anlegen!

    Bsp:
    Schreibe mal in eine neue, leere Tabelle:
    A1 erst mal leerlassen!
    A2 reinschreiben: =SVERWEIS(A1;F1:G10;2; )
    (du erhälst eine Fehlermeldung, ok!)
    F1 reinschreiben: E13
    G1 reinschreiben: SWORDFISH

    Dann tippe in A1 E13 ein, und oh Wunder, in A2 steht die Lösung.
    Das sollte als Ansatz genügen, es ist viel einfacher als es aussieht!

    HTH
     
  4. mackay

    mackay MacUser Mitglied

    Beiträge:
    2.436
    Zustimmungen:
    7
    Registriert seit:
    05.01.2003
    @th3sw0rdf!$h

    der von Jabba vorgeschlagene SVerweis ist die eleganteste Lösung :)

    damit kannst du ganze Adress-Felder ausfüllen lassen.

    Am besten wäre du versuchst zu schildern was passieren soll, wenn du E13 eingibts.

    Kay ;)
     
Die Seite wird geladen...
Ähnliche Themen - Autovervollständigung bei Excel Forum Datum
FehlerMelung bei OpenOffice Office Software Donnerstag um 09:06 Uhr
Blaue Linie bei Pages und Seitenränder. Wie verschieben? Office Software 12.11.2016
Runden bei Numbers Office Software 05.11.2016
Standardpfad für Excel bei Speichern unter ändern Office Software 03.10.2016
Datum bei numbers Office Software 27.08.2016

Diese Seite empfehlen

Benutzerdefinierte Suche