apt-get ohne internet

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von pfannkuchen2001, 06.01.2007.

  1. pfannkuchen2001

    pfannkuchen2001 Thread Starter MacUser Mitglied

    Beiträge:
    2.410
    Zustimmungen:
    37
    MacUser seit:
    17.02.2006
    Hallo,
    ich habe mir grad ubuntu installiert, und möchte nun ein progamm installieren (wifi-manager oder so) und brauch dazu aber internet. um ins netz zu kommen, muss ich das progrmm aber installieren.

    also kann ich das nicht auch irgendwie von einem anderen rechner auf einen USB-Stick packen, und dann über den umweg auf der linux-kiste installieren?

    - wenn ja, wo find ich das? also das programm?

    Hannes
     
  2. BounceReloaded

    BounceReloaded MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    MacUser seit:
    16.05.2006
  3. IceCold

    IceCold Gast

    Das Installieren von *.deb Paketen ohne Internet funktioniert mit

    Code:
    dpkg -i [i]Paketname[/i].deb
    Zu beachten ist dabei, dass es sich um die richtige Plattform handelt (ppc).
    Und es funktioniert nur, solange das Programm keine anderen Pakete benötigt, die noch nicht installiert sind. Sollten zusätzliche Pakete benötigt werden, musst du diese ebenfalls manuell downloaden, und sie auf die selbe Art installieren.
     
  4. pfannkuchen2001

    pfannkuchen2001 Thread Starter MacUser Mitglied

    Beiträge:
    2.410
    Zustimmungen:
    37
    MacUser seit:
    17.02.2006
    super danke.

    nun hab ich aber grad noch ein problem festgestellt. ich habe per ndiswrapper meinen DWL-122 Wlan stick installiert. das hat auch geklappt. leider wird der stick immer erst erkannt, wenn ich ihn rausziehe, und dann wieder reinstecke. Warum wird der stick nicht beim booten erkannt? was muss ich tun, damit er das macht?

    Hannes
     
  5. BounceReloaded

    BounceReloaded MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    MacUser seit:
    16.05.2006
    Hallo,

    schau Dir mal die Datei /etc/network/interfaces an.
    Da kann man einstellen ob die Netzwerkschnittstelle beim Booten gestartet wird ( indem man auto vor die Bezeichnung z.B. eth0 oder ath0 usw. schreibt ).

    Außerdem kann man da auch verschieden Parameter wie feste IP, ESSID usw. mitgeben.

    Ich weiß aber nicht ob Ubuntu für diese Einstellungen auch eine grafische Oberfläche anbietet.

    Ich habe bisher immer meine Einstellungen für die Netzwerkarte über diese Datei gemacht und das hat immer geklappt ( benutze allerdings Debian ).

    Falls das nicht funktioniert, kannst Du über das Terminal mit dem Befehl "lsmod" ohne Anführungszeichen sehen welche Module geladen sind, dann den USB-Stick einstecken und nochmal "lsmod" eingeben.
    Jetzt sollte mindestens ein neuer Eintrag vorhanden sein und diesen kannst Du dann in die Datei /etc/modules eintragen und so das Laden von bestimmten Modulen zum Systemstart manuell anstoßen.


    Markus
     
  6. pfannkuchen2001

    pfannkuchen2001 Thread Starter MacUser Mitglied

    Beiträge:
    2.410
    Zustimmungen:
    37
    MacUser seit:
    17.02.2006
    hmm aus irgendeinem Grund macht er das jetzt doch. wer wird erkannt!
    aber da ist schon mein nächstes Problem: wer will keine verbindung zu meinem Router herstellen (WPA/WPA2)!
    Ich will das eigendlich mit hilfe von wpa_supplicant machen.
    also hier meine wpa_supplicant.conf:
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    eapol_version=1
    ap_scan=2
    network={
            ssid=":D"
            scan_ssid=1
            proto=RSN
            key_mgmt=WPA-PSK
            pairwise=CCMP
            group=TKIP CCMP
    	psk="2Y4sgQNMtm8VRqs6gRDB5q4XoCM8XdZK7wa2VtXBEHe4JxdT4TSNxax6Ez8bWNq"
    }

    sollte dich eigendlich richtig sein?! wenn ich nun versuchen will ob es klappt, dann wartet mir der terminal mit folgendem auf:
    Code:
    froelich@ubuntudesktop:~$ sudo wpa_supplicant -iwlan0 -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf -d
    Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
    Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    eapol_version=1
    ap_scan=2
    Priority group 0
       id=0 ssid=':D'
    Initializing interface (2) 'wlan0'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    SIOCGIWRANGE: WE(compiled)=20 WE(source)=18 enc_capa=0x5
      capabilities: key_mgmt 0x5 enc 0x7
    WEXT: Operstate: linkmode=1, operstate=5
    Own MAC address: 00:0d:88:fa:db:7f
    wpa_driver_wext_set_wpa
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_countermeasures
    wpa_driver_wext_set_drop_unencrypted
    Setting scan request: 0 sec 100000 usec
    Added interface wlan0
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    State: DISCONNECTED -> SCANNING
    Trying to associate with SSID ':D'
    Cancelling scan request
    WPA: clearing own WPA/RSN IE
    Automatic auth_alg selection: 0x1
    WPA: No WPA/RSN IE available from association info
    WPA: Set cipher suites based on configuration
    WPA: Selected cipher suites: group 24 pairwise 16 key_mgmt 2
    WPA: clearing AP WPA IE
    WPA: clearing AP RSN IE
    WPA: using GTK CCMP
    WPA: using PTK CCMP
    WPA: using KEY_MGMT WPA-PSK
    WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 04 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
    No keys have been configured - skip key clearing
    wpa_driver_wext_set_drop_unencrypted
    State: SCANNING -> ASSOCIATING
    WEXT: Operstate: linkmode=-1, operstate=5
    wpa_driver_wext_associate
    Setting authentication timeout: 60 sec 0 usec
    EAPOL: External notification - EAP success=0
    EAPOL: External notification - EAP fail=0
    EAPOL: External notification - portControl=Auto
    Wireless event: cmd=0x8b06 len=8
    Wireless event: cmd=0x8b1a len=10
    CTRL-EVENT-TERMINATING - signal 2 received
    Removing interface wlan0
    State: ASSOCIATING -> DISCONNECTED
    WEXT: Operstate: linkmode=-1, operstate=5
    No keys have been configured - skip key clearing
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    wpa_driver_wext_set_wpa
    wpa_driver_wext_set_drop_unencrypted
    wpa_driver_wext_set_countermeasures
    No keys have been configured - skip key clearing
    WEXT: Operstate: linkmode=0, operstate=6
    Cancelling scan request
    froelich@ubuntudesktop:~$ 
    
    was ist da falsch?
    ich habe auch schon verschiedene treiber eingetragen, aber irgendwie kommt es immer aufs gleiche hinaus.

    vielleicht ist es ganz nützlich: iwconfig
    Code:
    froelich@ubuntudesktop:~$ iwconfig
    lo        no wireless extensions.
    
    eth1      no wireless extensions.
    
    wlan0     IEEE 802.11b  ESSID:":D"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
              Bit Rate:11 Mb/s   
              Power Management min timeout:0us  mode:All packets received
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    sit0      no wireless extensions.
    
    froelich@ubuntudesktop:~$ 
    
    meine ifconfig hat komischerweise nix was anch wlan aussieht - is das normal?
    Code:
    froelich@ubuntudesktop:~$ ifconfig
    eth1      Protokoll:Ethernet  Hardware Adresse 00:0B:6A:1B:E5:FE  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              Kollisionen:0 Sendewarteschlangenlänge:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:201 Basisadresse:0xd400 
    
    lo        Protokoll:Lokale Schleife  
              inet Adresse:127.0.0.1  Maske:255.0.0.0
              inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:98 errors:0 dropped:0 overruns:0 frame:0
              TX packets:98 errors:0 dropped:0 overruns:0 carrier:0
              Kollisionen:0 Sendewarteschlangenlänge:0 
              RX bytes:7620 (7.4 KiB)  TX bytes:7620 (7.4 KiB)
    
    froelich@ubuntudesktop:~$ 
    
    noch das was ndiswrapper ausspuckt:
    Code:
    froelich@ubuntudesktop:~$ ndiswrapper -l
    Installed drivers:
    netprism                driver installed, hardware present 
    froelich@ubuntudesktop:~$ 
    und noch fix die ausgabe von iwlist:
    Code:
    froelich@ubuntudesktop:~$ iwlist wlan0 scanning
    wlan0     Scan completed :
              Cell 01 - Address: 00:12:BF:C9:D9:AA
                        ESSID:":D"
                        Protocol:IEEE 802.11b
                        Mode:Managed
                        Frequency:2.427 GHz (Channel 4)
                        Quality:0/100  Signal level:-59 dBm  Noise level:-256 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP 
                            Pairwise Ciphers (2) : TKIP CCMP 
                            Authentication Suites (1) : PSK  
                           Preauthentication Supported
                        IE: WPA Version 1
                            Group Cipher : TKIP 
                            Pairwise Ciphers (2) : TKIP CCMP 
                            Authentication Suites (1) : PSK  
    
    froelich@ubuntudesktop:~$ 
    

    eigendlich müsste doch alles stimmen? --> ich hab aber auch nicht wirklich ahnung von linux... :D

    also was muss ich machen, damit es klappt?
     
  7. IceCold

    IceCold Gast

    Gib mal
    Code:
    ifconfig -a
    ein. Dann listet er dir alle Netzwerk Komponenten auf, auch die, die deaktiviert sind.

    Leider kenn ich mich mit WLAN unter Linux nicht aus.
     
Die Seite wird geladen...

Diese Seite empfehlen