Alias auf sparseimage?

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Dethix, 26.03.2007.

  1. Dethix

    Dethix Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    08.09.2005
    Hi zusammen,

    ich versuche schon den ganzen abend folgendes zum laufen zu bringen:

    Apache ist eingerichtet und läuft. nun habe ich in der httpd.conf einen alias eingetragen.

    Alias /projekt/ "/Volumes/projekte/projektname/"

    Die files liegen in einem sparseimage das ich gemountet habe. über terminal und den finder kann ich auch per "/Volumes/projekte/projektname/" darauf zugreifen. vom Apache bekomme ich nur "Forbidden You don't have permission to access /projekt/ on this server." Nun vermute ich mal da der apache unter nem anderen user ausgeführt wird das dieser nicht auf das sparseimage zugreifen darf.
    nur ist es überhaupt möglich das der darauf zugreift und wenn ja wie?

    Gruß
    Dethix
     
  2. Dethix

    Dethix Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    08.09.2005
    hmm hat keiner ne idee? ich weiss nicht ob das hier überhaupt die passende kategorie dafür ist....wenn jemand eine bessere kennt bitte verschieben :)
     
  3. moses_78

    moses_78 MacUser Mitglied

    Beiträge:
    1.322
    Zustimmungen:
    22
    MacUser seit:
    08.04.2005
    Du könntest mehr Details rausrücken. Tipp mal
    tail -f /var/log/httpd/error_log
    ins Terminal ein, und probier noch einmal, auf
    die Seite zuzugreifen. Wenn es neue Einträge
    im Errorlog gibt, poste sie.

    Ansonsten, ein kleiner Schuss ins Blaue:
    Füge der httpd.conf ein
    <Directory "/Volumes/projekte/projektname/">
    Order allow,deny
    Allow from all
    </Directory>

    Btw. Kenne ich dich von Rubyforen.de?
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.829
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    guck dir doch mal die zugriffsrechte in der information an...
    gemountete images kriegen wohl per default keine rechte für andere...
    da musst du zumindest mal das lese-recht anschalten...
     
  5. Dethix

    Dethix Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    08.09.2005
    Also beim gemouteten image das lese recht bei "andere" anschalten hatte ich auch schon probiert, hat aber leider nichts gebracht.

    im Log gibt er mit "Permission denied: access to /projekte/ failed because search permissions are missing on a component of the path" aus.

    <Directory "/Volumes/projekte/projektname/">
    Order allow,deny
    Allow from all
    </Directory>
    habe ich bereits in meiner httpd.conf stehen.

    Und ja man kann mich durchaus von rubyforen.de kennen :) die welt ist klein ;)
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Apache läuft unter dem Benutzer www.
    Wenn der Webserver Dateien aus einem bestimmten Verzeichnis ausliefern soll, muss der Benutzer www die Datiene und den gesamten Verzeichnispfad lesen dürfen - und zwar zunächst einmal auf Dateisystemebene.
     
  7. Dethix

    Dethix Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    08.09.2005
    Das ist mir schon klar, nur wie erreiche ich das? schließlich habe ich doch schon leserechte für jedermann eingerichtet ?!?!
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    mach mal folgendes und poste die Ausgabe
    Code:
    zsh
    ls -l /Volumes/projekte/projektname/**/*
     
  9. Dethix

    Dethix Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    08.09.2005
    hmm also aufgrund der größe des Projekts liste ich mal lieber nicht hier alle 1000 Einträge auf ;)

    Bei den meisten files sieht es von der Berechtigung aber so aus:
    -rw----r-- 1 Dethix Dethix

    einzelne unterverzeichnisse haben auch das hier:
    drwx---r-x 19 Dethix Dethix
     
  10. moses_78

    moses_78 MacUser Mitglied

    Beiträge:
    1.322
    Zustimmungen:
    22
    MacUser seit:
    08.04.2005
    Du kannst Benutzerrechte bei Volumes deaktivieren. Dazu gibt
    es irgendeine Option in dem "Informationen"-Dialog im Finder,
    die "Benutzerrechte ignorieren" oder so heisst. Danach musst
    du das Volume natührlich neu mounten.

    Oder, du änderst die Nutzerrechte der Dateien, mit chmod -R o+r
    /Pfad/Zum/Ordner.
     
Die Seite wird geladen...
Ähnliche Themen - Alias auf sparseimage
  1. Rothlicht
    Antworten:
    5
    Aufrufe:
    471
    wegus
    02.12.2015
  2. Akeno
    Antworten:
    5
    Aufrufe:
    1.189
    Akeno
    12.09.2014
  3. macboehni
    Antworten:
    2
    Aufrufe:
    933
    macboehni
    24.01.2014
  4. Lior
    Antworten:
    3
    Aufrufe:
    497
    scope
    08.11.2012
  5. Labrar
    Antworten:
    6
    Aufrufe:
    654
    Labrar
    23.10.2012