AFP nur als Gast nach verhängnisvollem Klick

Dieses Thema im Forum "Mac OS X" wurde erstellt von KaoT, 24.01.2007.

  1. KaoT

    KaoT Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Moin,

    alleine schon einen aussagekräftigen Titel für mein Problem zu finden ist schwierig. Die Situation zu beschreiben geradezu delikat. :)

    User Systemversion ist 10.3.9. - feste IP - eingeloggt als Admin

    Die Situation: Die Verbindung zu einem AFP Server ist nur noch als Gast möglich, da alle weiteren Optionen (bis auf "Abbrechen" und "Verbinden") ausgegraut sind.

    Vorgehensweise um die Situation nachzuspielen (auf eigene Gefahr):

    - CMD + K im Finder
    - IP Adresse eines AFP Servers eingeben (dem man als Registrierter Benutzer bekannt ist)
    - Klick auf Verbinden
    - Im folgenden Dialog links unten auf Optionen...
    - Kennwort im Klartext übertragen ausklicken
    - OK
    - Ganz normal als Registrierter Benutzer mit Name und Kennwort mit dem File Server verbinden
    - Volume im Finder entmounten
    - Nun wieder Schritt 1-3 (CMD + K etc...)
    !! Ab jetzt ist bei mir im Verbinden-Dialog Gast als default ausgewählt, alles andere deaktiv (Grau, nicht klickbar) - ausgenommen "Abbrechen" und "Verbinden".

    Bisher versucht:
    Rechte reparieren -> Keine Besserung
    Von System-DVD booten -> Rechte reparieren -> Keine Besserung
    PRAM und NVRAM zurückgesetzt -> Keine Besserung
    Caches geleert -> Keine Besserung

    Neuen AdminUser angelegt -> Kann ganz normal per AFP konnektieren
    Ok, es ist also ein User- und kein Systemproblem.
    Fehlerherleitung beim neuen User vollführt. -> Funktioniert leider wie beschrieben.
    Sofort danach mit der Suche nach allen heute geänderten Dateien auf allen lokalen Volumes gesucht. Alles gelöscht was innerhalb der letzten Minute angelegt oder verändert wurde -> Das waren ausschließlich Dateien auf User Ebene und da in der Library.
    Z.B.: Recent Servers (Folder mit Inhalt), div. plists, etc... -> Keine Besserung.
    Aus-/Einloggen, neustart. -> Keine Besserung.

    Wo merkt sich OS X diese verdammte Einstellung???

    Für eure Hilfe wäre ich sehr dankbar.

    cu
    KaoT
     
  2. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Gute Frage.
    Da ich auf meinen Rechnern produktiv arbeite, werd ich das jetzt nicht ausprobieren.
    Würde mich aber schon interessieren, ob das reproduzierbar ist.
     
  3. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo KaoT,

    Bei 10.3.9 müsste es com.apple.AppleShareClientCore.plist in /Users/username/Library/Preferences sein.

    Edit: Habe noch mal nachgesehen - ab 10.2 ist es in /Users/username/Library/Preferences/.GlobalPreferences.plist unter com.apple.AppleShareClientCore gespeichert

    Möglicherweise löst sich das Problem nicht wenn man diese Datei löscht. Dann versuche Folgendes:

    Leg wieder einen neuen User an. Melde Dich am Server an und lass das mit den Optionen und kopiere dann diese Datei in den fehlerhaften Account an selbe Stelle und lass das eventuell fehlerhaft neu angelegte File überschreiben.

    Gruß Andi
     
    Zuletzt bearbeitet: 25.01.2007
  4. KaoT

    KaoT Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Success!!!!

    Hi Andi,

    vielen Dank für deinen Tip. Funktioniert.

    Hinzuzufügen wäre, dass die Datei unsichtbar ist (was man am "." davor erkennen kann). Wer sich also mit dem Terminal nicht so auskennt sollte das alles in der GUI abfrühstücken.

    Um hier mit unsichtbaren Dateien hantieren zu können, muss ins Terminal "defaults write com.apple.finder AppleShowAllFiles 1" eingegeben werden, danach einmal den Finder neustarten. Dies macht man ohne weitere Terminalkommandos durch ein Aus und Wiedereinloggen des Users.

    Rückgängig macht man es, indem man die 1 im Befehl durch eine 0 ersetzt. Der Rest bleibt wie gehabt (aus ein loggen etc...)

    Danke nochmal.

    cu
    KaoT
     
  5. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.842
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo KaoT,

    was mich noch interessieren würde ist ob Du die Datei jetzt austauschen musstest oder ob das Löschen ausgereicht hätte und was für ein AFP-Server das war.

    Der Bug scheint wohl alle Versionen von OS X zu betreffen - wobei ich es jetzt bei 10.4 nicht versucht habe.

    Gruß Andi
     
  6. KaoT

    KaoT Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    1
    MacUser seit:
    21.06.2004
    Hi, gerade nochmal versucht: Löschen reicht. Allerdings ist das natürlich auch ne radikale Methode. Evtl. reicht es ja, den Eintrag für AppleShare in der globalPreferences zu löschen. Was nämlich da noch so drinne steht weiss ich nicht. Bei einem neuangelegten Testuser natürlich sehr wenig, aber auf meinem laufenden Produktivsystem hühner ich ungern so "tief" im System rum.
    Der Server ist ein Linuxsystem, wahrscheinlich RedHat, mit netatalk installiert.

    Danke nochmals.

    cu
    KaoT
     
Die Seite wird geladen...

Diese Seite empfehlen