Zugriffsrechte auf freigegebene Ordner

  1. didch

    didch Thread Starter MacUser Mitglied

    Mitglied seit:
    15.12.2004
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo
    Ich Brauche mal eure Hilfe,
    Und zwar habe ich auf den OSX 10.3 Server (G4dp)
    einen Ordner mit vielen Unterordner von einem OS9 rechner kopiert und für das Netzwerk freigegeben mit Eigentümer und Gruppe.
    Jeweils im Finder als auch im Arbeitsgruppen Manager unter Zugriff.
    Nun kann ich aber keine Dateien in die unterordner schreiben von einem Client aus. Gibt es da was ich noch machen muß?
     
    didch, 03.01.2005
    #1
  2. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Die Benutzer müssen Schreibrecht auf die Ordner haben, in denen Sie Dateien anlegen sollen.

    HTH
     
    maceis, 03.01.2005
    #2
  3. didch

    didch Thread Starter MacUser Mitglied

    Mitglied seit:
    15.12.2004
    Beiträge:
    8
    Zustimmungen:
    0
    Das habe ich doch auch so eingestellt: Gruppe hat Schreib und Leserecht. Doch irgendwie scheint es bei den Unterordnern nicht anzunehmen. Egal wie ich es anstell. Bei neu angelegten ordnern gehts und bei dem übergeordneten auch
     
    didch, 04.01.2005
    #3
  4. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Dann wirst Du halt die Unterordner "von Hand" ändern müssen.
    "chmod -R" ändert die Rechte übrigens rekursiv durch alle Unterverzeichnisse.
    Oder Du benutzt eine geeignete Gruppe (je nach Deinen speziellen Anforderungen)
     
    maceis, 04.01.2005
    #4
  5. bassermann

    bassermann

    vertippt: der befehl heißt: chmod -R

    oder nicht?
     
    bassermann, 05.01.2005
    #5
  6. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    ja richtig, war ein Tippfehler
    - Danke für den Hinweis
     
    maceis, 05.01.2005
    #6
  7. ovski

    ovski MacUser Mitglied

    Mitglied seit:
    16.04.2004
    Beiträge:
    150
    Zustimmungen:
    3
    die rechte werden z.t. vom admin-interface nicht sauber übertragen, das stimmt.

    da du nichts mehr gepostet hast, denke ich das der chmod -R befehl funktioniert hat. zum testen würd ich sogar nen chmod -R 777 * machen um ganz sicher nichts und niemanden auszuschliessen.

    danach musst du das verhalten der rechte-vererbung überprüfen und die rechte entsprechend vom übergeordneten objekt übernehmen lassen. kannst du beim Arbeitsgruppenmanager über den zugriff definieren. wird übrigens für windows und mac clients unterschieden. bei win-clients kannst du sogar individuelle rechte für jedes verzeichnis einstellen.

    greez
    ovski
     
    ovski, 11.01.2005
    #7
  8. didch

    didch Thread Starter MacUser Mitglied

    Mitglied seit:
    15.12.2004
    Beiträge:
    8
    Zustimmungen:
    0
    Hi
    habe es immer noch nicht geschafft die Zugriffsrechte richtig einzustellen.
    Ich muß auch zugeben das ich mit dem chmod -R Befehl nichts Anfangen.
    Ich vermute das es daran liegt das ich diesen Hotfolder von einem 9er System kopiert habe und der Ordner sich anders verhällt als ein neu erstellter.
     
    didch, 11.01.2005
    #8
  9. ovski

    ovski MacUser Mitglied

    Mitglied seit:
    16.04.2004
    Beiträge:
    150
    Zustimmungen:
    3
    nun eigentlich müsste der ordnern als ganz normal zu managen sein.
    zur sicherheit kannst du aber einen neuen ordner erstellen und die daten dort rein ziehen.

    der chmod befehl funktioniert wie folgt:
    chmod modifziert die zugriffsrechte
    -R bezieht die Unterverzeichnisse mit ein

    dezimale aufschlüsselung der rechte:
    4 definiert leserechte
    2 definiert schreibrechte
    1 definiert ausführ oder öffnenrechte (öffnen von ordnern)

    in kombination bedeutet das also: z.B. 5 -> lesen und ausführen, 3 schreiben und ausführen, 6 lesen und schreiben etc.

    den befehl wendest du in der shell ein verzeichnis über dem zielordner an.

    z.B. für den ordner in /Users/user1/data wie folgt:
    cd /Users/user1
    chmod -R 777 data

    alles klar soweit?
    check: "man chmod" für mehr infos

    dabei ist wichtig das du admin bzw. root rechte hast. dazu hängst du vor den chmod befehl ein sudo
    sudo chmod -R 777 data

    dazu muss aber der root-user im netinfomanager aktiviert worden sein. diesen findest dzu in den utilities. dürfte nicht allzuschwer sein. du findest den eintrag in einem der menüs oben.

    danach prüfst du alle einträge für den freigegeben ordner. du musst die rechte vom umgebenen objekt übernehmen, sonst klappt das nie.

    noch fragen? ;)
     
    ovski, 11.01.2005
    #9
  10. tom71

    tom71 MacUser Mitglied

    Mitglied seit:
    19.03.2004
    Beiträge:
    203
    Zustimmungen:
    0
    Arbeitsgruppen-Manager.

    Ich denke, da gibt es eine Option "Zugriffsrechte des übergeordneten Ordners übernehmen" oder so ähnlich. Versuchs mal damit...
     
    tom71, 11.01.2005
    #10
Die Seite wird geladen...
Ähnliche Themen - Zugriffsrechte auf freigegebene
  1. i7MacUser
    Antworten:
    1
    Aufrufe:
    241
    i7MacUser
    01.05.2017
  2. gernhart
    Antworten:
    6
    Aufrufe:
    369
  3. mds
    Antworten:
    4
    Aufrufe:
    254
  4. Moe
    Antworten:
    4
    Aufrufe:
    488
    TommiWe
    22.01.2017
  5. mac_bullitt
    Antworten:
    2
    Aufrufe:
    1.295
    ttroller
    29.01.2009