Zertifikat in Mail importieren geht nicht

Dieses Thema im Forum "Mac OS Software" wurde erstellt von revo, 09.09.2004.

  1. revo

    revo Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    Mitglied seit:
    09.09.2004
    ... oder zumindest verstehe ich nicht, wie es gehen soll. Wenn ich so vorgehe, wie in der Hilfe beschrieben (Zertifikat anschauen, es auf den Schreibtisch ziehen, Doppelklick), öffnet es sich zwar, aber das Menü, von dem die Mail-Hilfe spricht, bekomme ich nicht, Was mache ich falsch?

    Danke,
    revo
     
  2. revo

    revo Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    Mitglied seit:
    09.09.2004
    Hm, nein, da habe ich meine Frage wohl missverständlich formuliert...
    Also: Ich rufe von einem Server meiner Uni per pop3 meine mails ab. Leider stoppt Mail jedesmal und sagt, die Identität konnte nicht festgestellt werden (die des Uni-Servers). Mir wird, wenn ich "Zertifikat anzeigen" anklicke, auch das Zertifikatssymbol angezeigt. Nur: wie kann ich dieses nun so importieren, dass Mail den Server akzeptiert?

    revo
     
  3. revo

    revo Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    Mitglied seit:
    09.09.2004
    kann mir da jemand helfen? ist das erste mal, dass ich mit 'nem mac arbeite, also brauch' ich noch eingewöhnungszeit :)
     
  4. Thorongil

    Thorongil MacUser Mitglied

    Beiträge:
    354
    Zustimmungen:
    0
    Mitglied seit:
    30.08.2004
    Du willst das root-Zertifikat deiner CA der UNI importieren. Also kein Zertifikat eines Users, sondern ein Server-Zertifikat.

    Ich weiß zwar auch nicht, wie das geht, aber deine Frage war etwas mißverständlich, vieleicht kann uns nun jemand weiterhelfen?
     
  5. VicDorn

    VicDorn MacUser Mitglied

    Beiträge:
    662
    Zustimmungen:
    0
    Mitglied seit:
    06.09.2004
    Ich würde das auch gerne machen, da mein Provider (Hosteurope) nur ein nicht 1000% abgesichertes Zertifikat anbietet (IMAP-SSL). Laut Apple Hilfe soll man sich das Zertifikat anzeigen lassen, wenn die Fehlermeldung angezeigt wird und dann soll man das Zertifikat auf den Desktop ziehen. Leider komme ich noch nichtmal soweit, da Mail irgendwie hängt, sobald ich das Symbol über dem Desktop loslasse. Hmm... es geht zwar auch alles so, aber es ist halt schon nervig, bei jedem Mailverschicken die Meldung wegklicken zu müssen...

    Jemand noch eine Idee?

    Gruß,

    Stefan
     
  6. lundehundt

    lundehundt MacUser Mitglied

    Beiträge:
    17.760
    Zustimmungen:
    881
    Mitglied seit:
    22.02.2003
  7. revo

    revo Thread Starter MacUser Mitglied

    Beiträge:
    136
    Zustimmungen:
    0
    Mitglied seit:
    09.09.2004
    Ha, zumindetst ich habe mein Problem gelöst. Man sollte halt den Hilfe-Text RICHTIG lesen :) Dann wäre mir aufgefallen, dass dort steht, man solle das Zertifikat mit der Wahl-Taste ziehen. Ich als Mac-Neuling habe das in meinem Hirn in "mit gedrücketr Maustaste ziehen" übersetzt :rolleyes:
    lundehundts Tip macht allerdings auch Sinn, ist wohl der technische Vorgang hinter den Kulissen, oder?
     
  8. VicDorn

    VicDorn MacUser Mitglied

    Beiträge:
    662
    Zustimmungen:
    0
    Mitglied seit:
    06.09.2004
    Aha, werde das auch mal versuchen, heute nach Feierabend.

    Bleibt nur noch die Frage, warum ich das X.509 nicht in meiner Auswahlliste finde, wenn ich importieren will - da gibt es nur "System" und die eigenen. In /System/Library/Keychains sind 2 Dateien, einmal die X509Anchors und noch eine andere, die auch mit X509 anfaengt (kann mich gerade nicht erinnern). Gefunden habe ich bis jetzt auch nichts dazu.

    Gruss,

    Stefan
     
  9. VicDorn

    VicDorn MacUser Mitglied

    Beiträge:
    662
    Zustimmungen:
    0
    Mitglied seit:
    06.09.2004
    Guten Abend,

    ich habe jetzt das Zertfikat in die X509Anchors importiert - ich musste dazu als root angemeldet sein und dann noch manuell die Datei aus /System/Library/Keychains als Keychain hinzufügen. (Überall war von "als Administrator" die Rede - ich dachte bei OS X ist Administrator != root?!).

    Leider poppt bei Mail.app die Meldung "Dieser Server hat kein root-Zertifikat" immer noch auf. Es könnte daran liegen, dass das Zertifikat auf *.webpack.hosteurope.de ausgestellt ist. Mozilla akzeptiert diesen Wildcard klaglos, ich habe die Vermutung, das der Schlüsselbund da etwas pingeliger ist. Hat jemand hier noch ein Webpack bei Hosteurope und nutzt IMAP mit SSL-Verbindung mit Mail.app? ich wäre dankbar für jeden kleinen Tipp; ich habe schon Stunden gesucht :confused:

    Bis dahin werde ich entweder bei Mail.app immer das Fenster wegklicken oder warten, bis Thunderbird auf das OS X Adressbuch zugreifen kann.

    Grüße,

    Stefan
     
Die Seite wird geladen...

Diese Seite empfehlen