Zeichensatzprobleme bei Backup von MySQL-Daten

  1. hondo

    hondo Thread Starter

    Hallo Leute,
    habe nach einem Servercrash völligen Datensalat auf meinem momentanen Projekt gehabt. Zum Glück habe ich immer brav und mindestens einmal täglich ein Backup meiner MySQL-Datenbank mittels CocoaMySQL gemacht.

    Jetzt aber das Problem:
    Nach dem Import des Dumps in eine neu angelegte Datenbank sind scheinbar alle Zeicheninformationen etwas durcheinander geraten.

    Bei vielen Tabelleneinträgen kommen solch komische Zeichenkombinationen vor (Beispiel: ||||||+N+||||||||||||+N+||||||) und alle Umlaute sind weg.

    Kann mir jemand von den MySQL-Spezialisten sagen, was ich falsch gemacht habe bzw. lässt sich der Dump noch retten?

    Danke im Voraus und Grüße von Hondo.
     
    hondo, 02.03.2005
  2. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    Direkt helfen kann ich Dir nicht, so ad hoc! Aber ich kann google:

    http://dev.mysql.com/doc/mysql/de/character-sets.html

    hilft Dir das ?
     
    wegus, 02.03.2005
  3. hondo

    hondo Thread Starter

    Wegus, danke für den Wink mit dem Zaunpfahl....

    Der Artikel geht zumindest in die Richtung. Ich schätze mal, dass beim Dumpen etwas schief gelaufen ist. Werde mal ein paar Testdumps mit verschiedenen Einstellungen ziehen und wieder einspielen.

    Wenn ich die Lösung gefunden habe, melde ich mich.

    Grüße, Hondo.
     
    hondo, 02.03.2005
  4. tk86

    tk86MacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    178
    Zustimmungen:
    0
    ich hatte auch so ein Problem!

    Ich habs damals dann mit ner Windows-Kiste hochgeladen per phpMyAdmin und das hat dann geklappt. Frag mich aber nicht warum! Mit phpMyAdmin und Mac hats die komischen Laute gegeben!
     
    tk86, 19.05.2005
  5. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Ich habe in meine /etc/my.conf folgendes eingetragen
    Code:
    [mysqld]
    default-character-set = latin1
    Probleme mit Umlauten oder anderen Sonderzeichen hatte seither ich noch nie.
    Auch nicht beim Austausch von dumps zwischen Datenbanken bei meinem webhoster und dem lokalen Server.

    HTH
     
    maceis, 19.05.2005
Die Seite wird geladen...
Ähnliche Themen - Zeichensatzprobleme bei Backup
  1. nicoch
    Antworten:
    2
    Aufrufe:
    285
  2. forestgump
    Antworten:
    2
    Aufrufe:
    1.166
    Mankind75
    24.03.2017
  3. mad dog
    Antworten:
    19
    Aufrufe:
    3.911
    MacEnroe
    14.08.2015
  4. wvn
    Antworten:
    3
    Aufrufe:
    937
  5. lizarazu
    Antworten:
    8
    Aufrufe:
    3.678
    Andy.321
    25.06.2012