1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Zeichensatzprobleme bei Backup von MySQL-Daten

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von hondo, 02.03.2005.

  1. hondo

    hondo Thread Starter

    Hallo Leute,
    habe nach einem Servercrash völligen Datensalat auf meinem momentanen Projekt gehabt. Zum Glück habe ich immer brav und mindestens einmal täglich ein Backup meiner MySQL-Datenbank mittels CocoaMySQL gemacht.

    Jetzt aber das Problem:
    Nach dem Import des Dumps in eine neu angelegte Datenbank sind scheinbar alle Zeicheninformationen etwas durcheinander geraten.

    Bei vielen Tabelleneinträgen kommen solch komische Zeichenkombinationen vor (Beispiel: ||||||+N+||||||||||||+N+||||||) und alle Umlaute sind weg.

    Kann mir jemand von den MySQL-Spezialisten sagen, was ich falsch gemacht habe bzw. lässt sich der Dump noch retten?

    Danke im Voraus und Grüße von Hondo.
     
  2. wegus

    wegus MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    15.301
    Zustimmungen:
    1.798
    Direkt helfen kann ich Dir nicht, so ad hoc! Aber ich kann google:

    http://dev.mysql.com/doc/mysql/de/character-sets.html

    hilft Dir das ?
     
  3. hondo

    hondo Thread Starter

    Wegus, danke für den Wink mit dem Zaunpfahl....

    Der Artikel geht zumindest in die Richtung. Ich schätze mal, dass beim Dumpen etwas schief gelaufen ist. Werde mal ein paar Testdumps mit verschiedenen Einstellungen ziehen und wieder einspielen.

    Wenn ich die Lösung gefunden habe, melde ich mich.

    Grüße, Hondo.
     
  4. tk86

    tk86 MacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    178
    Zustimmungen:
    0
    ich hatte auch so ein Problem!

    Ich habs damals dann mit ner Windows-Kiste hochgeladen per phpMyAdmin und das hat dann geklappt. Frag mich aber nicht warum! Mit phpMyAdmin und Mac hats die komischen Laute gegeben!
     
  5. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.712
    Zustimmungen:
    602
    Ich habe in meine /etc/my.conf folgendes eingetragen
    Code:
    [mysqld]
    default-character-set = latin1
    Probleme mit Umlauten oder anderen Sonderzeichen hatte seither ich noch nie.
    Auch nicht beim Austausch von dumps zwischen Datenbanken bei meinem webhoster und dem lokalen Server.

    HTH