.Xdefaults funktioniert nicht richtig!

  1. nordpol

    nordpol Thread StarterMacUser Mitglied

    Mitglied seit:
    07.07.2003
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo zusammen
    Ich habe u.a. hier gelesen, dass man mit einer Datei Namens .Xdefaults im Homeverzeichnis (also ~/.Xdefaults) das X11-Terminal bedeutend ansehnlicher machen kann (Farbe, Scrollbar...). Ich habe mir dafür nun eine Vorlage aus dem Netz geholt, diese Datei erstellt und X11 gestartet. Leider passierte nichts :( Mein OS ist 10.4.2
    Ich weiss, ich bin Anfänger, aber könnt ihr mir helfen, was habe ich falsch gemacht? :(

    Grüsse vom
    nordpol
     
    nordpol, 19.07.2005
  2. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Du kannst uns helfen, Dir zu helfen, z. B. indem Du die Ausgabe von
    cat ~/.Xdefaults
    (im Terminal eingeben) postest und außerdem schreibst, was Du denn erwartest, dass passieren soll und was stattdessen passiert.

    Bei mir (ebenfalls 10.4.2) klappt .Xdefaults problemlos.
     
    maceis, 19.07.2005
  3. nordpol

    nordpol Thread StarterMacUser Mitglied

    Mitglied seit:
    07.07.2003
    Beiträge:
    14
    Zustimmungen:
    0
    also
    Die Eingabe von cat~/.Xdefaults ergibt:

    Code:
    [Computer_n1:~] nordpol% cat ~/.Xdefaults
    *Scrollbar.backgroundPixmap: gradient:horizontal?dimension=14&start=gray80&end=w
    <BtnUp>: NotifyScroll(Proportional) EndScroll()[Computer_n1:~] nordpol% xterm
    [Computer_n1:~] nordpol% 
    Was ich (vielleicht in meiner Naivität) erwartet hätte, ist, dass ich fortan bei jedem Aufstarten von X11 einen Scrollbalken habe. Was stattdessen bei mir passiert, ist nichts.
    Ich habe eine txt-Version meiner Setting-Datei angehängt, vielleicht liegt ja da der Hund begraben. (Auch der Versuch mit einer kleinere/einfacheren Steuerdatei ist mit einer ähnlichen Ausgabe gescheitert)

    Danke und Gruss
    nordpol
     

    Anhänge:

    • Dateigröße:
      1,7 KB
      Aufrufe:
      14
    nordpol, 19.07.2005
  4. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Fang doch mal mit einer ganz einfachen Variante an, und erweitere die nach und nach:

    Code:
    % cat .Xdefaults
    xterm*Foreground:       black
    xterm*Background:       light grey
    xterm*Border:           dark blue
    xterm*ScrollBar:        on
    
    Und noch was: die Datei muss natürlich als reine Textdatei ohne Endung abgespeichert werden.
    Das was bei Dir mit cat rauskommt sieht nicht gut aus.
    Womit erstellst Du die Datei (und in welchem Format)?
     
    maceis, 19.07.2005
  5. nordpol

    nordpol Thread StarterMacUser Mitglied

    Mitglied seit:
    07.07.2003
    Beiträge:
    14
    Zustimmungen:
    0
    war der entscheidende Satz. Ich verwendete BBeditLite 6.1 for OSX. Ich habe nun von denselben Autoren Textwrangler runtergeladen und verwendet. Resultat: Es funktioniert!!!

    Herzlichen Dank!
     
    nordpol, 19.07.2005
Die Seite wird geladen...
Ähnliche Themen - Xdefaults funktioniert richtig
  1. Tastentipper
    Antworten:
    45
    Aufrufe:
    1.326
    Olivetti
    03.03.2017
  2. Merlok
    Antworten:
    26
    Aufrufe:
    1.418
    Olivetti
    28.02.2017
  3. Harry3
    Antworten:
    20
    Aufrufe:
    1.573
  4. twr
    Antworten:
    0
    Aufrufe:
    619
  5. OS X
    Antworten:
    9
    Aufrufe:
    1.099
    Olivetti
    21.02.2013