Xcode::Backspace \b wird nicht ausgeführt

Dieses Thema im Forum "Mac OS Entwickler, Programmierer" wurde erstellt von Winn, 18.12.2006.

  1. Winn

    Winn Thread Starter MacUser Mitglied

    Beiträge:
    423
    Zustimmungen:
    0
    Mitglied seit:
    07.11.2002
    Hello folks,

    eine Seltsamkeit beschäftigt mich zur Zeit, wenn ich unten aufgelistetes Programm ausführe, erhalte ich im Run Log von Xcode "Hallo?????Salut" und wenn ich das Programm direkt im Terminal kompiliere und ausführe genau das erwünschte Ergebnis von "Salut".

    Woran liegt das und wie kann ich das Run/Debug Log von Xcode so einstellen, damit das Backspace auch wirklich ausgeführt wird ?

    Vielen Dank schonmal für Zeit und Müh

    Winn

    Code:
    #include <stdio.h>
    #include <stdlib.h>
    
    int main () 
    {
    	fprintf(stdout,"Hallo");
    	fprintf(stdout,"\b\b\b\b\b");
    	fprintf(stdout,"Salut");
    
    	return 0;
    }
    
     
  2. below

    below MacUser Mitglied

    Beiträge:
    13.276
    Zustimmungen:
    1.086
    Mitglied seit:
    15.03.2004
    Es haben schon ein paar Leute berichtet, dass das run log von Xcode nicht so richtig toll ist.

    Schick Dein Problem mal an http://bugreport.apple.com, vielleicht wird das run log mal besser.

    Alex
     
  3. Winn

    Winn Thread Starter MacUser Mitglied

    Beiträge:
    423
    Zustimmungen:
    0
    Mitglied seit:
    07.11.2002
    Na super... okay, bug report ist ausgefüllt...

    Hast Du eine Ahnung seit wann dieses Fehlverhalten bei Xcode vorzufinden ist ?

    Winn
     
Die Seite wird geladen...

Diese Seite empfehlen