X11, Matlab Editor: Sonderzeichen eingeben

  1. spice

    spice Thread StarterMacUser Mitglied

    Mitglied seit:
    18.03.2005
    Beiträge:
    187
    Zustimmungen:
    1
    Hallo,

    ich habe ein Problem mit Matlab bzw. mit dem Matlab Editor. Ich kann innerhalb des Editors keine Sonderzeichen wie [ ] oder { } eingeben. Im Workspace von Matlab klappt das problemlos.

    Meine Frage ist, woran das liegen kann. Hat einer von Euch ne Idee oder weiss, wie ich die eckigen Klammern innerhalb des Editors eingeben kann?

    Denn auf Dauer wird es ein wenig nervig entweder die Klammern im Workspace einzutippen und dann per Copy und Paste ins Editorfenster zu kopieren oder die M-Files direkt in einem externen Editor zu schreiben.

    Vielleicht ist das Problem auch in X11 zu suchen?

    Danke für Eure Hilfe...

    spice
     
    spice, 03.12.2005
  2. nablamalnabla

    nablamalnablaMacUser Mitglied

    Mitglied seit:
    17.08.2005
    Beiträge:
    179
    Zustimmungen:
    16
    Hast du für dieses Problem inzwischen irgendwo anders eine Lösung gefunden? Interessiert mich nämlich auch - und hat ja in der Tat einen hohen Nerv-Faktor...

    Gruß,
    nablamalnabla
     
    nablamalnabla, 10.01.2006
  3. Winn

    WinnMacUser Mitglied

    Mitglied seit:
    07.11.2002
    Beiträge:
    423
    Zustimmungen:
    0
    Hab damit eigentlich kein Problem...

    ALT+8={
    ALT+9=}
    ALT+5=[
    ALT+6=]

    mfg Winn
     
    Winn, 10.01.2006
  4. nablamalnabla

    nablamalnablaMacUser Mitglied

    Mitglied seit:
    17.08.2005
    Beiträge:
    179
    Zustimmungen:
    16
    Hi Winn,

    genau das geht eben nicht. Alles, was über die Alt-Taste läuft, erscheint im m-File-Editor nicht.

    /edit: Welche Matlab-Version und ggf. welches Service Pack verwendest du denn?
     
    nablamalnabla, 10.01.2006
  5. Winn

    WinnMacUser Mitglied

    Mitglied seit:
    07.11.2002
    Beiträge:
    423
    Zustimmungen:
    0
    Seltsam !! Ich hab die 7.1 (R14) mit SP3... sonst geht mal innerhalb des Matlab Editors in die "Preferences >> Editor/Debugger >> Keyboard Bindings und schaut mal, ob Ihr dort "Macintosh" eingestellt ist...
     
    Winn, 10.01.2006
  6. nablamalnabla

    nablamalnablaMacUser Mitglied

    Mitglied seit:
    17.08.2005
    Beiträge:
    179
    Zustimmungen:
    16
    Tja.. ist so eingestellt. Mit englischem Tastaturlayout kommen die Klammern auch, dort wird ja kein Alt benötigt...

    Oder ich muß mich mal um die Service Packs kümmern - hatte ich bisher vernachlässigt!
     
    nablamalnabla, 10.01.2006
Die Seite wird geladen...
Ähnliche Themen - X11 Matlab Editor
  1. Andreannie
    Antworten:
    7
    Aufrufe:
    1.876
    icarus777
    14.11.2011
  2. Candidus
    Antworten:
    1
    Aufrufe:
    871
    berbel01
    07.06.2009
  3. Ironman
    Antworten:
    1
    Aufrufe:
    619
  4. fischixx
    Antworten:
    3
    Aufrufe:
    1.419
  5. Marduk
    Antworten:
    38
    Aufrufe:
    2.531
    LaborWolf
    07.02.2006