X11 funktioniert nicht!

Diskutiere das Thema X11 funktioniert nicht! im Forum Umsteiger und Einsteiger.

  1. cpeter

    cpeter Thread Starter Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    Mitglied seit:
    26.05.2006
    Hallo,

    als erstes sollte ich dazusagen, dass ich Neueinsteiger, bzw. Umsteiger bin.

    Ich benutze einen iMac (Intel inside) und wollte Programme wie z.B. GIMP nutzen, die X11 benötigen.

    Also habe ich mir auf der Apple Web-Site X11 gedownloaded und wollte es installieren. Nach wenigen Schritten kam die Meldung, dass ich ex bereits auf meinen Laufwerk installiert ist. Bzw. eine neuere Version.

    Angeblich gibt es unter Dienstprogramme eine Anwendung X11 - bei mir nicht. Wo finde ich die Anwendungen die zu X11 gehören. Mit Spotlight konnte ich auf meinem Rechner nichts mit dem Namen X11 finden.

    Wie kann ich X11 starten oder konfigurieren.

    Weil GIMP lässt sich nicht installieren ohne X11 und X11 ist angeblich schon installiert.

    Es muss doch auf dem Apple auch so etwas geben wie Programme installieren/entfernen. Oder was kann ich tun?

    Beste Grüße
    Carsten
     
  2. theHobbit

    theHobbit Mitglied

    Beiträge:
    730
    Zustimmungen:
    6
    Mitglied seit:
    07.08.2005
    Auf Deiner OS X CD sollte es eine Datei namens X11User.pkg geben. Die installierst Du per Doppelklick, damit sollte das Thema gegessen sein.

    Allerdings hab ich einen G4 Mini, weiss nicht ob X11 schon auf dem Intel läuft oder noch unter Rosetta ...

    Gruß
    -theHobbit-

    EDIT: und natürlich herzlich willkommen hier im Forum !
     
  3. -jez-

    -jez- Mitglied

    Beiträge:
    341
    Zustimmungen:
    0
    Mitglied seit:
    14.01.2006
    mußt das X11 von deiner Installations DVD nehmen, irgendwo im Ordner "Additional Programs" liegt das.
     
  4. cpeter

    cpeter Thread Starter Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    Mitglied seit:
    26.05.2006
    Vielen Dank für die schnellen Antworten.

    Hab's von der DVD installieret.

    Die Datei heisst x11sdk.pgk

    danach lief GIMP immer noch nicht.

    Nachdem ich ein Neustart gemacht habe hatte ich erst einmal die Weltkugel beim Start.

    Was ein Glück hatte ich noch einen PC.. Sonst hätte ich nicht einmal Apple Umschalt "P" "R" rausgefunden und booten können.

    So wie es aussieht ist es immer noch nicht installiert.

    Wie kann ich denn sehen, ob es installiert ist oder funktioniert?

    Beste Grüße
     
  5. rex1966

    rex1966 Mitglied

    Beiträge:
    1.019
    Zustimmungen:
    53
    Mitglied seit:
    10.12.2003
    Hallo theHobbit

    X11 ist Universal,hab einen Intel iMac und eben mal nachgeschaut.

    Gruß
    rex1966
     
  6. Wallaby

    Wallaby Mitglied

    Beiträge:
    181
    Zustimmungen:
    0
    Mitglied seit:
    25.04.2004
    das x11sdk ist das software developer kit und nicht das install paket.
    das paket heisst X11User.pkg und das paket ist in einem nicht sichtbaren
    verzeichnis deiner install cd/dvd.
    du kannst das installationsprogramm starten und installation anpassen wählen
    um das paket nachträglich zu installieren. oder du suchst auf der dvd
    nach dem paket und doppelklickst es direkt.

    das X11.pkg auf der apple seite ist nicht für tiger, was auch extra dabei steht.

    -W-
     
  7. theHobbit

    theHobbit Mitglied

    Beiträge:
    730
    Zustimmungen:
    6
    Mitglied seit:
    07.08.2005
    X11 installieren -> wie mache ich das?

    Wie Wallaby schon schrieb (und meine Wenigkeit auch :)) musst Du das X11User.pkg installieren.

    Hab mal eben meine Tiger DVD rausgekramt und nachgesehen: das Paket findest Du auf der DVD im Verzeichnis

    System -> Installation -> Packages -> X11User.pkg .

    siehe hier :



    Wenn Dein Finder-Fenster anders aussieht sobald die DVD eingelegt ist, drück mal Apfel+3 :)

    Gruß
    -theHobbit-
     
  8. Hr. Hobbit, vielen Dank! Diesen Post werde ich sicher noch oft verlinken! X11 Probleme hat ja offensichtlich jeder 2te User. Besser, noch dazu mit Screenshot, kann mans nicht erklären. :)

    MfG, juniorclub.
     
  9. theHobbit

    theHobbit Mitglied

    Beiträge:
    730
    Zustimmungen:
    6
    Mitglied seit:
    07.08.2005
    @juniorclub : bitteschön - gerne :)

    Gruß
    -theHobbit-
     
  10. cpeter

    cpeter Thread Starter Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    Mitglied seit:
    26.05.2006
    Vielen Dank, habe es gefunden jetzt hoffe ich nur noch das es funktioniert.

    Aber schon mal vielen Dank... Für Neueinsteiger war das ein super tipp, gerade wenn man sich nicht so gut mit dem Apple auskennt.

    Beste Grüße
    Carsten
     
  11. Spaceranger

    Spaceranger Mitglied

    Beiträge:
    2.348
    Zustimmungen:
    47
    Mitglied seit:
    03.04.2006
    Als ich mir OpenOffice runtergeladen hab gabs ne deutsche Anleitung dazu wo drin stand wie man X11 installiert und das beim installieren manchmal angegeben wird das es bereits installiert ist, ist es aber nicht. War genau beschrieben wir oben. Hat sofort gefunzt.
     
  12. flori73

    flori73 Mitglied

    Beiträge:
    269
    Zustimmungen:
    3
    Mitglied seit:
    26.03.2006
    Frage: Wie deinstalliert man das X11sdk.pkg am effektivsten ?
     
  13. schweizerfranke

    schweizerfranke Mitglied

    Beiträge:
    69
    Zustimmungen:
    1
    Mitglied seit:
    30.01.2007
    hehe, das mit dem deinstallieren wüsst ich auch gern, hab die selbe odysee hinter mir

    Super erklärung übrigens, danke
     
  14. kili

    kili Registriert

    Beiträge:
    2
    Zustimmungen:
    0
    Mitglied seit:
    26.05.2008
    hallo allerseits,

    ich hab ein anderes problem was aber mit dem hier zusammenhängt:

    also, ich will ebenfalls Gimp benutzen und stoße beim installieren vom "X11User.pkg" auf dasselbe problem mit der neueren version, obwohl ich keine davor installiert habe.

    nur habe ich gerade eben die installationscd von tiger reingeschoben und sind bei mir ganz andere ordner usw. auf der cd, als wie auf diesem screenshot !? bei mir fehlt zum beispiel dieses "X11User.pkg" (was ich aber aus dem internet geladen habe)



    ich weiß nicht, ob da iwie ein zusammenhang betsteht, ka
    es wäre sehr nett wenn jem. antworten und helfen könnte!

    danke

    grüße kili
     
  15. aXon

    aXon Mitglied

    Beiträge:
    734
    Zustimmungen:
    37
    Mitglied seit:
    04.01.2004
    aloha!

    besser ist es, sich von der passenden seite das neueste X11 zu besorgen, voraussetzung man hat die aktuellste version von leo drauf -> http://xquartz.macosforge.org/trac/

    edit: das problem mit X11 ist jenes, dass man vorher das X1 von der leo DVD installieren muste und danach erst eine neuere installieren konnte. ist aber seit X11 2.1 behoben, sodass eine aktuelle version auf der von mir verlinkten seite ausreicht und nichts mehr vorher installiert werden muss.

    edit2: ups, nicht gelesen, dass du tiger verwendest. die X11 versionen sind nicht miteinander kompatibel, sodass man für X11 in tiger die alte version benutzen muss, also von DVD (wenn es die bei apple noch als download gibt, natürlich auch)
     
  16. kili

    kili Registriert

    Beiträge:
    2
    Zustimmungen:
    0
    Mitglied seit:
    26.05.2008
    aber was hilft das mir?

    gibt es denn keine eindeutige Lösug wie man das beheben kann?

    grüße kili
     
Die Seite wird geladen...

MacUser.de weiterempfehlen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...