• Wenn du alle Inhalte sehen, oder selber eine Frage erstellen möchtest, kannst du dir in wenigen Sekunden ein Konto erstellen. Die Registrierung ist kostenlos, als Mitglied siehst du keine Werbung!

Windows Update auf NVMe SSD führt zu unbrauchbarem BootCamp

TheRocka

Mitglied
Thread Starter
Mitglied seit
15.10.2004
Beiträge
890
Hallo liebe Menschen,

ich habe ein NVMe SSD (970 EVO) in mein MacBook Pro late 2013 eingebaut, Windows 10 über BootCamp installiert und mich bei den Einstellungen an diese Anleitung gehalten: https://maxwireless.de/2019/windows-auf-dem-macbook-mit-nvme-ssd-installieren/.
Alles funktionierte problemlos, aber ein WindowsUpdate (keine Ahnung, was da immer so im Hintergrund installiert wird) führte dazu, dass der Rechner bei der Passworteingabe regelmäßig mit einem Bluescreen abstürzt. Ich komme nicht mehr rein und kann auch keine Tastenkombination beim Booten zielführend ausführen.
Ich habe also BootCamp gelöscht und neu eingerichtet. Nach einiger Zeit dasselbe Problem :(.
Ich weiß, dass die Nutzung der NVMe SSD wahrscheinlich das Problem ist. Aber was kann ich denn ggf. tun? Möchte eigentlich nicht unter Windows alle Updates deaktivieren, da es dann ja zwangsweise zu Sicherheitslücken kommt.

Hat jemand eine Hilfestellung? Vielen Dank!!!
 

dg2rbf

Mitglied
Mitglied seit
08.05.2010
Beiträge
6.473
Hi,
tja, da wirds wohl an den Treibern von Win10 für diese NVME SSD hapern, da wird wohl ein inkompatibler Treiber beim Update installiert.
Franz
 

OmarDLittle

Mitglied
Mitglied seit
21.05.2017
Beiträge
1.534
Lösung ist, nicht Bootcamp zu verwenden, sondern im UEFI-Modus zu installieren. Bootcamp ist eine Frickellösung von Apple, die Windows 10 im "MBR-Kompatibilitäsmodus" (ich weiß grad nicht ob der einen anderen Namen hat) laufen lässt anstatt im UEFI-Modus.
 
  • Gefällt mir
Reaktionen: TheRocka

TheRocka

Mitglied
Thread Starter
Mitglied seit
15.10.2004
Beiträge
890
Lösung ist, nicht Bootcamp zu verwenden, sondern im UEFI-Modus zu installieren. Bootcamp ist eine Frickellösung von Apple, die Windows 10 im "MBR-Kompatibilitäsmodus" (ich weiß grad nicht ob der einen anderen Namen hat) laufen lässt anstatt im UEFI-Modus.
Puh, hast du da ein Tutorial parat? Trau mir da ja einiges zu😀
 

OmarDLittle

Mitglied
Mitglied seit
21.05.2017
Beiträge
1.534
Ja müsstest googeln, irgendwie musst du glaub ich einen Bereich auf der Platte frei machen, zB eine Partition mit dem Disk utility erstellen und mit exfat formatieren, und die kannst du dann im Installer von Windows neu mit NTFS formatieren. Den Stick nicht mit Bootcamp erstellen, sondern unter windows regulär mit Installation media creation Programm, das du von Microsoft bekommst, aber nur wenn du es unter windows 10 auch herunterlädst (am Mac bekommst du nur ein iso-file zum Download).
 
  • Gefällt mir
Reaktionen: TheRocka und dg2rbf

TheRocka

Mitglied
Thread Starter
Mitglied seit
15.10.2004
Beiträge
890
Ok. Ich werde das mal probieren. Also den von Bootcamp erstellten Stick kann ich nicht für eine normale Installation auf einer vorher erstellten Partition nutzen? Ich werde dann wohl den Rechner meiner Frau quälen müssen.
 

OmarDLittle

Mitglied
Mitglied seit
21.05.2017
Beiträge
1.534
Du benötigst einen UEFI-Stick, so einen fertigt das media creation tool an, Bootcamp aber nicht. Du kannst auch bei dir ein Windows-10-ISO runterladen direkt von Microsoft und einen Bootstick erstellen, aber das ist aufwänder als auf einem Windowsgerät mal eben die App laufen zu lassen die es automatisch erledigt.
 
  • Gefällt mir
Reaktionen: TheRocka

Kontrapaganda

Mitglied
Mitglied seit
14.12.2019
Beiträge
263
Lösung ist, nicht Bootcamp zu verwenden, sondern im UEFI-Modus zu installieren. Bootcamp ist eine Frickellösung von Apple, die Windows 10 im "MBR-Kompatibilitäsmodus" (ich weiß grad nicht ob der einen anderen Namen hat) laufen lässt anstatt im UEFI-Modus.
Laut https://discussions.apple.com/thread/8080187 unterstützt BootCamp auf dem Macbook Pro des TEs unter anderem einen UEFI-Install. Wie man da in der Praxis die Auswahl trifft, weiß ich leider nicht.
 

TheRocka

Mitglied
Thread Starter
Mitglied seit
15.10.2004
Beiträge
890
So, habe eine Partition angelegt, Stick unter Windows erstellt, Windows installiert und Bootcamptreiber installiert. Alles läuft.
AAAABER:
Wenn der Login im Akkubetrieb versucht wird, stürzt der Rechner, wie auch vorher schon, ab. Im Netzbetrieb funktioniert alles. Es ist ein neuer Akku verbaut worden und unter Mac OS auch alles paletti. Sehr komisch alles. Es ist ja nicht so, dass der Rechner ausgeht. Er stürzt mit einem Bluescreen ab.
Hat da noch jemand eine Idee???
Für die Hilfe bislang vielen Dank!
 

OmarDLittle

Mitglied
Mitglied seit
21.05.2017
Beiträge
1.534
Bist du tatsächlich im UEFI-Modus? Ich glaube dxdiag.exe zeigt das an. Also du hast jetzt einen neuen Fehler mit Login im Akkubetrieb? Kannst du das mal beschreiben, wie du das reproduzieren kannst, was genau passiert und wie der Code aus dem Bluescreen lautet? Da steht ja was drin. Aber wenn das Ding am Netzbetrieb funktioniert, ist ja zumindest mal das Thema mit NVMe gelöst.
 
  • Gefällt mir
Reaktionen: TheRocka und dg2rbf

TheRocka

Mitglied
Thread Starter
Mitglied seit
15.10.2004
Beiträge
890
Habe mal weiter rumprobiert. Ich glaube, ich habe das Problem eingegrenzt: Nach dem Update wurden die Energieeinstellungen überschrieben. Die in dem oben verlinkten Artikel vorgenommen Einstellungen von der PCI Express Einstellungen wurden zurückgesetzt. Jetzt klappt es wieder.
Aber warum überhaupt diese Einstellung einen Effekt hat verstehe ich nicht. Aber gut, jetzt scheint es (erst einmal) zu laufen.
Vielen Dank an euch!
 
  • Gefällt mir
Reaktionen: dg2rbf