Windows bootet nicht (mehr)

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Seitdem ich unter Lion gezwungen bin zu arbeiten, bootet die Windows-Partition nicht mehr.

Folgender Umstand: Ich kann das System über die ALT-Taste auswählen, dann kommt der übliche USB-Reset, dann der schwarze Bildschirm und dann der Cursor oben links in der Ecke.

Das war's dann auch schon, da bleibt das System dann hängen und macht nichts mehr.

Bootcamp kann keine Windows-Partition auf der internen Platte anlegen, da die Systemplatte angeblich von einem anderen Dienstprogramm partitioniert wurde. Das scheint wohl reFit gewesen zu sein, zumindest hatte ich das versucht.

Das "deinstallieren" vom reFit scheint geklappt zu haben, zumindest ist es jetzt weg und erscheint auch nicht mehr.

Jetzt habe ich zwei Möglichkeiten: Entweder, ich bekomme die bestehende Windows-Partition wieder zum laufen (beste Option), oder ich erstelle mit Bootcamp eine neue Windows-Partition und installiere das neu.

Nur, Bootcamp will nicht und Windows weigert sich.

Was läuft da schief?
 

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Eine weitere Partition kannst du mit dem BC-Assi nicht erstellen, da ja noch eine vorhanden ist.
Diese müsstest du erst manuell (z.B. mit dem Festplatten-Dienstprogramm) löschen.

Warum Windows nicht mehr bootet weiß ich nicht, aber mit der (Neu)Installation von OSX hat das erst mal nix zu tun.
Pack mal die Windows CD rein und vesuch den MBR zu reparieren.
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Ich kann eine weitere Partition erstellen, sie befindet sich aber nicht auf der Platte, wo bereits das Windows installiert ist.

Was die Windows-CD/DVD angeht, sie verhält sich genauso. Bleibt bei dem schwarzen Cursor hängen...
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Nein, die zweite Platte habe ich via OptiBay eingebaut.

Aber so langsam komme ich dahinter. Mir fehlt die EFI-Partition "Disk0s1" auf der ersten Platte, die wird scheinbar von Bootcamp erstellt.

Da mein Bootcamp aber nicht will, stehe ich etwas dumm da...
 

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Ich meinte das (DVD)Laufwerk, von der du die Windows CD bootest... ;)
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Ja, aber das hat nichts mit der bestehenden Windows-Version zutun. Zudem funktioniert die Installation über ein Firewire-Laufwerk einwandfrei, wenn sie denn anläuft...

NACHTRAG: Die Ursache habe ich gefunden. Es ist tatsächlich die Partition "disk0S1" bzw. "disk1S1". Fehlt diese, geht Bootcamp davon aus, dass an dem System "herumgepfuscht" wurde und verweigert seinen Dienst.
 
Zuletzt bearbeitet:

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Was für einen Mac hast du denn?
denn bis aufs MBA haben die meisten Macs Probleme Windows von einem externen DVD-Laufwerk zu installieren.
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Ganz normales Macbook Pro (Midd 2010). Die Probleme, das Windows zu starten, habe ich mit einem USB-Laufwek, da während des Startvorgang der USB-Port zurück gesetzt wird. Bei Firewire passiert das jedoch nicht, das bleibt am System dran und Windows verliert nicht die Substanz zum starten.

Das dramatische an der ganzen Geschichte, ich kann derzeit nicht einmal Parallel starten, was mir ja grundsätzlich reichen würde, derzeit unterstützt es jedoch kein Lion und kann daher einige Treiber nicht mit laden.
 

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Ja, aber dennoch haben die meisten Macs Probleme, da der EFI legcay Bootloader kein externes Windows bootet; egal ob USB oder FW.
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
Es geht doch garnicht um das booten von einem externen Datenträger, sondern darum, dass Bootcamp nicht mehr funktioniert und/oder das bestehende Windows nicht mehr startet...
 

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Ja, aber da du die Windows CD nicht booten kannst, kannst du auch nicht den MBR reparieren... ;)
 

SirSalomon

Aktives Mitglied
Thread Starter
Mitglied seit
26.10.2003
Beiträge
4.836
So, ich hab die Lösung gefunden. Es sind die versteckten Partitionen, die für EFI-Boot angelegt werden. Sie nennen sich "diskXsY", wobei das X für eine Laufwerksnummer steht und das Y für die Partition.

Es ist logisch, dass Windows nicht ohne EFI-Boot starten kann. Das Windows-System an sich war und ist in Ordnung, konnte nur nicht starten weil eben die Partition fehlte. Das Bootcamp die Partition nicht mehr anlegen konnte, lag daran, dass die Partition gelöscht waren.

Die einzige Lösung dafür liegt darin, dass die Platten mit dem FPM neu eingerichtet werden müssen. Sowohl die erste, wie auch die zweite. Windows an sich bootet auch von einer zweiten, internen Festplatte. Bootcamp kann auch auf einer zweiten Festplatte eine Windows-Partition anlegen. Da der Mac an sich von jedem Medium booten kann, gibt er die Partition scheinbar als erste Partition an das System und hält diese Position auch.

Ich habe also Mac OSX Lion auf der ersten Platte installiert und Windows auf der zweiten Platte. Es läuft, irgendwie, und ich bin erst mal wieder so im Leben, wie ich es wollte :)
 
Oben