Win98 Textdateien mit Sonderzeichen

K

koli.bri

Hallo.

Ist zwar schon eine Weile her, dass mir das aufgefallen ist, aber jetzt wurde es wieder Problematisch.

Ich hab aus meiner Win98 Zeit eine Menge Textdateien mit Notizen, Planungen für Webprojekte und allerlei anderes.
doch wenn Umlaute, das scharfe S und andere Sonderzeichen auftauchen, werden diese nun am iBook durch andere Zeichen ersetzt.

Ich denke, das liegt einfach da dran, dass Win98 und Mac OS/Textedit verschiedene ASCII-Tabellen benutzen. ISt ja auch nicht weiterhin schlimm.

Nur, gibt es da vielleicht irgend ein Programm, was man einmal über die Textdateien drüberlaufen lässt, und dann alle jetzt fehlerhaft dargestellten Zeichen ändert?
Am besten so, dass ich dem vorher die Textdateien alle auf einmal angebe und der dann ein Dateiübergreifendes Ersetzen macht (Übrigens eine Funktion, die ich bisher weder bei Mac OS noch bei Textwrangler oder Taco gefunden habe, das Dateiübergreifende ersetzen.)

gruß
Lukas
 

msslovi0

Aktives Mitglied
Registriert
20.03.2005
Beiträge
2.726
Dateiübergreifendes Ersetzen kann BBEdit, übrigens eine der wenigen Funktionen, die ich an SubEthaEdit vermisse. Der wiederum kann nämlich Dateikodierungen ändern.

Dafür kann man aber auch Cyclone nehmen. Stapelverarbeitungfunktionalität müsste man aber auch dem via Applescript beibringen.

Matt
 

Gremlin

Mitglied
Registriert
11.01.2006
Beiträge
764
Wenn du Dateien in Textedit nicht über Doppelklick, sondern über Ablage->Öffnen aufmachst, hast du in dem Dialog die Option, die Zeichenkodierung, die textEdit verwenden soll, auszuwählen. Standard bei Windows ist glaube ich "Windows Latin 1", aber probier ruhig mal rum. Mit Ablage->Speichern unter... kannst du dann die neue Kodierung angeben - Standard beim Mac ist da UTF-8, dann hast du auch mit anderen Programmen keine Probleme mehr mit diesen Dateien.

Gremlin
 
Oben Unten