Wieder eine Frage zu .htaccess

  1. Admiral

    Admiral Thread StarterMacUser Mitglied

    Mitglied seit:
    15.03.2004
    Beiträge:
    202
    Zustimmungen:
    0
    Hallo zusammen,

    nun gibt es zwar in diesem Forum viele Beiträge zu der .htaccess, die ich alle beherzigt habe, aber keiner brachte mich weiter :(

    Denn ich weiss einfach nicht was man in der Zeile: AuthUserFile
    eintragen muss.
    Bei Windows muss man den absoluten Pfad angeben. Da ist das auch kein Problem aber beim MAC OS X weiss ich den nicht zu setzen.

    Die Webseiten liegen auf folgendem Pfad:
    HD: Library/WebServer/Documents/Demo

    Meine Beispiel-htaccess sieht so aus:

    AuthName "Webserver"
    AuthType Basic
    AuthUserFile /Volumes/Library/WebServer/Documents/Demo/.htpasswd
    require valid-user


    Bekomme aber vom Apache nur ne 500er internal Server Error.

    Weiss jemand einen Rat?

    Vielen Dank im voraus,

    Gruß Admiral
     
    Admiral, 07.02.2005
  2. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    Grundsätzlich ist das erstmal richtig! Allerdings sollte Deine passwd überall liegen nur nicht im Documents-Pfad des Servers ( sonst kann sie ggf. ausgelesen werden). Auch bei Mac OS oder LINUX gibst Du einfach nur den Pfad zur Datei an! Wichtig ist, daß der Apache-User auch leserechte auf die Datei haben muß, sonst kann er dort nicht nachschauen!
    Gegebenenfalls kannst Du noch ein

    satisfy any

    anfügen um die authorisierung zu erzwingen!

    Prüf bitte auch, ob in der httpd.conf

    AllowOverride AuthConfig

    gesetzt ist, sonst hat die .htaccess ohnehin keine Wirkung!
     
    wegus, 07.02.2005
  3. Admiral

    Admiral Thread StarterMacUser Mitglied

    Mitglied seit:
    15.03.2004
    Beiträge:
    202
    Zustimmungen:
    0
    ich hätte es wissen müssen :(

    Hallo wegus,

    ich habe einen wichtigen Aspekt vergessen:
    ich habe die .htaccess in Dreamweaver erstellt. Ich hatte vegessen das dadurch unsichtbare Formatierungen reingeschrieben werden, die der Apache als Fehler interpretiert. Ich habe die Datei jetzt mit Textedit ohne Formatierungen erstellt und siehe da - es funzt :)

    Jedoch musste der Pfad ohne /Volumes angegeben werden.

    Vielen Dank für die Hilfe

    Gruß Admiral
     
    Admiral, 08.02.2005
  4. xlqr

    xlqrMacUser Mitglied

    Mitglied seit:
    08.09.2003
    Beiträge:
    1.942
    Zustimmungen:
    15
    lass mal das volumes im pfad weg, ob das was bringt ...
    Code:
    /Library/WebServer/Documents/Demo/.htpasswd
     
    xlqr, 08.02.2005
  5. Eames

    EamesMacUser Mitglied

    Mitglied seit:
    26.09.2003
    Beiträge:
    2.572
    Zustimmungen:
    14
    Hier mal meine:

    AuthUserFile /Library/WebServer/.htpasswd
    AuthName "Titanium Webserver"
    AuthType Basic
    Require valid-user

    Gruss . Mikalux
     
    Eames, 08.02.2005
  6. Admiral

    Admiral Thread StarterMacUser Mitglied

    Mitglied seit:
    15.03.2004
    Beiträge:
    202
    Zustimmungen:
    0
    kaum geändert und scho so viele Antworten :)

    danke an alle, jetzt klappt es!


    Gruß Admiral
     
    Admiral, 08.02.2005
  7. Eames

    EamesMacUser Mitglied

    Mitglied seit:
    26.09.2003
    Beiträge:
    2.572
    Zustimmungen:
    14
    Freut mich zu lesen :)

    Hier noch zwei hilfreiche und informative Links zum Thema .htaccess

    » Detailierte Beschreibung der Parameter

    » Passwortschutz für Webseiten via .htaccess mit Generator

    Gruss . Mikalux
     
    Eames, 08.02.2005
Die Seite wird geladen...
Ähnliche Themen - Wieder eine Frage
  1. Gelfling
    Antworten:
    17
    Aufrufe:
    862
    Olivetti
    20.04.2017
  2. Bo Nuss
    Antworten:
    2
    Aufrufe:
    233
    Bo Nuss
    03.02.2017
  3. Kacknasae
    Antworten:
    0
    Aufrufe:
    120
    Kacknasae
    14.01.2017
  4. Themenautor
    Antworten:
    0
    Aufrufe:
    1.078
    Themenautor
    06.01.2017
  5. Kingilicious
    Antworten:
    12
    Aufrufe:
    537
    Kingilicious
    16.10.2016