wenn dann

  1. ms510

    ms510 Thread Starter MacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    431
    Zustimmungen:
    0
    kurze frage zu excel

    zelle a hat 11 verschiedene werte(char)

    wenn funktion soll so aussehen
    wenn a=01 oder 02 oder 03 oder 04 oder 06 oder 07 dann 12 sonst 13

    mit wenn(A1=(ODER("01";.....;"07");"12";"13") geht nicht
    verschachtel schon, also

    WENN(B2="01";"12";WENN(B2="02";"12";WENN(B2="03";"12";13))) usw

    rafft excel oben das nicht oder gehts auch kürzer?
     
  2. Jabba

    Jabba MacUser Mitglied

    Mitglied seit:
    21.11.2003
    Beiträge:
    4.458
    Zustimmungen:
    109
    Hai ms510,

    Erstes Problem: Excel mag 01 nicht... wenn, dann musst Du die Zelle als Text formatieren, damit Du den Wert "01" auch abfragen kannst.
    Zweites Problem:
    Du hast Die ODER Funktion falsch angewendet... muss lauten:

    =WENN(ODER(A1="01";A1="02"; etc. );"12";"13")

    Die ODER Funktion hat auch den Vorteil, dass Du 30 Bedingungen einknüpfen kannst, und zudem die Klammerorgie der WENN Funktion umgehst.

    So gehts.
    (drittes Problem: Hat sicher erledigt, da Du die Wenn Verschachtelung jetzt nicht mehr benötigst... gehen eh nur max. 7 WENNs)

    HTH
     
Die Seite wird geladen...