websharing

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
hi,

kann mal jemand versuchen ob er zugriff auf:

http://medmgmt-207.tajen.edu.tw

oder

http://192.192.192.207

hat, müsste ein flash5 demo für schattenmantel sichtbar sein.

thanx'n greetz lost

PS: welche sicherheitsrisiken sind mit websharing verbunden wenn man nur diesen einen Order freigibt. Und ist es möglich dort eine "richtige" html seite zu platzieren???
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
mmmh!

Also bei mir ist sowohl file- als auch websharing aktiv, dem websharing-Ordner hab ich unter gemeinsam Nutzen>jeder >lesen und schreiben aktiviert. (dem Volumen auf dem der Ordner ist jedoch NICHT)

Wenn ich auf die obigen urls gehe escheint der flash5demo installer.

Irgend eine Idee woran es liegen könnte?
 

Vevelt

Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Du must nur Websharing aktivieren, sowie dafür sorgen, daß die FireWall des Routers Port 80 an den entsprechenden Rechner weiterleitet...

Filesharing kannst du ausmachen. Rechte mußt du auch nicht vergeben, der lokal laufende Webserver Apache muß drauf zugreifen können, nicht alle... :D

Gruß, Vevelt.
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
blöde Frage: wie bringe ich es dem Router bei?

In den websharing-Voreinstellungen ist Port80 ausgewählt.

An dem Router (der an einem WinTel Win2000-Server hängt) habe ich noch nie herum konfiguriert.

greetz lost

PS: vor ein paar wochen hat es ohne probleme geklappt

PPS: hab nu filesharing abgeschalten.
 

Vevelt

Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Hat der Router ein Webinterface (über Browser zu erreichen)?

Bei meinem Netgear-Router kann ich dann im Menü Ports den Port 80 an eine bestimmte IP hinter dem Router weiterleiten... :D

Gruß, Vevelt.
 

Schattenmantel

Mitglied
Mitglied seit
22.04.2002
Beiträge
1.759
An diesem Thema bin ich gleich doppelt interessiert! :D

Zum einen weil ich gerne das deutsche Flash 5 Trial hätte und zum anderen weil ich selber noch nie Websharing über den Mac genutzt habe und das mal interessant wäre zu wissen wie das geht! :D


lostreality
Danke das du dir die Mühe machst mir zu dem Flash Trial zu verhelfen!!!
 

Vevelt

Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
HowTo

Also, nun nocheinmal generell:

1) Websharing aktivieren
2) Dokumente/Dateien in den /Library/Documents/Webserver Ordner kopieren
3) Im Router den Port 80 zu dem Websharing-Mac durchleiten
4) Möglicherweise bei DynDNS eine automatisch aktualisierende (Client für DynDNS downloaden) IP-Weiterleitung registrieren...
5) Nun per Browser jenen Rechner aufrufen (per DNS-Namen oder IP-Adresse, die bei der EInwahl bezogen wurde). Im Router-Netz muß man direkt die Rechner-IP des Websharing Macs eingeben, sonst funktioniert es nicht...

So, damit sollte es eigentlich klappen... :D

Wenn im Documents/Webserver/ Verzeichnis kein index.html vorhanden ist, dann stellt der Apache Webserver den gesamten Ordnerinhalt dar. Sehr nützlich für "Dateifreigaben".

In diesem Sinne, Vevelt.
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
Hi Velvet,

Erst mal Danke für Deine Mühe:p

So also der Router (SMC Barricade) hat ein web-interface, und dort habe ich einen der 20 Serviceports auf 80 gestellt und ihm die IP des Macs (die oben angegebene) zugewiesen.

Das einzige was ich nicht finden kann ist das Verzeichniss von dem du spichst
"Dokumente/Dateien in den /Library/Documents/Webserver"

In websharing kann ich doch manuell den freizugebenen Ordner festlegen!?!

greetz lost
 

Bodo

Mitglied
Mitglied seit
09.11.2001
Beiträge
655
ICh glaub der Ordner heißt schlicht "Sites" oder so (in Deinem Userverzeichnis)
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
Das klingt stark nach OSX, ich benutze hie ausschließlich OS 9.2.2.

trotzdem Danke
 

Bodo

Mitglied
Mitglied seit
09.11.2001
Beiträge
655
Entschuldigung

(Themaverfehlung - setzen; 6)
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
Hi

Könnt ihr es noch mal versuchen, von hier aus kann ich zum erstem mal seit dem einrichten einen Download starten.

greetz lost
 

Vevelt

Mitglied
Mitglied seit
01.09.2001
Beiträge
1.634
Sorry, ich klinke mich aus (zu wenig Ahnung von OS9 :D)

Gruß, Vevelt.
 

lostreality

Mitglied
Thread Starter
Mitglied seit
03.12.2001
Beiträge
9.503
@schattenmantel

shit, ich versuch's nochmal per mail obwohl vorhin beide zurückgekommen sind.

Ich drück uns die Daumen

greetz lost
 

Schattenmantel

Mitglied
Mitglied seit
22.04.2002
Beiträge
1.759
Also Mail ist angekommen, nur :( leider ist die .sit defekt! Ich kann die nicht aufmachen.

Habs dir aber schon per Mail geschickt. :(

Ist vielleicht beim versenden der Mail kaputt gegangen...

Sag mal hast du ne iDisk? Wenn ja. Die ist doch auf 20 MB gross. Kann man das nicht über die machen?

Im schlimmsten Fall kann ich dir die Zugangsdaten von nem alten Webspaceaccount gegeben der ausläuft. Dann kannste es hochladen und ich saugs mir dann von dort.

Gruss Schattenmantel
 
Oben