Video auf geringere Abspiel-Geschwindigkeit umkodieren? Wie?

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Ich habe ein YouTube-Vortragsvideo, wo der Sprecher mit derartiger Geschwindigkeit vorträgt, dass man dem Inhalt kaum folgen kann.

Wenn ich das mit VLC abspiele, dann kann ich die Geschwindigkeit reduzieren (im Beispiel konkret auf 0,78-fach), und die Wiedergabequalität sowohl von Video und Audio ist so unglaublich gut (inkl. des Erhalts der Stimmhöhe), dass man meint, der Vortragende habe original so langsam gesprochen.

Es ist mir aber trotz vieler Versuche nicht gelungen, bei diesem Abspielmodus eine neue Kopie zu machen. Also so, dass die Normalgeschwindigkeit der Kopie der verlangsamten Geschwindigkeit des Originalvideos entspricht.

Wenn ich z.B. beim verlangsamten Abspielen mit VLC die Menüfunktion "Aufnehmen" aktiviere, dann spielt VLC zwar bis zum Ende ab, ist dann aber blockiert, so dass mir nur noch "Sofort Beenden" bleibt und eine tatsächlich erzeugte Kopie nicht abspielbar ist.

Ich habe auch bei anderen Utilities (wie Avidemux, Handbrake, MKVToolnix, etc.pp.) gesucht, ob es eine Verlangsamungsfunktion für eine konvertierte Datei gibt, bin aber nicht fündig geworden.

Weiss jemand eine Lösung? Danke.
 

Kaito

Mitglied
Mitglied seit
31.12.2005
Beiträge
6.917
Ist hier beschrieben: https://trac.ffmpeg.org/wiki/How to speed up / slow down a video
Das genutzte atempo (nicht zu verwechseln mit asetrate) versucht die Tonhöhe beizubehalten.
Hinweis an dieser Stelle: das ist stark verlustbehaftet, grundsätzlich. Es gibt verschiedene Bibliotheken die das können (scaletempo, librubberband, etc.) und keine davon ist perfekt, es werden immer irgendwelche Artefakte erzeugt. Mit atempo bist du schon relativ gut bedient, besser wirds bei diesen Ratios nur mit händischem tunen der Parameter auf dein spezielles Video.

ffmpeg installieren kannst du z.B. mit https://brew.sh/. Die Befehle sind dann im Terminal einzugeben. Auf macOS kannst du, anstelle Pfade von Dateien händisch abzutippen, die Datei auch via Drag&Drop ins Terminal ziehen, wodurch dann automatisch der Pfad der Datei an der Stelle des Cursors geschrieben wird.
 
  • Gefällt mir
Reaktionen: MacNormalo

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Erstmal Danke für Euer Feedback!
keine davon ist perfekt, es werden immer irgendwelche Artefakte erzeugt
Wie kommt es denn dann, dass der "harmlose" Player VLC das einfach so nebenher derart perfekt macht?
 

Kaito

Mitglied
Mitglied seit
31.12.2005
Beiträge
6.917
Du hörst die Artefakte nicht. :)
Oder das Audio ist sehr simple, oder bereits sehr schlecht. VLC nutzt scaletempo per default, das sollte eigentlich die schlechteste Option der dreien sein, wenn es um Verlangsamung geht. Rubberband ist das beste, kannst du mit ffmpeg auch nutzen, aber bei deinen Ratios (0.78) dürfte es keinen nennenswerten Unterschied machen.
 
  • Gefällt mir
Reaktionen: MacNormalo

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Danke für die (Er)Klärung.
Weil ich bei komplizierten Terminal-Parametereingaben immer schon vorab eine leicht zittrige Hand bekomme, frage ich mal, ob es evtl. auch eine GUI dazu gibt?
Ansonsten werde ich es einfach mal heldenhaft probieren :cake:
 

Kaito

Mitglied
Mitglied seit
31.12.2005
Beiträge
6.917
Da passiert nichts. Nur Mut.
 
  • Gefällt mir
Reaktionen: MacNormalo

Kaito

Mitglied
Mitglied seit
31.12.2005
Beiträge
6.917
Den Befehl einfach aus dem Wiki kopieren. Kurz schauen ob alles dran ist, dann die Eingabedatei abändern. Wenn du das mit drag&drop machst, wie oben beschrieben, sind Schreibfehler ausgeschlossen.
 
  • Gefällt mir
Reaktionen: dg2rbf und MacNormalo

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Da passiert nichts. Nur Mut.
Ich habe mir heute mal Mut angetrunken und die ganze Sache versucht. Vielleicht war ich ja (über)mutig, jedenfalls ist das schiefgelaufen. Nach der Rieseninstallation von Homebrew (hoffentlich ist mein Macbook jetzt nicht linksgrün unterwandert :cake: ) scheint mein Terminal ffmpeg immer noch nicht zu kennen:

ffmpeg.jpg

Was könnte ich falsch gemacht haben?
 

mausfang

Mitglied
Mitglied seit
04.08.2016
Beiträge
1.682
Aus dem Screenshot sieht man aber nicht, dass Du ffmpeg installiert hast. Oder?
 

Bozol

Mitglied
Mitglied seit
16.07.2003
Beiträge
2.358
Warum der Weg über Homebrew? FFMPEG gibts auch für macOS: Klick
 
  • Gefällt mir
Reaktionen: dg2rbf und MacNormalo

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314

mausfang

Mitglied
Mitglied seit
04.08.2016
Beiträge
1.682
Homebrew ist nur der Paketmanager ... dadurch ist noch nicht ffmpeg installiert ...
Das ist die Vorbereitung ...

probier es doch mal wie @Bozol vorschlägt ...
 
  • Gefällt mir
Reaktionen: MacNormalo

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Ich hab's mit dem folgenden Kommando im Terminal laufen lassen:
ffmpeg -i /transfer/Test.mp4 -filter_complex "[0:v]setpts=0.5*PTS[v];[0:a]atempo=0.78[a]" -map "[v]" -map "[a]" /transfer/Test1.mp4

Ergebnis war immerhin ein Test1.mp4-Output mit korrekt aufs 0,78-fache reduzierter Audiogeschwindigkeit, aber gleichzeitig nochmal erhöhter Video-Geschwindigkeit.

Was muss ich am Kommando ändern? Ich rate mal die "0.5*PTS", aber rumexperimentieren bringt wohl nix, vor allem wenn Ihr's wisst.

Ja?
 

MacNormalo

Mitglied
Thread Starter
Mitglied seit
03.02.2020
Beiträge
314
Weil Ihr Euch wohl schon entnervt abgewendet hattet, hab ich's jetzt mal mit 1/0.78=1.282 statt 0.5 versucht.

Hat prima funktioniert.

Gut dass ich mir Mut angetrunken hatte... o_O

Euch allen Danke! :upten:
 
  • Gefällt mir
Reaktionen: mausfang