Verbindung zu Server sehr langsam

  1. Pioneer

    Pioneer Thread Starter MacUser Mitglied

    Mitglied seit:
    20.04.2004
    Beiträge:
    156
    Zustimmungen:
    0
    Ich habe meinen Mac einfach an ein kleines Win-Heimnetz (100 Mbit) angeschlossen. Mein Server (Win) teilte ihm gleich eine Ip zu. Wenn ich mit meinem Mac zwischen den Workstations Daten tausche, hab ich volle Geschwindigkeit, doch wenn ich Daten von dem Server hole hab ich nur ca. 150kb/s. Wie kann ich den Traffic zum Server erhöhen?
     
    Pioneer, 17.07.2004
    #1
  2. starbuxx

    starbuxx MacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    Welcher Mac? Welches OS? Was fürn Serverbetriebssystem? Was fürn Protokoll (SMB, FTP, NFS?) Angeschlossene Rechner? Geswitcht oder mit Hub? Anderer paralleler Traffic? Welche Netzwerkkarte? Errors am Hub/Switch? Collisions?

    Was sagt ein 'ifconfig' im Terminal? (Gesetzt den Fall Du hast OS X)

    Was heisst das, Du tauscht mit Deinem Mac zwischen den Workstations Daten? Andere Windowskisten? Welche OS?

    Gruss,
    sbx
     
    starbuxx, 17.07.2004
    #2
  3. Pioneer

    Pioneer Thread Starter MacUser Mitglied

    Mitglied seit:
    20.04.2004
    Beiträge:
    156
    Zustimmungen:
    0
    G5
    Mac OS X 10.3.4
    Der Server hat Win2k (die normale Version).
    SMB.
    Es sind derzeit nur der Server und mein Mac im Betrieb, alles läuft über einen Switch.
     
    Pioneer, 17.07.2004
    #3
  4. starbuxx

    starbuxx MacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    Sorry, hab' grad noch ein bischen geändert. Versuch nach einem Dateitransfer mit dem Server mal 'ifconfig' und poste hier die Ausgabe, schau besonders auf 'Errors'.

    Wie ist denn der Filetransfer zwischen einer Win Wkst und dem Server? Auch langsam?

    Grüsse,
    sbx
     
    starbuxx, 17.07.2004
    #4
  5. Pioneer

    Pioneer Thread Starter MacUser Mitglied

    Mitglied seit:
    20.04.2004
    Beiträge:
    156
    Zustimmungen:
    0
    Es können nur die Beiden nicht richtig miteinander. Wenn ich mit dem Mac Daten mit anderen Win Recher im Netzwerk tausche, hab ich volle Geschwindigkeit. Auch mit dem Server hab ich unter den Win Pc´s keine Probleme.

     
    Pioneer, 17.07.2004
    #5
  6. starbuxx

    starbuxx MacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    achm, grrr...

    Das zeigt das ifconfig von OSX ja wieder nich an (Übertragungsfehler).

    Wenn Du im Netzwerk Dienstprogramm mal als Ethernet-Schnittstelle 'en0' auswaehlst und dann schaust, was in dem Feld rechts steht, was siehstn da? Möglichst während, nach eines Dateitransfers zum Server.

    Grüsse,
    sbx
     
    starbuxx, 17.07.2004
    #6
  7. glotis

    glotis MacUser Mitglied

    Mitglied seit:
    18.05.2004
    Beiträge:
    553
    Zustimmungen:
    7
    Hi
    auch auf der Win-Kiste müsste der samba logfiles anlegen, schau da mal rein
     
    glotis, 18.07.2004
    #7
  8. Pioneer

    Pioneer Thread Starter MacUser Mitglied

    Mitglied seit:
    20.04.2004
    Beiträge:
    156
    Zustimmungen:
    0
    @starbuxx
    ich hab weder Sendefehler, Emfpangsfehler oder Kollisionen

    @glotix
    hab schon gesucht, aber nichts brauchbares gefunden

    Was bringt eigentlich das Apple Talk Protokoll?
     
    Pioneer, 18.07.2004
    #8
  9. starbuxx

    starbuxx MacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    Hi Pioneer,

    ich hab' grad nochmal ein bischen überlegt, was es sein könnte + ein wenig rumgegoogelt.

    Es gibt einen ganzen Haufen Lösungsansätze, z.T. kann es an Windows liegen, z.T. auch an OS X.

    Versuche mal folgende Einträge in
    Code:
    /private/etc/smb.conf:
    
    unter [globals]
    max xmit = 16644
    socket options = IPTOS_LOWDELAY TCP_NODELAY
    max xmit ist für die maximale framegrösse zuständig, evtl. auch kleiner wählen (8192). Die 'socket options' arbeiten ein wenig gegen das lahme 'Acknoledging' des Windows SMB Servers.

    Danach smbd neu starten.
    Code:
    killall nmbd -SIGHUP
    killall smbd -SIGHUP
    Weiterhin poste ich Dir einfach mal ein paar Links. Ich kann gerade allerdings nix davon testen, weil ich keinen Windows Rechner hier hab'.

    http://gertranssmb3.berlios.de/output/speed.html
    http://support.microsoft.com/default.aspx?scid=kb;DE;321169
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q321098&SD=MSKB
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;279282
    http://forums.macosxhints.com/archive/index.php/t-4976

    Versuche bei Deinen Tests soviel Software wie Möglich auf dem Win2000 und dem Mac auszuschalten.

    Viel Erfolg,
    sbx
     
    starbuxx, 18.07.2004
    #9
  10. glotis

    glotis MacUser Mitglied

    Mitglied seit:
    18.05.2004
    Beiträge:
    553
    Zustimmungen:
    7
    glotis, 19.07.2004
    #10
Die Seite wird geladen...
Ähnliche Themen - Verbindung Server sehr
  1. jaegermeisterh
    Antworten:
    3
    Aufrufe:
    1.338
    jaegermeisterh
    09.01.2013
  2. muelle
    Antworten:
    6
    Aufrufe:
    1.433
    Suruga
    20.04.2008
  3. harsiebus
    Antworten:
    0
    Aufrufe:
    1.133
    harsiebus
    13.03.2008
  4. mac_bahr
    Antworten:
    0
    Aufrufe:
    422
    mac_bahr
    27.12.2007
  5. alphaomega
    Antworten:
    1
    Aufrufe:
    1.234
    SM74
    17.08.2007