Umlaute beim Zugriff auf Samba-Server

  1. DanielG

    DanielG Thread StarterMacUser Mitglied

    Mitglied seit:
    22.01.2006
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo Forum,
    ich bin so eine Art Mac-Neuling und bin eigentlich schon recht zufrieden mit meinem iBook.
    Allerdings habe ich ein Problem: In meinem Netzwerk steht ein Linux-Rechner, auf dem Samba läuft. Der Dateiaustausch zwischen Windows und Linux klappt problemlos, auch die Umlaute sind hüben wie drüben in Ordnung.

    Das bringt mich natürlich auf die Idee, dass meine Probleme mit den Umlauten auf der Mac OS-Clientseite liegen. Jedoch weiß ich nicht wirklich, wo ich da den Hebel ansetzen kann... :confused:
    Kann mir vielleicht jemand weiterhelfen? Ich hoffe, ich bin hier im richtigen Forum gelandet...

    Grüße
    Daniel
     
    DanielG, 22.01.2006
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.160
    Zustimmungen:
    3.885
    hast du auch das charset auf dem samba server richtig eingestellt?
    das mac samba benutzt standard-mässig UTF-8
     
    oneOeight, 22.01.2006
  3. DanielG

    DanielG Thread StarterMacUser Mitglied

    Mitglied seit:
    22.01.2006
    Beiträge:
    14
    Zustimmungen:
    0
    Soo, bin dem mal auf den Grund gegangen.
    Das Charset im Mac-Samba ist auf UTF-8-MAC eingestellt.

    Wenn ich jetzt den samba-server auf UTF-8 einstelle, ändert sich gar nichts...
    Komisch ist auch, dass die dos client page in mac auf 437 eingestellt ist auf nem deutschen mac...
     
    DanielG, 22.01.2006
  4. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Wllkommen bei macuser.de.

    Ich schieb Dich mal nach Unix, da Dein Problem mit Mac OS X eigentlich nicht wirklich was zu tun hat und SAMBA ein Unix Server ist.
    Ich denke da findest Du auch das beste Publikum für Deine Frage
    Oder möchstest Du lieber nach Netzwerke?

    Hast Du denn schon die smb.conf Deiner Linux Kiste mit der vom Mac auf Unterschiede vergleichen.
    Welche Samba Version benutzt Du unter Linux?
     
    maceis, 23.01.2006
  5. DanielG

    DanielG Thread StarterMacUser Mitglied

    Mitglied seit:
    22.01.2006
    Beiträge:
    14
    Zustimmungen:
    0
    Okay, wenn du meinst dass ich hier mehr Publikum bekomme, glaub ich dir als Neuling mal. :p
    Die Samba-Version auf meinem Linux ist 3.0.14a-r2 (ist ein Gentoo-System).
    Und da hatte ich gestern mal UTF-8 als charset eingestellt, das hat aber nicht wirklich was gebracht...
    Wie empfindlich ist denn das Mac-Samba gegenüber Änderungen? Also muss ich da irgendwelche schweren Aussetzer erwarten, falls ich etwas falsch konfiguriere?
    Grüße...
     
    DanielG, 23.01.2006
  6. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Naj, das kommt darauf an, was Du falsch machst.
    Im großen und ganzen ist Samba aber eher robust.
     
    maceis, 23.01.2006
  7. teejot

    teejotMacUser Mitglied

    Mitglied seit:
    27.12.2003
    Beiträge:
    29
    Zustimmungen:
    0
    Hi,

    habe genau deine Netzkonfiguration. Sambaserver unter Gentoo (3.0.14a-r2) und iBook und Windows. Ich kann im Finder Dateien mit Umlauten erstellen und diese werden mir auch mit SSH auf dem Linuxrechner angezeigt. Windows weiss ich garnicht (US-Tastatur). Also Codepage hab ich nicht eingestellt bei Samba.

    Schau doch mal in /etc/profile.env (unter linux). dort finde ich die einzigen ländereinstellungen auf meinem gentoo-rechner.
    export LANG='en_US.utf8'
    export LANGUAGE='en_US.utf8'
    export LC_ALL='en_US.utf8'

    gruss
     
    teejot, 23.01.2006
  8. DanielG

    DanielG Thread StarterMacUser Mitglied

    Mitglied seit:
    22.01.2006
    Beiträge:
    14
    Zustimmungen:
    0
    Okay... das Anlegen von Verzeichnissen, die Umlaute enthalten, klappt einwandfrei.
    Aber wenn ich auf Dateien zugreife die Umlaute enthalten, werden sie auf mac nicht richtig angezeigt.
    Und wenn ich Umlaute mitm Mac einfüge, werden die danach unter linux und windows falsch angezeigt.
    In meinem gentoo habe ich die drei Variablen (LANG,LANGUAGE,LC_ALL) mal so gesetzt wie bei dir, aber es ändert nichts an der Gesamtsituation (bin unzufrieden damit... :D )

    Also ehrlichgesagt hätte ich ja nicht gedacht, dass das so eine schwere Geburt werden würde...

    P.S.: Kann ich eigentlich NFS mit Tiger mounten?
     
    DanielG, 23.01.2006
  9. osjumper

    osjumperMacUser Mitglied

    Mitglied seit:
    12.05.2003
    Beiträge:
    13
    Zustimmungen:
    0
    Linux NFS-share unter OSX mounten

    eigentlich ganz einfach: Apfel-K
    nfs://192.168.xxx.xxx/freigabename
    eintragen, sollte gehen. Bei mir kam dann immer die Meldung "Passwort falsch..." oder ähnlich. Die Lösung (hier bei ubuntu bzw. eisfair): in der /etc/exports auf dem Server muß der Parameter "insecure" eingefügt werden, dann klappts! OSX nutzt wohl zur Verbindungsaufnahme einen Port, der Linux nicht gefällt und ohne insecure dann kein mount. Beispiel:

    # /etc/exports
    /public 192.168.0.0/255.255.255.0(rw,async,insecure)
     
    osjumper, 27.01.2006
  10. DanielG

    DanielG Thread StarterMacUser Mitglied

    Mitglied seit:
    22.01.2006
    Beiträge:
    14
    Zustimmungen:
    0
    Ich hab eigentlich hier schonmal ein Thema aufgemacht mittlerweile und das Problem besteht auch weiterhin... Also Protocol not supported, wenn ich im Terminal versuche zu mounten.
    Und nach Apfel-K meckert er "Name oder Kennwort ungültig"... Muss ich jetzt noch uids mappen oder was?

    Es kann doch nicht sooo schwer sein hier mal irgendeine Netzwerkverbindung zum laufen zu bringen bei der dann auch noch die Umlaute funktionieren... :mad:
     
    DanielG, 27.01.2006
Die Seite wird geladen...
Ähnliche Themen - Umlaute beim Zugriff
  1. fantaeiner
    Antworten:
    16
    Aufrufe:
    924
  2. bolshi
    Antworten:
    0
    Aufrufe:
    1.034
  3. janlange
    Antworten:
    8
    Aufrufe:
    5.311
    janlange
    18.11.2009
  4. grünspam
    Antworten:
    2
    Aufrufe:
    626
    grünspam
    05.11.2007
  5. Zucki
    Antworten:
    5
    Aufrufe:
    1.245