Benutzerdefinierte Suche

Tooltipps funktionieren nicht unter OS X!?

  1. unit02

    unit02 Thread StarterMacUser Mitglied

    Mitglied seit:
    08.12.2003
    Beiträge:
    58
    Zustimmungen:
    0
    Hallo!

    Vorweg: Ich bin kein HTML Profi... eher das Gegenteil!
    Beim programmieren meiner Homepage habe ich ein Problem.

    Es gibt verschiedene Bilder auf meiner Seite. Der Inhalt soll Stichwortartig als "Tooltip" wiedergegeben werden (also wenn der Mauszeiger auf dem Bild ruht". Den entsprechenden Text habe ich am jeweiligen Bild mit ´alt="Text"´ eingefügt.

    Mit meinem Browser (Internet Explorer) auf der Arbeit funktioniert es auch. Auf meinem Mac funktioniert es leider nicht. Weder auf Safari, Camino noch dem Explorer... woran könnte das liegen?

    Mein System: aktuelles OS X

    PS: Die Bilder sind auf der Seite als Tumbnails, das entsprechende große Bild öffnet sich beim anklicken des Tumbnails in einem eigenen Fenster `_blank`.
    Gibt es einen Befehl, der das Bild in einem Popup, also nicht in einem "richtigen" neuen Browserfenster öffnet?
     
    unit02, 03.09.2004
  2. abgemeldeter Benutzer

    abgemeldeter Benutzer

    Klick mal hier im Forum auf Neue Beiträge und lass den Mauszeiger über einem Titel ruhen. Dann siehst Du, dass die Tooltipps durchaus funktionieren. Es liegt also nicht an OS X oder Safari.
     
    abgemeldeter Benutzer, 03.09.2004
  3. unit02

    unit02 Thread StarterMacUser Mitglied

    Mitglied seit:
    08.12.2003
    Beiträge:
    58
    Zustimmungen:
    0
    Super Tipp! Danke!


    Danke! Vielleicht hätte ich dazu schreiben sollen, dass mir bekannt ist, dass es auf anderen Seiten durchaus funktioniert... wichtiger ist mir aber, dass es auf meiner Seite eben nicht funktioniert. Deshalb habe ich ja auch angegeben, welchen Befehl ich dazu verwendet habe.
     
    unit02, 03.09.2004
  4. Erika

    ErikaMacUser Mitglied

    Mitglied seit:
    03.01.2004
    Beiträge:
    232
    Zustimmungen:
    0
    Hallo init02,

    Du hast bestimmt noch nicht das aktuelle OSX. Erst ab 3 scheint es zu funktionieren.
    Gib doch mal den Pfad an und frag dann hier an wer was sieht.

    Erika
     
    Erika, 03.09.2004
  5. Brandhoff

    BrandhoffMacUser Mitglied

    Mitglied seit:
    07.02.2004
    Beiträge:
    401
    Zustimmungen:
    0
    In das "alt"-Tag gehört eigentlich ein kurzer Beschreibungstext zur zugeordneten Grafik, der erscheint, solange das Bild geladen wird oder falls es nicht geladen werden kann (vom Nutzen für barrierefreies Webdesign mal abgesehen). Der IE bildet den Text in vorlauter Weise als "Tooltip" ab, obwohl er es nicht sollte.

    Was du verwenden solltest, ist der "title"-Tag. Dieser ist für längere Beschreibungen gedacht, wobei die Syntax dann so aussehen kann:

    Code:
    <img src="pics/galerie.gif" alt="Galerie" title="In der Galerie k&ouml;nnen Sie meine Grafiken bewundern.">
    Die von dir angesprochene Popup-Funktion für die Großansichten ist nur per JavaScript realisierbar.

    cheers.
     
    Brandhoff, 03.09.2004
  6. unit02

    unit02 Thread StarterMacUser Mitglied

    Mitglied seit:
    08.12.2003
    Beiträge:
    58
    Zustimmungen:
    0
    Danke!

    Danke, anscheinend hatte ich mein Problem wohl nicht deutlich genug beschrieben... Deshalb freut es mich jetzt ganz besonders, daß es doch jemand erkannt hat! Werde den Code sofort ändern, wenn ich wieder an meinen Rechner komme. Vielen Dank für die Hilfe! In meinem HTML-Buch steht der "title"-Tag nicht... ist wohl schon etwas älter...
     
    unit02, 03.09.2004
  7. Brandhoff

    BrandhoffMacUser Mitglied

    Mitglied seit:
    07.02.2004
    Beiträge:
    401
    Zustimmungen:
    0
    SelfHTML weiß so was. ;)

    Da findest du btw auch ein kleines Tutorial zu Popups, mal ganz abgesehen von so ziemlich allem, was mit HTML, CSS und JavaScript zu tun hat.

    cheers.
     
    Brandhoff, 04.09.2004
Die Seite wird geladen...
Ähnliche Themen - Tooltipps funktionieren
  1. Manni1306
    Antworten:
    0
    Aufrufe:
    1.115
    Manni1306
    08.10.2011
  2. ikleinOtti
    Antworten:
    6
    Aufrufe:
    1.961
    ikleinOtti
    12.04.2010
  3. Denise/Bay
    Antworten:
    18
    Aufrufe:
    1.619
    Denise/Bay
    18.03.2010
  4. hello
    Antworten:
    1
    Aufrufe:
    1.175