TeXShop setzt keine Umlaute

  1. visby7

    visby7 Thread Starter MacUser Mitglied

    Mitglied seit:
    09.09.2005
    Beiträge:
    25
    Zustimmungen:
    0
    LateX hat mich sehr interessiert. Also habe ich von http://www.tug.org/mactex/ MacTeX.dmg heruntergeladen und installiert. Nun bleibe ich schon am Anfang an einem mir unerklärlichen Fehler hängen: nach dem Setzen fehlen im Text die deutschen Umlaute und das "ß". Irgendetwas scheint beim Installieren nicht auf den richtigen Pfad gekommen zu sein. Die Modifikationen der Kodierung z.B. MacOSRoman, Iso Latin 1, UTF-8 etc. bringt nichts. Die Umlaute bleiben weg.

    Hat jemand eine Idee, was zu tun ist?
     
  2. peterg

    peterg MacUser Mitglied

    Mitglied seit:
    02.03.2005
    Beiträge:
    2.755
    Zustimmungen:
    184
    Hallo,

    genau die Modifikation der Umlaute. Bedenke: es gibt einmal Einstellungen für die Eingabe über die Tastatur und zum anderen hinsichtlich der Umsetzung beim Setzen der Datei. Lies doch noch mal in der Doku nacht: Stichworte inputenc und Sprachpakete.

    Peter
     
  3. visby7

    visby7 Thread Starter MacUser Mitglied

    Mitglied seit:
    09.09.2005
    Beiträge:
    25
    Zustimmungen:
    0
    Alle Einstellungen, die ich finden kann stehen auf MacOSRoman.

    Es wird aber dieser Text (so steht er im TeXShop-Editor): Universität Zürich
    so gesetzt: Universitt Zrich

    Dieser Text (Editor): Universit\"at Z\"urich
    liest sich nach dem setzen so: Universität Zürich

    Es gibt noch eine weitere Erstaunlichkeit!

    Dies: %\date{}
    wird zu: February 3, 2007

    Dies: \date{}
    bringt kein Datum!!!!

    Logisch finde ich das nicht!

    Gruß
    Visby7
     
  4. E. Hindman

    E. Hindman MacUser Mitglied

    Mitglied seit:
    27.07.2005
    Beiträge:
    348
    Zustimmungen:
    45
    Teil meines Standard-Headers:

    \usepackage[ngerman]{babel}
    \usepackage[T1]{fontenc}
    \usepackage[applemac]{inputenc}

    damit solltest du weiter kommen.

    Versuch mal \today für das heutige Datum.
     
  5. dehose

    dehose unregistriert

    Mitglied seit:
    05.03.2004
    Beiträge:
    5.166
    Zustimmungen:
    492
    Teil meines Headers:

    \usepackage[ngerman]{babel}
    \usepackage[latin1]{inputenc}
    \usepackage[T1]{fontenc}

    abgespeichert unter Iso Latin 1 Codierung. Umlaute und Sonderzeichen sind kein Problem.
     
  6. E. Hindman

    E. Hindman MacUser Mitglied

    Mitglied seit:
    27.07.2005
    Beiträge:
    348
    Zustimmungen:
    45
    Das Eurozeichen ist aber auch mit Latin ein Problem.
    Ich hab dafür
    \usepackage{eurosym} \let € = \euro
    im Header.
     
  7. neptun

    neptun MacUser Mitglied

    Mitglied seit:
    28.09.2003
    Beiträge:
    2.017
    Zustimmungen:
    22
    Würde ich auch so empfehlen.
    Mit "applemac" verzichtet man unnötigerweise auf die Kompatibilität mit anderen Systemen.

    Gruss, neptun

    P.S. Der Titel ist übrigens irreführend - das Problem hat nichts mit TeXShop zu tun.
     
  8. E. Hindman

    E. Hindman MacUser Mitglied

    Mitglied seit:
    27.07.2005
    Beiträge:
    348
    Zustimmungen:
    45
    Ich nehm alles zurück und behaupte das Gegenteil. :)
    Hatte "applemac" in meinen ersten LaTex Tagen aufgeschnappt und bis heute nie hinterfragt.
     
  9. visby7

    visby7 Thread Starter MacUser Mitglied

    Mitglied seit:
    09.09.2005
    Beiträge:
    25
    Zustimmungen:
    0
    Es funktioniert :)

    Vielen Dank auch!
     
  10. neptun

    neptun MacUser Mitglied

    Mitglied seit:
    28.09.2003
    Beiträge:
    2.017
    Zustimmungen:
    22
    Mit % machst du den Befehl zu einem Kommentar; fürs Datum wird also "default value" eingesetzt, also das heutige Datum.
    Klar - mit dem leeren String zwischen den geschweiften Klammern veranlasst du, dass das Datum leer bleibt.
    Doch - das ist sehr logisch ;)

    Gruß, neptun
     
Die Seite wird geladen...