Terminal startet nicht mehr korrekt

  1. zordak

    zordak Thread Starter MacUser Mitglied

    Mitglied seit:
    10.06.2004
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo allerseits,

    habe erst vor 2 Jahren zu MacOS X gewechselt und bin darum noch recht unbeholfen im Umgang mit dem Mac, aber bin dem Mythos Apple verfallen, wie man sieht. Seit einer Stunde versuche ich aber schon folgendes Problem in den Griff zu bekommen:

    ich habe vorhin mit einem kleinen Interpreter gearbeitet, der sich mosml nennt; ist ne kleine Programmiersprache, die ich lernen muß.

    Jedenfalls läuft dieses mosml Programm in einem Terminalfenster unter mac os. Um einige Probleme mit der Tastatur zu beheben hab ich in den Terminaleinstellungen unter "Terminal"-> "Fenstereinstellungen" einige Sache in hinsicht auf Emulation etc. geändert. Danach habe ich auf "als Standard verwenden" geklickt und schon hatte ich den Salat.

    Danach wollte ich ein neues Bashfenster öffnen (um mit ssh zu arbeiten) und stattdessen startet direkt der Interpreter im Terminalfenster, wenn ich auf "Terminal" klicke. Komme also nicht mehr in die bash. Hab "Terminal" auch schon direkt aus dem Programmverzeichnis aufgeführt, nix. Er springt immer wieder direkt in mein Programm und begrüßt mich mit der Meldung

    wenn ich meinen interpreter verlasse (also mit quit() ) bekomm ich ein

    und mein Terminalprozess ist beendet. Wie man sieht steht hier in irgendeiner Konfigurationsdatei der bash, dass sie mosml starten und nach beenden des Programms die bash verlassen soll.

    Habe mir schon das Programm Xupport geladen (wie hier schon einmal beschrieben wurde) und damit versucht diverse versteckte Konfigurationsdateien für die bash zu finden, aber war nicht von Erfolg gekrönt. Außer einer .bash_history ist mir nichts aufgefallen.

    Auch ein "Befehl ausführen" /bin/bash --rc brachte nichts.

    Bin momentan echt ratlos und hab keine Ahnung, wie ich mein Terminalfenster reparieren kann. Für Hilfe wäre ich euch sehr dankbar.

    Grüße
    Daniel
     
    zordak, 04.11.2005
    #1
  2. autoexec.bat

    autoexec.bat MacUser Mitglied

    Mitglied seit:
    21.01.2005
    Beiträge:
    2.113
    Zustimmungen:
    20
    Der Eintrag sollte eigentlich in der Datei

    .bash_profile

    in deinem Benutzerverzeichnis bzw. in

    /etc/bashrc

    oder

    /etc/profile

    zu finden sein.
     
    autoexec.bat, 05.11.2005
    #2
  3. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.160
    Zustimmungen:
    3.885
    .profile oder .bashrc im home
    oder halt mal wieder das com.apple.terminal.plist file in ~/Library/Preferences löschen
     
    oneOeight, 05.11.2005
    #3
  4. zordak

    zordak Thread Starter MacUser Mitglied

    Mitglied seit:
    10.06.2004
    Beiträge:
    12
    Zustimmungen:
    0
    @jalapeno leider hab ich kein .bash_profile und im rest steht nix drin außer ein paar tex infos

    @oneOeight vielen dank! das com.apple.terminal.plist file löschen hat den gewünschten erfolg gebracht. wär ich nie drauf gekommen =)
     
    zordak, 05.11.2005
    #4
Die Seite wird geladen...
Ähnliche Themen - Terminal startet korrekt
  1. Macs Pain
    Antworten:
    14
    Aufrufe:
    530
    Macs Pain
    14.07.2017
  2. schnorri
    Antworten:
    3
    Aufrufe:
    105
    loewenstromer
    02.07.2017
  3. CmYk1987
    Antworten:
    2
    Aufrufe:
    537
    oneOeight
    30.03.2010
  4. 1248mac
    Antworten:
    7
    Aufrufe:
    502
    cilly
    18.11.2004
  5. PeterDickten
    Antworten:
    4
    Aufrufe:
    723
    PeterDickten
    11.04.2004