Terminal loggt sich automatisch via SSH auf server ein.

  1. starbuxx

    starbuxx Thread StarterMacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    Gruess Euch,

    folgendes aergert mich schon seit laengerem:

    wenn ich Terminal.app starte, verbindet es sich immer automatisch mit dem sshd auf meinem Debian Server. Normalerweise mache ich diese Logins aus Komfortgruenden mit JellyFiSSH.

    Das sieht dann nach dem Klick auf Terminal.app so aus:
    Code:
    grzmpf:~ sbx$ ssh -c 3des -2 -l root 192.168.1.10 -p 22;exit
    Password: 
    Um auf meine lokale Shell zu kommen, muss ich immer den Umweg ueber Rechtsklick -> Neuer Befehl '/bin/bash' + [x] Befehl in eigener Shell ausführen machen.

    Eine .xterm Datei existiert nicht in /Users/meinname/Library/Application Support.

    Weiss jemand von Euch wie ich das meinem Terminal wieder abgewöhnen kann?

    Gruesse,
    sbx
     
    starbuxx, 29.09.2005
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.174
    Zustimmungen:
    3.889
    da wird wohl irgendwo in einer der shell startup dateien das ssh mit drin stehen...
    probier doch mal ein "grep ssh .*" in deinem home
     
    oneOeight, 29.09.2005
  3. starbuxx

    starbuxx Thread StarterMacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    hi oneOeight,

    hm. das steht nur in der .bash_history.

    die hab' ich mal geloescht -> hat aber nix gebracht.

    any further ideas?

    gruesse,
    sbx

    edit: ich lass grad mal
    Code:
    find / -name ".*" -exec grep "ssh -c 3des -2" {} \;
    laufen. vielleicht findet das ja noch was.
     
    starbuxx, 29.09.2005
  4. starbuxx

    starbuxx Thread StarterMacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    hm

    irgendwas hat er nach einer weitern suche in /Users/meinname/Library/Preferences/com.apple.Terminal.plist gefunden. das ist aber eine binary, die ich mit pico nicht bearbeiten konnte.

    ich hab' sie einfach mal umbenannt und Terminal.app nochmal gestartet -> voila!

    jetzt muss ich zwar mein Terminal neu einstellen, aber das ist allemal ok.

    gibts eigentlich ein programm womit man diese 'binary' .plists bearbeiten kann?

    gruesse und danke,
    sbx
     
    starbuxx, 29.09.2005
  5. Horror

    HorrorMacUser Mitglied

    Mitglied seit:
    03.02.2003
    Beiträge:
    1.416
    Zustimmungen:
    9
    Ja, das mit dem Terminal ist mir auch schon passiert.

    Bearbeiten kannst du die Files mit dem Property List Editor unter /Developer/Applications/Utilities.

    Dirk
     
    Horror, 29.09.2005
  6. starbuxx

    starbuxx Thread StarterMacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    hi horror!
    danke fuer den tip!

    sbx
     
    starbuxx, 29.09.2005
  7. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.174
    Zustimmungen:
    3.889
    dann hattest du wohl in den terminal einstellungen das "beim öffnen eines terminal fensters folgen befehl ausführen" aktiviert gehabt...
     
    oneOeight, 29.09.2005
  8. starbuxx

    starbuxx Thread StarterMacUser Mitglied

    Mitglied seit:
    13.04.2003
    Beiträge:
    1.442
    Zustimmungen:
    8
    @oneoeight
    nee, lustigerweise nicht. da hab' ich ja zuerst geschaut.

    danke trotzdem!

    gruesse,
    sbx
     
    starbuxx, 29.09.2005
  9. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Code:
    plutil -convert xml1 /Users/meinname/Library/Preferences/com.apple.Terminal.plist \
    && pico /Users/meinname/Library/Preferences/com.apple.Terminal.plist
     
    maceis, 29.09.2005
  10. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Ach so, noch was:
    Das kann man einfacher haben:
    Code:
    grep -r "ssh -c 3des -2" /
    Mit -exec dauert es wesentlich länger.
    "-name ".*"" kannst Du auch weglassen, wenn Du alle Dateien finden möchtest.
     
    maceis, 29.09.2005
Die Seite wird geladen...
Ähnliche Themen - Terminal loggt automatisch
  1. urus
    Antworten:
    15
    Aufrufe:
    471
  2. Bozol
    Antworten:
    0
    Aufrufe:
    182
  3. Huckflysh
    Antworten:
    12
    Aufrufe:
    797
    oneOeight
    07.02.2017
  4. tdrocks
    Antworten:
    0
    Aufrufe:
    308
    tdrocks
    30.01.2017
  5. Lito
    Antworten:
    2
    Aufrufe:
    1.361