Benutzerdefinierte Suche

Terminal (entf) kaputt

  1. theWireless

    theWireless Thread StarterMacUser Mitglied

    Mitglied seit:
    27.06.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Bei mir im Terminal ging' die Entf-Taste (Fn + Backspace) nicht. Er hat dafür immer ein ~ geschrieben. In VIM z.B. aber hat er dann, wie er es auch soll, den Buchstaben, der vor dem Cursor stand, brav entfernt. Ich hab' dann bischen in den Fenstereinstellungen rumgespielt, was wohl ein Fehler war :D Nun macht er in VIM z.B. den Buchstaben, der vor dem Cursor steht, groß - er wandelt in in einen Großbuchstaben um. Was hab' ich da getan? Ich bekomm' das nichmehr weg :) Und wie krieg' ich das so hin, dass er auch im "normalen" Terminal die Entf-Taste richtig interpretiert?

    TIA
     
    theWireless, 03.04.2005
  2. theWireless

    theWireless Thread StarterMacUser Mitglied

    Mitglied seit:
    27.06.2004
    Beiträge:
    80
    Zustimmungen:
    0
    ach kommt schon, weis da keiner was? Is echt wichtig, ich kann so nich arbeiten *grml*
     
    theWireless, 04.04.2005
  3. nidhoegg

    nidhoeggMacUser Mitglied

    Mitglied seit:
    18.07.2004
    Beiträge:
    787
    Zustimmungen:
    1
    Mal im Ernst, seit wann löscht man in vim Buchstaben mit de entf -Taste? :D
    Ich kenne das von Dir beschriebene Verhalten nur von vi.
    Hast Du vielleicht den vi-Kompartibilitätsmodus von vim eingeschaltet?

    Gruß, nidhoegg
     
    nidhoegg, 04.04.2005
  4. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.176
    Zustimmungen:
    3.891
    schon mal die fenstereinstellungen/tastatur gecheckt? und da die feine und kleine checkbox "Entf.-Taste sendet Rückschrittzeichen" entdeckt?
     
    oneOeight, 04.04.2005
  5. theWireless

    theWireless Thread StarterMacUser Mitglied

    Mitglied seit:
    27.06.2004
    Beiträge:
    80
    Zustimmungen:
    0
    @nidhoegg: lass mich doch meine Buchstaben löschen wie ich das will ;)
    wie deine Sig schon sagt: "free as in freedom" steht es mir doch auch frei, wie ich was lösche...

    Nein, ich hab' in VIM nix eingeschaltet. Ich glaube nicht, dass ich auf meinen 3 Servern auf allen die gleiche Einstellung verbockt habe.

    @oneOeight: meine Güte ja - aber es geht nicht!!!
     
    theWireless, 04.04.2005
  6. Ivanovic

    IvanovicMacUser Mitglied

    Mitglied seit:
    02.06.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Hi!
    Hab heute die Lösung dafür gefunden. Man erstellt eine Datei namens .inputrc in seinem Home-Verzeichniss. Dort fügt man
    Code:
    "\e[3~": delete-char 
    ein.
    Es sollte auch über die Konfiguration von Terminal gehen. Fesntereinstellungen--> Tastatur --> entf passend setzen.
    Ich hoffe es hat dir geholfen.
     
    Ivanovic, 02.06.2005
Die Seite wird geladen...
Ähnliche Themen - Terminal (entf) kaputt
  1. Macs Pain
    Antworten:
    14
    Aufrufe:
    538
    Macs Pain
    14.07.2017
  2. schnorri
    Antworten:
    3
    Aufrufe:
    106
    loewenstromer
    02.07.2017
  3. uhlhorn
    Antworten:
    11
    Aufrufe:
    332
    Olivetti
    19.05.2017
  4. thb
    Antworten:
    15
    Aufrufe:
    632
    Olivetti
    15.05.2017
  5. Muecke.1982

    Daten Löschen mit Entf.

    Muecke.1982, 20.10.2014, im Forum: Mac OS
    Antworten:
    6
    Aufrufe:
    616
    Muecke.1982
    20.10.2014