Systemeinstellungen verschwunden 10.6.7

AntiFlagAA

Neues Mitglied
Thread Starter
Mitglied seit
11.05.2011
Beiträge
9
Hallo zusammen

Folgendes Problem:

beim Öffnen der Systemeinstellungen habe ich nur Growl unter "Sonstige" zur

Verfügung und der Rest fehlt.

Das Ganze geschah von jetzt auf gleich und ich bin mir keiner Schuld bewusst.

Ich habe keine Programme installiert oder sonstige dubiose Dateien geöffnet.

Beim Versuch die Einstellungen über das WLAN Zeichen zu öffnen erscheint

folgende Fehlermeldung:

""Die Systemeinstellung „Netzwerk“ kann nicht installiert werden, da sie bereits installiert ist.
Die Systemeinstellung „Netzwerk“ ist Teil von Mac OS X und kann nicht ersetzt werden.""

Danke für Antworten

Anti
 

Anhänge

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
Lade mal das 10.6.7 Combo Update und installier das drüber.
 

dannycool

Aktives Mitglied
Mitglied seit
02.02.2005
Beiträge
1.493
Tipp mal im Terminal
Code:
ls -la /System/Library/PreferencePanes
Das sollte ein Schwung von Zeilen geben die alle mit drwxr-xr-x oder lrwxr-xr-x anfangen, ist das bei dir anders?
 

blue apple

Aktives Mitglied
Mitglied seit
01.12.2005
Beiträge
17.364
von der system-dvd und pacifist die PreferencePanes nachinstallieren
 

AntiFlagAA

Neues Mitglied
Thread Starter
Mitglied seit
11.05.2011
Beiträge
9
hs-134-012:~ Alex$ ls -la /System/Library/PreferencePanes
total 8
drwxr-xr-x 32 root wheel 1088 27 Okt 2010 .
drwxr-xr-x 63 root wheel 2142 28 Mär 2010 ..
drwxr-xr-x 3 root wheel 102 7 Dez 2009 Accounts.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Appearance.prefPane
drwxr-xr-x 3 root wheel 102 23 Mär 2010 Bluetooth.prefPane
drwxr-xr-x 3 root wheel 102 17 Dez 2009 DateAndTime.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 DesktopScreenEffectsPref.prefPane
drwxr-xr-x 3 root wheel 102 25 Feb 2010 DigiHubDiscs.prefPane
drwxr-xr-x 3 root wheel 102 21 Jan 2010 Displays.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Dock.prefPane
drwxr-xr-x 3 root wheel 102 21 Jan 2010 EnergySaver.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Expose.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 FibreChannel.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Ink.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 Keyboard.prefPane
drwxr-xr-x 3 root wheel 102 28 Jan 2010 Localization.prefPane
lrwxr-xr-x 1 root wheel 17 28 Mär 2010 Mac.prefPane -> MobileMe.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 MobileMe.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 Mouse.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Network.prefPane
drwxr-xr-x 3 root wheel 102 17 Mär 2010 ParentalControls.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 PrintAndFax.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 Security.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 SharingPref.prefPane
drwxr-xr-x 3 root wheel 102 4 Jan 2010 SoftwareUpdate.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Sound.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Speech.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 Spotlight.prefPane
drwxr-xr-x 3 root wheel 102 27 Jan 2010 StartupDisk.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 TimeMachine.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 Trackpad.prefPane
drwxr-xr-x 3 root wheel 102 4 Mär 2010 UniversalAccessPref.prefPane
so sieht das aus...
 

blue apple

Aktives Mitglied
Mitglied seit
01.12.2005
Beiträge
17.364
dann sind sie scheinbar noch vorhanden?
suche mal mit cmd+f nach einer dieser datei, aber systemfiles anhaken... (oder nimm easyfind als alternative)
 

AntiFlagAA

Neues Mitglied
Thread Starter
Mitglied seit
11.05.2011
Beiträge
9
die Dateien sind im Ordner alle noch vorhanden

wenn ich sie aber anklicke, kommt die Sache mit dem installieren...

ich will aber nichts neu installieren sonderen nur die Einstellungen öffnen :((
 

blue apple

Aktives Mitglied
Mitglied seit
01.12.2005
Beiträge
17.364
neustart gemacht?
eventuell ein safe boot und pram-reset machen...
 

dannycool

Aktives Mitglied
Mitglied seit
02.02.2005
Beiträge
1.493
Seltsam :)

Es gibt da noch einen Cache. Den kann man bedenkenlos löschen aber ich weiß nicht ob das was bringt:
Code:
rm ~/Library/Caches/com.apple.preferencepanes.*
Ansonsten auch mal testweise einen anderen User anlegen und gucken ob es da funktioniert.
 

AntiFlagAA

Neues Mitglied
Thread Starter
Mitglied seit
11.05.2011
Beiträge
9
Neustart auch zigmal gemacht

safeboot auch schon probiert funzt auch da nicht :(

ich dreh durch

wie soll ich nen anderen User anlegen wenn ich an die Benutzereinstellungen auch nicht mehr ran komm?
 

manue

Aktives Mitglied
Mitglied seit
17.11.2006
Beiträge
27.147
OSX DVD rein und das System drüber installieren.
Dauert 20 Minuten und danach gehts 100% wieder.

Bevor man sich blöde sucht... :)

edit: Okay, da ging wohl das "blöde Suchen" schneller ... :hehehe:
 

dannycool

Aktives Mitglied
Mitglied seit
02.02.2005
Beiträge
1.493
Ok, so rückblickend klang es eigentlich auch ein wenig wie ein korrupter Cache...

Account anlegen geht im Terminal mit dscl, aber das ist etwas fiddelig und natürlich komplett anders als jedes andere Unix oder Mac OS X 10.4 oder älter... ;)
 
Oben