System friert ein

Strunz2

Mitglied
Thread Starter
Dabei seit
09.12.2009
Beiträge
172
Punkte Reaktionen
4
Hallo,

ich habe ein MacBook und darauf "Debian Bullseye" installiert.
Nach einer Weile friert das System ein, ich kann keine Maus bzw. keine
Tastatur mehr verwenden!

Unter /var/log/Xorg.0.log

kommt folgenden Fehlermeldung:

No input driver specified, ignoring this device.

Wer kann mir weiterhelfen?

Mfg
Strunz2
 

Roman78

Aktives Mitglied
Dabei seit
02.10.2006
Beiträge
5.901
Punkte Reaktionen
3.327
Was für ein MacBook ist es? Läuft MacOS ohne dieses Problem? Hast du schon mal eine USB-Maus oder Tastatur probiert? Läuft die Zeit weiter wenn die Maus und Tastatur nicht mehr funktionieren?
 

Strunz2

Mitglied
Thread Starter
Dabei seit
09.12.2009
Beiträge
172
Punkte Reaktionen
4
Hallo,

ich habe von "Bullseye" auf "Bookworm" geupdatet und folgende Dateien installiert:
ii libinput-bin 1.20.1-1 amd64 input device management and event handling library - udev quirks
ii libinput10:amd64 1.20.1-1 amd64 input device management and event handling library - shared library
ii xserver-xorg-input-libinput 1.2.1-1+b1 amd64 X.Org X server -- libinput input driver

Anbei findet ihr meine "xorg.conf"
Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    InputDevice    "Synaptics Touchpad" "CorePointer"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    Screen         "Screen 0" 0 0
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection
      
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Option          "CorePointer"           "true"
    Option          "SendCoreEvents"        "true"
    Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/input/mice"
        Option          "SHMConfig"             "true"
        Option          "MaxTapTime"            "0"
        Option          "HorizScrollDelta"      "0"
        Option          "VertScrollDelta"       "30"
        Option          "TapButton1"            "0"
        Option          "TapButton2"            "0"
        Option          "TapButton3"            "0"
EndSection


Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "CoreKeyboard"
        Option      "XkbRules"      "xorg"
        Option      "XkbModel"      "pc105"
        Option      "XkbLayout"     "de"
    Option      "XKBVARIANT"    "mac
        Option      "XkbOptions"    "lv3:rwin_switch,apple:badmap"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "HWcursor"               # [<bool>]
        #Option     "NoAccel"                # [<bool>]
        #Option     "ShadowFB"               # [<bool>]
        #Option     "VideoKey"               # <i>
        #Option     "WrappedFB"              # [<bool>]
        #Option     "GLXVBlank"              # [<bool>]
        #Option     "ZaphodHeads"            # <str>
        #Option     "PageFlip"               # [<bool>]
        #Option     "SwapLimit"              # <i>
        #Option     "AsyncUTSDFS"            # [<bool>]
        #Option     "AccelMethod"            # <str>
        #Option     "DRI"                    # <i>
    Identifier  "Card0"
    Driver      "nouveau"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen "
    Identifier "Screen 0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection


Hoffe ihr könnt mir weiterhelfen ;-)

Mfg
Strunz2
 

Strunz2

Mitglied
Thread Starter
Dabei seit
09.12.2009
Beiträge
172
Punkte Reaktionen
4
Ich habe die Lösung: :)
Folgende Pakete (Testing) installiert:

ii libinput-bin 1.21.0-1 amd64 input device management and event handling library - udev quirks
ii libinput10:amd64 1.21.0-1 amd64 input device management and event handling library - shared library
ii xserver-xorg-input-libinput 1.2.1-1+b1 amd64 X.Org X server -- libinput input driver
 
Oben