SSH-Zugriff nicht möglich?

Mauki

Aktives Mitglied
Thread Starter
Mitglied seit
24.07.2002
Beiträge
15.411
Ich möchte von meinem iBook aus via Terminal auf einen VDR zugreifen. Der Zugriff per Sama geht problemlos nur per SSH komm ich nicht drauf.

Ich gebe im Terminal folgendes an "ssh Benutzer@192.168.xxx.xx". Ich werde dann nach einem PW gefragt. Ich gebe dann das PW ein und werde nochmals gefragt. Nach der dritten Eingabe wird mit folgendem Fehler abgebrochen.

Code:
Password: 
Password: 
Password: 
Permission denied (publickey,keyboard-interactive).
[Prozess abgebrochen - Ergebnis 255]
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.227
tja, falsches passwort würde ich sagen ;)
oder der user darf nicht connecten...
 

Mauki

Aktives Mitglied
Thread Starter
Mitglied seit
24.07.2002
Beiträge
15.411
Das PW ist korrekt. SSH Zugriff ist auf dem VDR freigeschaltet.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.227
wenn du sicher bist, dass das passwort korrekt ist, dann darf der sich user wohl nicht einloggen oder nur mit pubkey. in den sshd einstellungen mal checken...
 

Mauki

Aktives Mitglied
Thread Starter
Mitglied seit
24.07.2002
Beiträge
15.411
Ich habs jetzt mal probiert in dem ich auf Verbinden mit gehe. Da wähl ich SSH aus, geben unten root an und als Server "ssh 192.168.xxx.xx".

Es kommt aber die gleiche Meldung wie oben. SSH ist aktiviert und der Benutzer und PW ist richtig?

Bin völlig ratlos :confused:
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.227
mach doch mal ein ssh -vvvv für den debug output von ssh, vielleicht steht da was für dich rat bringendes...
 

Mauki

Aktives Mitglied
Thread Starter
Mitglied seit
24.07.2002
Beiträge
15.411
Da erhalten ich folgendes:

Code:
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
usage: ssh [-1246AaCfgkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-i identity_file] [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-w local_tun[:remote_tun]] [user@]hostname [command]
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.227
natürlich musst du es mit
ssh -vvvv benutzer@host
probieren...
du willst ja gucken, was beim einloggen schief geht...
 

Mauki

Aktives Mitglied
Thread Starter
Mitglied seit
24.07.2002
Beiträge
15.411
So jetzt sieht es anders aus:

Code:
ssh -vvvv benutzer@hostLast login: Sat Apr  5 15:47:25 on ttyp2
Welcome to Darwin!
ibook:~ Mauki$ ssh -vvvv root@192.168.178.20
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.178.20 [192.168.178.20] port 22.
debug1: connect to address 192.168.178.20 port 22: Host is down
ssh: connect to host 192.168.178.20 port 22: Host is down
ibook:~ Mauki$ ssh -vvvv root@192.168.178.20
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.178.20 [192.168.178.20] port 22.
debug1: Connection established.
debug1: identity file /Users/Mauki/.ssh/identity type -1
debug1: identity file /Users/Mauki/.ssh/id_rsa type -1
debug1: identity file /Users/Mauki/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7
debug1: match: OpenSSH_4.7 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug2: fd 3 setting O_NONBLOCK
debug1: An invalid name was supplied
Configuration file does not specify default realm

debug1: An invalid name was supplied
Configuration file does not specify default realm

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_init: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 133/256
debug2: bits set: 545/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: filename /Users/Mauki/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 7
debug1: Host '192.168.178.20' is known and matches the RSA host key.
debug1: Found key in /Users/Mauki/.ssh/known_hosts:7
debug2: bits set: 520/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /Users/Mauki/.ssh/identity (0x0)
debug2: key: /Users/Mauki/.ssh/id_rsa (0x0)
debug2: key: /Users/Mauki/.ssh/id_dsa (0x0)
debug1: Authentications that can continue: publickey,keyboard-interactive
debug3: start over, passed a different list publickey,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/Mauki/.ssh/identity
debug3: no such identity: /Users/Mauki/.ssh/identity
debug1: Trying private key: /Users/Mauki/.ssh/id_rsa
debug3: no such identity: /Users/Mauki/.ssh/id_rsa
debug1: Trying private key: /Users/Mauki/.ssh/id_dsa
debug3: no such identity: /Users/Mauki/.ssh/id_dsa
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 1
Password: 
debug3: packet_send2: adding 32 (len 21 padlen 11 extra_pad 64)
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 0
debug3: packet_send2: adding 48 (len 10 padlen 6 extra_pad 64)
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 0
debug3: tty_make_modes: ospeed 9600
debug3: tty_make_modes: ispeed 9600
debug3: tty_make_modes: 1 3
debug3: tty_make_modes: 2 28
debug3: tty_make_modes: 3 127
debug3: tty_make_modes: 4 21
debug3: tty_make_modes: 5 4
debug3: tty_make_modes: 6 255
debug3: tty_make_modes: 7 255
debug3: tty_make_modes: 8 17
debug3: tty_make_modes: 9 19
debug3: tty_make_modes: 10 26
debug3: tty_make_modes: 11 25
debug3: tty_make_modes: 12 18
debug3: tty_make_modes: 13 23
debug3: tty_make_modes: 14 22
debug3: tty_make_modes: 17 20
debug3: tty_make_modes: 18 15
debug3: tty_make_modes: 30 0
debug3: tty_make_modes: 31 0
debug3: tty_make_modes: 32 0
debug3: tty_make_modes: 33 0
debug3: tty_make_modes: 34 0
debug3: tty_make_modes: 35 0
debug3: tty_make_modes: 36 1
debug3: tty_make_modes: 38 1
debug3: tty_make_modes: 39 1
debug3: tty_make_modes: 40 0
debug3: tty_make_modes: 41 1
debug3: tty_make_modes: 50 1
debug3: tty_make_modes: 51 1
debug3: tty_make_modes: 53 1
debug3: tty_make_modes: 54 1
debug3: tty_make_modes: 55 0
debug3: tty_make_modes: 56 0
debug3: tty_make_modes: 57 0
debug3: tty_make_modes: 58 0
debug3: tty_make_modes: 59 1
debug3: tty_make_modes: 60 1
debug3: tty_make_modes: 61 1
debug3: tty_make_modes: 62 1
debug3: tty_make_modes: 70 1
debug3: tty_make_modes: 72 1
debug3: tty_make_modes: 73 0
debug3: tty_make_modes: 74 0
debug3: tty_make_modes: 75 0
debug3: tty_make_modes: 90 1
debug3: tty_make_modes: 91 1
debug3: tty_make_modes: 92 0
debug3: tty_make_modes: 93 0
debug2: channel 0: request shell confirm 0
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel 0: rcvd adjust 2097152
Last login: Thu Mar 27 19:31:43 2008
vdr01 ~ # etc
So bin ich jetzt drauf aber über die normale Weise komm ich trotzdem nicht drauf, wenn ich mich direkt verbinden will übers Menü?
 

beo

Mitglied
Mitglied seit
03.02.2004
Beiträge
246
Lösche in der ~/.ssh/known_hosts die Zeile mit dem Schlüssel für Deinen VDR.

Beim nächsten Login musst Du den Publickey des VDR wieder hinzufügen und es sollte funktionieren.

Gruß.
 
Oben