SSH-Verbindung zu einer Linuxmaschine

Dieses Thema im Forum "Mac OS - Unix & Terminal" wurde erstellt von macner, 09.07.2003.

  1. macner

    macner Thread Starter MacUser Mitglied

    Mitglied seit:
    02.07.2003
    Beiträge:
    7
    Hi,
    ich möchte via Terminal eine SSH-Verbindung zu einem Linuxrechner aufbauen. Wenn die Anmeldung an der Linuxkiste stattgefunden hat, läuft dort ein Script ab, dass im SSH-Fenster Name und Uhrzeit des Users anzeigt. Grundsäztlich klappt das auch. Ich habe nur das Problem, dass Name und Uhrzeit im Sekundentakt so 2-3 Zeile unter der vorhergehenden Ausgabe neu angezeigt werden und die vorhergehenden Ausgaben aus dem Terminalfenster "herauslaufen". Außerdem werden einige Zeichen nicht korrekt angezeigt. Das Script soll einfach nur Name und Uhrzeit in einer Ecke des Fensters anzeigen und die Uhrzeit ständig aktualisieren. Das komische ist, dass das selbe Script problemlos funktioniert wenn ich mich von einem Windows- oder Linuxrechner via SSH anmelde. Zur Lösung des Problems habe ich schon folgendes versucht. Ich habe ein anderes Terminalprogramm genommen (nämlich iTerm), ich habe mit verschiedenen Terminalemulationen getestet, habe verschiedene Shells probiert, andere Zeichensätze ausprobiert und schließlich einen anderen SSH-Client auf auf dem Mac übersetzt und getestet. Nichts hat geholfen, jetzt bin ich mit meinem Latein wirklich am Ende. kann mir jemand von Euch weiterhelfen?

    Gruß
    Andreas
     
  2. Stefan

    Stefan MacUser Mitglied

    Mitglied seit:
    15.12.2002
    Beiträge:
    412
    Welche Shell hast Du denn laufen? tcsh, csh, bash...? Und in was ist das Script geschrieben?
    (Also nicht dass ich mich mit Shellprogrammierung auskennen würde. Aber es kann eigentlich nur an sowas liegen... Aber hier findet sich bestimmt wer der besser helfen kann)

    Ciao,
    Stefan
     
  3. macner

    macner Thread Starter MacUser Mitglied

    Mitglied seit:
    02.07.2003
    Beiträge:
    7
    Zur Zeit läuft wieder die tcsh, ist aber eigentlich Wurst, es funktioniert mit keiner Shell. Das Script ist ein einaches Shellscript #/bin/sh.
     
Die Seite wird geladen...