Springerlink Downloader fehler (pdftk bzw iconv fehler?!)

demokan

Mitglied
Thread Starter
Mitglied seit
06.07.2007
Beiträge
93
Hi,
ich möchte das "Springerlink Downloader" Script von milianw nutzen. Der reine PDF download + merge klappt problemlos. Leider fehlen jedoch die Cover. Ich denke es liegt am "fehlendem" bzw falsch installiertem iconv.

Kann mir da jemand weiterhelfen?

mfg Demo

edit: iconv --version spuckt folgendes aus:

iconv (GNU libiconv 1.11)
...
 

t3lly

Aktives Mitglied
Mitglied seit
24.02.2009
Beiträge
3.577
Bei mir klappt es wohl wegen den Covern nicht. Bekomme die Fehlermeldung:

ERROR: You have to install the packet ImageMagick in order to use convert

Das kam bei dir nicht? Hast du xcode, macports und dieses ImageMagick installiert?

Weiß sonst einer Rat?
 

Kaito

Aktives Mitglied
Mitglied seit
31.12.2005
Beiträge
7.020
Dein iconv ist zum aktuellen 1.14 noch nicht so alt. Was wolltest du denn laden? Dann versuch ichs hier mal. Der TE wird aber wohl keine Hilfe mehr benötigen, nach bald 10 Monaten.
Du t3lly wirst einfach convert installieren müssen, am besten durch die Packetverwaltung deiner Wahl.
 

bombard

Mitglied
Mitglied seit
25.12.2008
Beiträge
233
Hallo
Sorry, dass ich in dem Thema was anderes Frage.

Ich hatte das Script vorher mal entdeckt.
Könnt ihr mir sagen, wie ich das Script verwenden kann? Ich verstehe das irgendwie nicht.

gruß
 

Kaito

Aktives Mitglied
Mitglied seit
31.12.2005
Beiträge
7.020
Terminal, "python" eingeben, Leerzeichen drücken, die dort geladene Datei ins Terminalfenster ziehen, gewünschte Argumente angeben (in dem Fall wohl -l "<URL>") und realisieren, dass es mehrere Abhängigkeiten gibt, die du vermutlich nicht installiert hast.
 
Oben