smb Zugriff auf Synology - alle Ordner sichtbar

ez-lif

Aktives Mitglied
Thread Starter
Dabei seit
17.11.2006
Beiträge
1.067
Punkte Reaktionen
102
Hallo zusammen,

nachdem ich mich von sämtlichen Cloud-Diensten trennen möchte, habe ich mir wieder ein DS von Synology gekauft.
Nun wollte ich mein Netzlaufwerk per smb verbinden, was prinzipiell auch funktioniert.
Mich stört allerdings, wenn ich mich anmelde, dass alle Ordner (Laufwerke) der NAS sichtbar sind, obwohl die Ordner
so eingestellt sind, dass sie nur für berechtigte User sichtbar sein sollen.

Kann man das noch irgendwie einstellen, dass dies auch bei der smb Verbindung so der Fall ist und nicht für jeden alles sichtbar ist?

Danke schon mal! :)
 

walfreiheit

Aktives Mitglied
Dabei seit
06.06.2004
Beiträge
36.652
Punkte Reaktionen
15.886
Meldest du dich zufällig mit den Daten des Administrators an? ;)
 

ez-lif

Aktives Mitglied
Thread Starter
Dabei seit
17.11.2006
Beiträge
1.067
Punkte Reaktionen
102
Eben nicht.
Melde mich als ganz normaler User an - trotzdem werden alle Ordner angezeigt, wobei ich mich aber nur auf die freigegebenen wirklich verbinden kann. Bei den anderen erscheint eine Fehlermeldung
 

walfreiheit

Aktives Mitglied
Dabei seit
06.06.2004
Beiträge
36.652
Punkte Reaktionen
15.886
Ach so, ja klar, wenn du erst auf der Ebene die Berechtigungen verteilst, ist das doch klar …
 

ez-lif

Aktives Mitglied
Thread Starter
Dabei seit
17.11.2006
Beiträge
1.067
Punkte Reaktionen
102
Und wie kann ich das ändern?
 

walfreiheit

Aktives Mitglied
Dabei seit
06.06.2004
Beiträge
36.652
Punkte Reaktionen
15.886
Direkt mit den Freigaben verbinden, nicht mehr der kompletten Synology.
 

pc-bastler

Aktives Mitglied
Dabei seit
15.06.2005
Beiträge
3.455
Punkte Reaktionen
514
Du musst unterscheiden zwischen Freigaben (die können immer alle gesehen werden oder man schaltet sie generell unsichtbar) und Ordnern. Das was du eingestellt hast, gilt nur für Ordner innerhalb der Freigeben, nicht für die Freigabe selbst.
 

ez-lif

Aktives Mitglied
Thread Starter
Dabei seit
17.11.2006
Beiträge
1.067
Punkte Reaktionen
102
Kann mir das vielleicht mal einer an einem Beispiel erklären - irgendwie komme ich gerade nicht ganz mit :p
 

lisanet

Aktives Mitglied
Dabei seit
05.12.2006
Beiträge
5.986
Punkte Reaktionen
6.391
Samba kennt eine Einstellung "access based share enum" die genau das macht, nämlich die Sichtbarkeit auf die Shares beschränken, auf die der User Zugrifsberechtigung hat.

Auf einem QNAP lautet das auch so "Access based share enumeration". Das sollte auch auf Synology vorhanden sein.
 

Johanna K

Mitglied
Dabei seit
28.10.2009
Beiträge
886
Punkte Reaktionen
518
Das von dir beschriebene Verhalten ist nicht nur normal, sondern auch sinnvoll. Du könntest dich mit einer Freigabe ja auch mit anderen als deinen üblichen Anmeldedaten verbinden wollen. Zu dem Zeitpunkt, zu dem dein Mac dir alle Freigaben anzeigt, weiß er noch gar nicht, für welche Freigaben du einen Benutzernamen und ein Passwort kennst und für welche nicht.

Du kannst auf deiner Syno unter Systemsteuerung -> Gemeinsame Ordner -> Bearbeiten (zu einer angeklickten Freigabe) den Punkt "Verbergen Sie diesen gemeinsamen Ordner unter Netzwerkumgebung" auswählen. Dann ist er aber nie sichtbar, und du kannst dich nur direkt mit der Freigabe verbinden (im Finder "Gehe zu" -> "Mit Server verbinden"). (Ob das wirklich so ist, kann ich gerade nicht ausprobieren.)
 

lisanet

Aktives Mitglied
Dabei seit
05.12.2006
Beiträge
5.986
Punkte Reaktionen
6.391
Das von dir beschriebene Verhalten ist nicht nur normal, sondern auch sinnvoll.
hhmm, eigentlich ist es eher anders herum. Es ist bei mehreren User:innen schon sehr sinnvoll, nur die Shares anzuzeigen, auf welche die User:innen Zugriffsberechtigung haben. Wie oben geschrieben, bietet Samba genau dafür eine config-Option an.
 

ez-lif

Aktives Mitglied
Thread Starter
Dabei seit
17.11.2006
Beiträge
1.067
Punkte Reaktionen
102
Ahhh - ich habs gefunden (y)
Unter: Dateidienste -> SMB kann man "Freigegebene Ordner für Nutzer ohne Berechtigung ausblenden" auswählen.
 
Oben Unten