Seit Catalina kein Finder Zugriff auf DiskStation

Diskutiere das Thema Seit Catalina kein Finder Zugriff auf DiskStation. Hallo, Ich habe mein MacBookPro letzte Woche auf Catalina geupdatet. Seitdem erscheint zwar...

Radonbiker

Mitglied
Mitglied seit
23.02.2019
Beiträge
17
Versuch doch mal "Schleifenquadrat"+"K" und gib dann die IP deiner Diskstation ein.
Das habe ich schöner öffnet dann aber sobald ich das Fenster wieder schließe ist auch alles wieder aus dem Finder verschwunden.
 

Pinky69

Mitglied
Mitglied seit
06.11.2003
Beiträge
2.894
Verstehe ich das jetzt richtig, du kannst es verbinden über cmd+k (mit Server verbinden) ? Nur wenn du den Mac neu startest oder den Finder neu startest ist der Mount weg?
Könntest mit Automator (in Programme) dir ein Script schreiben und es beim Neustart automatisch ausführen lassen, dann ist die Diskstation immer gemountet wenn du den Mac neu startest.
 

Radonbiker

Mitglied
Mitglied seit
23.02.2019
Beiträge
17
Das hast du genau richtig erkannt. Ich habe jetzt nochmal, nicht das ich das nicht schonmal probiert habe, die DS MacBook FritzBox vom Netz genommen und gewartet und alles nach und nach wieder hochgefahren und neu verbunden und sie da es hat geklappt. Also kann ich im Finder die DS wieder sehen und auch wieder öffnen. Mal sehen wie lange das klappt.
 
  • Gefällt mir
Reaktionen: dg2rbf

trophy

Mitglied
Mitglied seit
29.06.2007
Beiträge
979
Ich habe auch das Problem, nur nach Neustart des iMac habe ich wieder Zugriff auf die NAS. Irgendwelche neuen Erkenntnisse in dem Zusammenhang?
 

lisanet

Mitglied
Mitglied seit
05.12.2006
Beiträge
1.879
Ich hatte so ein ähnliches Problem auch und hier schon mal dazu geschrieben. Catalina Synology Zugriff ständig deaktiviert und nur über afp

Bei mir lag es an den Einstellungen des Samba-Servers. Seit ich in der smb.conf auf dem Server unter [global] dies

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
und bei den jeweiligen Shares das hier

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
eingetragen habe, läuft es wieder.

Da ich einen Linux-Server habe, kenne ich mich leider nicht mit der GUI der verschiedenen NAS aus, ob man dort diesen Eintrag auch ergänzen kann. Das unglückliche daran ist, dass laut der Samba-Doku, dieser Eintrag als default eingestellt sein sollte. Aber ohne diese Einträge funktioniert es eben nicht. Vielleicht ist die Doku von Samba in diesem Punkt nicht mehr ganz aktuell gehalten worden (so etwas konnte ich aus einem Posting der Samba-Developer mailingliste entnehmen)

Vielleicht kennt sich hier im Forum ja jemand besser mit NAS und den Möglichkeiten der individuellen Ergänzung der configs aus.
 
  • Gefällt mir
Reaktionen: dg2rbf

Radonbiker

Mitglied
Mitglied seit
23.02.2019
Beiträge
17
Also bei mir besteht weiterhin das Problem. Wenn ich das MacBook aus dem Standby hole wird die Station angezeigt im Finder und auch die vorhandenen Ordner aber sobald ich einen Ordner öffnen möchte kommt eine Fehlermeldung. Erst ein Neustart des macs bringt Abhilfe aber auch nur bis er wieder aus dem Standby kommt.
Macht kein Spaß so.
 
  • Gefällt mir
Reaktionen: muruk63 und dg2rbf

muruk63

Mitglied
Mitglied seit
15.03.2005
Beiträge
95
Also ich habe das Problem jetzt auch. Vor einigen Tagen auf Catalina upgedatet und bisher keine Probleme gehabt. Jetzt schmiert die DS418 unter SMB-Zugriff ab. Auf allen Rechnern. Per AFP klappt der Zugriff. Unter Yosemite keine Probleme.
 

Apfelfuzzi

Mitglied
Mitglied seit
25.12.2018
Beiträge
15
aber sobald ich einen Ordner öffnen möchte kommt eine Fehlermeldung. Erst ein Neustart des macs bringt Abhilfe aber auch nur bis er wieder aus dem Standby kommt.
Macht kein Spaß so.
Bildschirmfoto 2020-01-30 um 16.12.27.png
Ich habe mit Befehlstaste + K das Verzeichnis Music auf der DS418 gemounted. Es werden auch alle anderen Hauptverzeichnisse der DS418 angezeigt.
Durch Doppelklick im Finderfenster lassen sich die Verzeichnisse nicht mounten, dann kommt es zu folgender Fehlermeldung:

Bildschirmfoto 2020-01-30 um 16.16.58.png
Mounten muss ich das Verzeichnis dann mit Befehlstaste + K

Das war auch mal anders vor Catalina...
 

Schnatterente

Mitglied
Mitglied seit
12.08.2010
Beiträge
1.290
Also ich habe das Problem jetzt auch. Vor einigen Tagen auf Catalina upgedatet und bisher keine Probleme gehabt. Jetzt schmiert die DS418 unter SMB-Zugriff ab. Auf allen Rechnern. Per AFP klappt der Zugriff. Unter Yosemite keine Probleme.
die Lösung steht in #5
 

djofly

Mitglied
Mitglied seit
31.07.2006
Beiträge
2.868
Also bei mir besteht weiterhin das Problem. Wenn ich das MacBook aus dem Standby hole wird die Station angezeigt im Finder und auch die vorhandenen Ordner aber sobald ich einen Ordner öffnen möchte kommt eine Fehlermeldung. Erst ein Neustart des macs bringt Abhilfe aber auch nur bis er wieder aus dem Standby kommt.
Macht kein Spaß so.
Gleiches Problem bei mit mit einer Synology Diskstation.

Ich hatte so ein ähnliches Problem auch und hier schon mal dazu geschrieben. Catalina Synology Zugriff ständig deaktiviert und nur über afp

Bei mir lag es an den Einstellungen des Samba-Servers. Seit ich in der smb.conf auf dem Server unter [global] dies

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
und bei den jeweiligen Shares das hier

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
eingetragen habe, läuft es wieder.
Das habe ich bei mir nun auch vorgenommen (manuell über das Terminal).

Mal sehen, ob das nun hilft.
 
  • Gefällt mir
Reaktionen: dg2rbf und heax2

heax2

Registriert
Mitglied seit
09.02.2020
Beiträge
3
Gleiches Problem bei mit mit einer Synology Diskstation.



Das habe ich bei mir nun auch vorgenommen (manuell über das Terminal).

Mal sehen, ob das nun hilft.

Hallo djofly

wie ist nun deine Erfahrung mit der Änderung der smb.konf Datei?
fügst du nur diesen Eintrag bei der Synology in die smb.konf Datei ein?
Ist die NAS seither bei dir stabil über den Finder erreichbar?

LG

Marco
 

djofly

Mitglied
Mitglied seit
31.07.2006
Beiträge
2.868
Muss ich noch mal weiter beobachten. Das Problem ist aber schon mal, dass das NAS beim Neustart den Eintrag am Share entfernt. Nur der globale bleibt erhalten.
 

lisanet

Mitglied
Mitglied seit
05.12.2006
Beiträge
1.879
Muss ich noch mal weiter beobachten. Das Problem ist aber schon mal, dass das NAS beim Neustart den Eintrag am Share entfernt. Nur der globale bleibt erhalten.
Die Einstellungen nur für global und nicht für die shares, ist die Standardeinstellung in Samba. Und genau die macht die Probleme.
 

BlackB8

MacUser Mitglied
Mitglied seit
10.02.2020
Beiträge
2
Hallo zusammen - nachdem ich das gleiche Problem habe (meine DiskStation hat sowohl SMB als auch AFP aktiviert) und ich auch beide benötige (Windows Rechner, MACs, TimeMachine) habe ich den Hinweis zu MSDFS weiter verfolgt.

In den Einstellungen der DiskStation (zumindest bei der aktuellen Version) gibt es unter den erweiterten Einstellungen zu SMB die Option:

MSDFS VFS-Modul aktivieren.

Bei mir war die Option deaktiviert. Nach Aktivierung und Neustart des Finders im MAC klappte die Verbindung mit der DiskStation wieder - also ganz ohne die SMB.config direkt zu ändern.
 
  • Gefällt mir
Reaktionen: Faraway und Schnatterente

SwissBigTwin

Mitglied
Mitglied seit
07.01.2013
Beiträge
17.065
Was ich nicht ganz verstehe...

1. Klicke ich in der Finder Seitenleiste auf mein NAS (roter Pfeil), kann ich mich nicht verbinden, die NAS verschwindet direkt aus dem Finder.
2. Klicke ich in der Finder Seitenleiste auf Netzwerk (grüner Pfeil), dann wird mein NAS, das Volume und die Ordner korrekt angezeigt.
3. Klicke ich in der Finder Seitenleiste direkt auf das Volume (gelber Pfeil) vom NAS, werden die Ordner auf dem NAS auch korrekt angezeigt.

Bis auf Punkt 1 funktioniert alles gut per SMB und mit Catalina.

NAS.jpg
 

heax2

Registriert
Mitglied seit
09.02.2020
Beiträge
3
Hallo zusammen - nachdem ich das gleiche Problem habe (meine DiskStation hat sowohl SMB als auch AFP aktiviert) und ich auch beide benötige (Windows Rechner, MACs, TimeMachine) habe ich den Hinweis zu MSDFS weiter verfolgt.

In den Einstellungen der DiskStation (zumindest bei der aktuellen Version) gibt es unter den erweiterten Einstellungen zu SMB die Option:

MSDFS VFS-Modul aktivieren.

Bei mir war die Option deaktiviert. Nach Aktivierung und Neustart des Finders im MAC klappte die Verbindung mit der DiskStation wieder - also ganz ohne die SMB.config direkt zu ändern.

Hallo Danke für Deine Antwort. Ich habe das getestet. Leider kam der Fehler gerade wieder.
Das ist somit immer noch nicht die Lösung, die allen dauerhaft helfen wird.
Dieses Problem gab es vor ca. 2 Jahren schon einmal bei einer OSX Version.
Leider ist es nun mit Catalina wieder ausgegraben worden.
Ich denke, hier muss eigentlich Apple nachbessern.

Mir scheint es aber so, als ob die mehr Interesse daran haben die Leute in die iCloud zu zwingen mit solchen offensichtlichen Bugs.
Seit Monaten keine Abhilfe und auch in den US Foren gleiche Probleme ohne Reaktion seitens Apple.
 

BlackB8

MacUser Mitglied
Mitglied seit
10.02.2020
Beiträge
2
Hallo Danke für Deine Antwort. Ich habe das getestet. Leider kam der Fehler gerade wieder.
Das ist somit immer noch nicht die Lösung, die allen dauerhaft helfen wird.
Bis jetzt funktioniert der Zugriff bei mir noch nach der Änderung. Welche Version hat deine DiskStation? Welche Erweiterte Einstellungen bei SMB hast Du eingestellt?

Ich habe aktuell DSM 6.2.2 Update 4 aktiv.

Bei den Einstellungen habe ich noch SMB1 bis SMB3 aktiv (leider wegen meinem Scanner sonst hätte ich gerne nur noch SMB3 aktiv)
Verschlüsselungsübertragungsmodus: Automatisch
Ausser DirSort VFS-Modul und MSDFS VFS-Modul sind alle anderen Optionen deaktiviert.

AFP ist ebenfalls aktiv aber NFS nicht.
 

heax2

Registriert
Mitglied seit
09.02.2020
Beiträge
3
Hallo BackB8. Danke für Deine Antwort.

Also ich habe folgende aktuelle Daten:
DSM 6.2.2-24922 Update 4 (aktuellste Version)

Unter Dateidienste sind folgende Optionen gesetzt:

SMB-Dienst aktiv
AFP hatte ich wieder deaktiviert. Das macht bei dem Problem keinerlei Unterschied zudem Apple ja SMB inzwischen benutzt

In den erweiterten Einstellungen von SMB:

WINS-Server kein Eintrag
maximales smb protokoll: SMB3
mindest-SMB Protokoll: SMB2 und Large MTU
Verchlüsselungsübertragungsmodus: Automatisch
Ausser DirSort VFS-Modul und MSDFS VFS-Modul sind alle anderen Optionen deaktiviert.
 

Gartenzwerg

Mitglied
Mitglied seit
29.08.2011
Beiträge
133
Ich habe das Problem auch und keine Lösung gefunden.
Man kann jedoch statt den Rechner neu starten den Finder „neu starten, sofort beenden“ und dann werden die Shares wieder neu verbunden. Die hält dann bis zum nächsten mal irgendwann.

Wenigstens nicht jedesmal neu booten.
 

Faraway

Mitglied
Mitglied seit
24.07.2011
Beiträge
739
Hallo zusammen - nachdem ich das gleiche Problem habe (meine DiskStation hat sowohl SMB als auch AFP aktiviert) und ich auch beide benötige (Windows Rechner, MACs, TimeMachine) habe ich den Hinweis zu MSDFS weiter verfolgt.

In den Einstellungen der DiskStation (zumindest bei der aktuellen Version) gibt es unter den erweiterten Einstellungen zu SMB die Option:

MSDFS VFS-Modul aktivieren.

Bei mir war die Option deaktiviert. Nach Aktivierung und Neustart des Finders im MAC klappte die Verbindung mit der DiskStation wieder - also ganz ohne die SMB.config direkt zu ändern.
Gleiches Problem aber diesen Fix/Vorschlag erst jetzt gefunden. Bei mir hats geholfen und die Sysnology DS218 ist wieder wie immer im Finder. Vielen dank!
 
Oben