Sehr langsame Reaktionen im Finder unter Panther

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Hallo MacUser,

auf meinem G5 habe ich das Problem, dass bestimmte Funktionen im Finder sehr langsam vonstatten gehen.

Bei Aufruf des Info-Fensters (Apfel + i) dauert es sehr lange, bis beispielsweise die Größeninformationen eines Ordners angezeigt werden; noch heftiger ist die Änderung der Rechte eines Ordners über das Info-Fenster. Es vergehen meist mehrere Minuten, bis dann die tatsächliche Reaktion eintritt.

Es nervt sehr, denn wenn wegen eines Kopiervorganges schnell die Rechte geändert werden müssen, oder oder... hat man meist nicht unbedingt 5 bis 10 Minuten Zeit dafür.

Bin für einen vernüftigen Tipp dankbar.

Beste Grüße
Gerry

PS.: Es handelt sich dabei um die ursprüngliche Installation auf dem Rechner, die auf Pnather geuppt ist und der G5 läuft mit den aktuellen Updates auf 10.3.7. Speicher ist auch ordentlich drin.
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Hat denn noch niemand dieses Problem erfolgreich gelöst?
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Hat den niemand anderes dieses Problem? Und schon einmal erfolgreich gelöst?
 

babaloo

Mitglied
Mitglied seit
09.03.2003
Beiträge
1.602
hallo gerry,

ich kenne das problem nicht. vielleicht auch deswegen nicht, weil ich NOCH NIE vor orgendeinem kopiervorgang die rechte geändert habe. rechte ändern kommt bei mir - wenn überhaupt - einmal im quartal vor. und dann auch nur bei recht exotischen operationen.

wofür änderst du die denn?

und schonmal versucht, das gleiche über's terminal zu machen?
 

babaloo

Mitglied
Mitglied seit
09.03.2003
Beiträge
1.602
ach so, und das mit der grössenänderung ist tatsächlich ein fehler des finders. der hat leider, leider, leider noch immer einige bugs drin.
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
hi babaloo,

danke für die reaktion. Meistens gibt es das Problem, wenn ich mal "kurz" schauen muss wie groß ein Ordner ist, oder wenn ich beim Speichern aus einem Programm heraus merke, dass ich nach Kopieren von ext. HD die Datei nicht überschreiben kann; also hilft es mir hier eigentlich nur die Rechte wieder so weit anzugleichen, dass ich speichern kann.

Aber gleich, ob Info oder Rechner, fast jede Aktion über das Info-Fenster dauert extrem lang. Die ist auf den anderen beiden Rechner nicht der Fall. Dort wird die gleichen Aufgaben sehr schnell erledigt. Auf dem gleichen Rechner habe ich ein zweites System eingerichtet, das bei Nutzung dieses Phänomen auch nicht zeigt.

Das Löschen der Finder Prefs inkl. der Finder Playlist hat keinen deutlichen Fortschritt gebracht.

Also wieder Ratlosigkeit....
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
... habe das Ganze noch nicht über das Terminal probiert.
 

hertzchen

Mitglied
Mitglied seit
20.09.2004
Beiträge
2.005
als erstes würde ich mal die finder .plist löschen (preferences) und neu booten, wird dann ja neu angelegt und hat schon so manches problem gelöst - weil bei panther der finder ja eigentlich kontinuierlich beschleunigt wurde :)
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Danke für das Feedback. Hatte gestern die Finder prefs und die Playliste des Finders gelöscht, weekly und monthly scripte laufen lassen und sicherheitshalber noch die Rechte repariert. Nun sind die Reaktionszeiten erträglich, auch wenn das System gefühlmäßig noch ein bisschen langsamer ist als die Alternativen mit denen ich arbeite.

Thanx 'n' Greetz
 

Hilarious

Mitglied
Mitglied seit
25.11.2004
Beiträge
2.186
Dann solltest Du jetzt mal schauen, was bei Dir alles so im Hintergrund läuft. Infos dazu findest Du in Dienstprogramme/Aktivitätsanzeige oder im Terminal mit dem Befehl "top" oder "ps -aux".
 
L

Lynhirr

Gerry233 schrieb:
Hat denn noch niemand dieses Problem erfolgreich gelöst?
Ich habe das Problem nicht :cool:

iMac G5 1,8 Giga, 1 Giga RAM

Rechte im User ändere ich nie, wozu auch. Das Infofenster geht schnell auf, zum Berecnen großer Ordner braucht er etwas, aber das war schon immer so und behindert mich nicht, da ich in der Zeit was anderes tue.
 

latelio

Mitglied
Mitglied seit
17.11.2003
Beiträge
165
ich hab schon einen anderen Fred offen, doch vielleicht kann hier jemand helfen: wenn ich ein Dokument (aus irgendeinem Programm heraus) zum ersten Mal speichern will (oder eine Kopie davon als "Sichern unter" machen will), dann wartet der Finder mindestens 10 Sekunden, bis das Speichern-Fenster aufgeht. Manchmal kommt überhaupt nichts und ich muss das Programm abmurksen.

Rechte repariert, Cron-jobs gemacht, PRam geleert, plist-Files weggeworfen, fsck durchgeführt: nichts hilft!
 
L

Lynhirr

Gib mal deine Rechnerkonfiguration durch, System und so …
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Lynhirr schrieb:
Gib mal deine Rechnerkonfiguration durch, System und so …
G5 2.0 Dual, >2 GB RAM, Panther X.3.7 (war auch schon unter X.3.5 so)

schiebe die Daten mit Hilfe von copyra auf die ext. HD und später wieder zurück, verbiegt in der Regel auch nicht die Rechte; es kommt allerdings hin- und wieder vor, dass ich die Daten per CD-RW transportiere, so dass hier dann die später wieder die User-Rechte geändert werden müssen.

Aber damit habe ich auf dem zweiten Rechner keine Probleme. Da Infosfenster dort ist schnell offen und notfalls können dort die Rechte auch schnell geändert werden.

Trotz regelmäßiger Prüfung der Rechte und Ausführung der sudo monthly, weekly, daily Befehle ist das Problem nicht weg, auch wenn es nach dem Löschen der Finder prefs und der playlist schon mal besser geworden ist.

Das einzige was mir jetzt noch einfällt ist die Reparaturinstallation...
 

latelio

Mitglied
Mitglied seit
17.11.2003
Beiträge
165
gestern hab ich folgende methode ausprobiert: den ganzen "preferences"-ordner auf den schreibtisch gelegt und dann nach und nach die voreinstellungen wieder in den neu gebildeten ordner zurückgelegt (immer wieder aus- und einloggen um zu sehen, ob sich was ändert).
nun geht die maschine wieder so flott wie vorher; ich vermute, dass irgendwas mit den .mac oder backup-preferences im argen lag.

den ausgelagerten preferences-ordner solltest du solange als kopie behalten, bis du sicher bist, dass nicht doch noch wichtige voreinstellungen (die manchmal seriennummern u.ä. enthalten) zurückkopiert werden müssen.
 

Gerry233

Mitglied
Thread Starter
Mitglied seit
24.11.2003
Beiträge
609
Hallo und danke für die Tipps bisher. Habe zwar noch nicht alles ausprobiert; aber habe auch bisher keine wirkliche Verbesserung erreicht. - Vielleicht bleibt als Ausweg doch nur die Neuinstallation...

Gebe Bescheid, wenn sich was Grundlegendes tut.