Samba nicht erreichbar

Diskutiere das Thema Samba nicht erreichbar im Forum Netzwerk. Hallo zusammen! Bevor ich mein Netzwerk-Problem schildere...hier mein Network, als Grafik...

dan_f

Mitglied
Thread Starter
Mitglied seit
22.11.2004
Beiträge
17
Hallo zusammen!

Bevor ich mein Netzwerk-Problem schildere...hier mein Network, als Grafik:
http://www.dafa-tech.de/network.jpg

Der Router ist ein Pentium2 mit FreeBSD als OS.
Darauf habe ich einen Samba installiert. Mit den 2 Workstations (Windows XP) kann ich auf den Samba zugreifen. Mit meinem iBook (MacOS X) allerdings nicht. (Internet geht bei allen).
Warum den aber? das ist hier die Frage.
Von Laptop auf Workstation geht. Den Samba zeigt es mir aber beim iBook nicht an.

Wäre super, wenn einer einen Tipp auf Lager hätte.

Gruß
Daniel
 

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
Hui...bei deinem Netz muss man ja richtig anfangen Subnetze zu berechnen :) Hast aber alles richtig gemacht...das passt schon.

Hast du einen WINS-Server eingerichtet? Den brauchst du nämlich, sobald du Samba über mehrere Subnetze bekanntmachen willst. Also in der smb.conf den WINS-Server aktivieren, und dann auf allen Rechnern den WINS-Server eintragen oder per DHCP verteilen lassen. Erst wenn alle Rechner den WINS-Server kennen, sollte dein iBook auch die anderen Shares sehen.

cla
 

usr

Mitglied
Mitglied seit
14.02.2003
Beiträge
266
Wieso Subnetze berechnen, wenn alle im gleichen liegen?

dan_f,
hast du beim Verbinden die IP angegeben?
 

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
usr schrieb:
Wieso Subnetze berechnen, wenn alle im gleichen liegen?
Liegen sie aber nicht. Er hat ein 192.168.1.x/25 (das sieht man aus der Subnetzmaske von 255.255.255.128) Subnetz gemacht, und somit sein iBook und die WLAN-Komponente am 2ten Rechner in einem anderen Subnetz als die anderen Rechner (das eine geht von .1 bis .126, das zweite dann ab .129)

cla
 
Zuletzt bearbeitet:

dan_f

Mitglied
Thread Starter
Mitglied seit
22.11.2004
Beiträge
17
Ich hab folgendes in der smb.conf gefunden:

Code:
# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
;   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#       Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one  WINS Server on the network. The default is NO.
;   wins proxy = yes
Die ersten 2 auf jedenfall auskommentieren, oder?
Welche IP gebe ich dem WINS-Server?


Folgendes habe ich noch gefunden:
ist das auch irgendwie relevant?

Code:
# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
;   interfaces = 192.168.12.2/24 192.168.13.2/24

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = yes
 

dan_f

Mitglied
Thread Starter
Mitglied seit
22.11.2004
Beiträge
17
Hmmmmmm

Mit Apfel-K und smb://ip_des_routers komme ich auf den Samba.

Wenn ich nun allerdings das WLAN unterbreche und auf das Samba-Icon klicke, spinnt mein iBook total rum. Finder bleibt hängen und "Sat1-Ball" dreht sich zu tote.
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
Hast mal vom Ibook aus ein "traceroute" auf den Samba-Server gemacht ?

Ich hab´s mir nur kurz angeschaut, aber müsste nicht auf der WS #1 ein Softwarerouter laufen, um die beiden Subnetze miteinender zu verbinden ?
Die Grafik ist übrigens nicht ganz eindeutig, da man eigentlich zu jeder IP-Adresse eine SNM angeben muss.
 

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
dan_f schrieb:
Ich hab folgendes in der smb.conf gefunden:

Code:
# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
;   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#       Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one  WINS Server on the network. The default is NO.
;   wins proxy = yes
Die ersten 2 auf jedenfall auskommentieren, oder?
Nein. Nur die erste auskommentieren. Du willst ja einen Server betreiben, und keinen Client (wofür die 2te Zeile stehen würde).
Ein schlichtes "wins support = yes" reicht also völlig aus.

dan_f schrieb:
Folgendes habe ich noch gefunden:
ist das auch irgendwie relevant?

Code:
# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
;   interfaces = 192.168.12.2/24 192.168.13.2/24
Das kannst du noch auskommentieren, und nur die interne Netzwerkkarte in deinem Server eintragen. Dann bindet sich Samba nur an die dort angegebenen Interfaces. Ein zusätzliches "bind interfaces only = true" sollte das ganze noch komplettieren.

dan_f schrieb:
Code:
# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = yes
Wenn der Rechner Server sein soll, würde ich den auf jeden Fall dann Domain Master machen lassen. Sonst schnappt sich irgendein Windows-Rechner die Zuständigkeit, und verwirrt die anderen nur wieder unnötig. Füg also folgendes ein:

os level = 200
preferred master = yes
domain master = yes

Und in Zukunft sollte dein Server für alle Samba-Tätigkeiten zuständig sein.

cla

P.S. Bevor es Verwirrungen gibt: Ich spreche hier die ganze Zeit von der smb.conf auf deinem FreeBSD-Server.
 
Zuletzt bearbeitet:

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
maceis schrieb:
Ich hab´s mir nur kurz angeschaut, aber müsste nicht auf der WS #1 ein Softwarerouter laufen, um die beiden Subnetze miteinender zu verbinden ?
Ich hoffe doch :)

maceis schrieb:
Die Grafik ist übrigens nicht ganz eindeutig, da man eigentlich zu jeder IP-Adresse eine SNM angeben muss.
Stimmt. Die SNM vom Server fehlt. Aber durch seine IP ist er wohl im ersten Subnetz, in dem sich auch die WS befinden.

cla
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
cla schrieb:
...
Stimmt. Die SNM vom Server fehlt. Aber durch seine IP ist er wohl im ersten Subnetz, in dem sich auch die WS befinden.
...
Nich nur das, auch bei den Workstations ist nur ein SNM eingetragen (dürfte wohl zweimal dieselbe sein).

btw.: das mit dem WINS würde ich nicht überbewerten. Wenn man sich ohnehin über die IP Adresse verbindet ist das imho sekundär.
In einem so kleinen Netz könnte man (wenn man denn Namen verwenden möchte) auch mit hosts-dateien arbeiten. Schneller geht das allemal.
 

dan_f

Mitglied
Thread Starter
Mitglied seit
22.11.2004
Beiträge
17
Ich denke mal ihr meint mit SNM das Subnetz.
Das ist bei allen Geräten die 255.255.255.128.

Auf WS #1 läuft das IP-Forwarding von Win XP Prof.
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
dan_f schrieb:
Ich denke mal ihr meint mit SNM das Subnetz.
Das ist bei allen Geräten die 255.255.255.128.
Nur zum Verständnis:
255.255.255.128 ist kein Subnetz, sondern eine Subnetzmaske (SNM).
Wie cla schon ausgeführt hat besteht Dein physikalisches Netz aus zwei logischen Netzen und zwar den Subnetzen 192.168.1.0 und 192.168.1.128.
Daher benötigst Du auch ein Routing auf der WS #1.

dan_f schrieb:
Auf WS #1 läuft das IP-Forwarding von Win XP Prof.
Mit dem oben vorgeschlagenen traceroute könntest Du testen, ob das ordnungsgemäß funktioniert, bzw wie weit Du vom Notebook aus kommst.
Hast Du das gemacht ?
Kannst Du den Samba-Server überhaupt anpingen ?
Läuft auf der WS #1 möglicherweise eine Softwarefirewall ?
 

dan_f

Mitglied
Thread Starter
Mitglied seit
22.11.2004
Beiträge
17
Das einzige Problem, dass ich hatte....ich sah den Samba nicht im Finder unter Netzwerk.

Der Tipp mit Apfel+K -> smb://ip_des_samba hat super geklappt.
Ich muss nur darauf achten, dass ich den Samba wieder "unmounte", wenn ich das WLAN kappe. Komme ich sonst nochmal auf das Samba-Laufwerk, dreht sich der "Sat.1-Ball" zutote und es bleibt nur noch ein ekliger Lange-Knopf-Drück-Restart.

Danke für eurere Hilfe.
 

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
dan_f schrieb:
Das einzige Problem, dass ich hatte....ich sah den Samba nicht im Finder unter Netzwerk.
Und genau dafür ist eben WINS gedacht. Um die Samba-Shares über Subnetze hinweg bekannt zu machen. Das ist afaik dann auch schon der einzige Sinn von WINS.

cla
 

ThaHammer

Mitglied
Mitglied seit
01.06.2004
Beiträge
3.304
Äh? Mal ne blöde Frage!

Aber sollte die WKS wo das WLAN dran hängt nicht einfach als Router ins zweite Netz fungieren? So kann das doch gar nicht gehen, wenn die WKS nicht routet!
 

matzetronic

Mitglied
Mitglied seit
25.10.2003
Beiträge
178
Das hier könnte direkt aus einer Fachinformatiker Abschluß-Prüfung stammen ;)

Du solltest mal auf dem router noch die route zum WLAN eintragen, sonst weiß der ja garnet was er mit den Paketen machen soll die ins WLAN sollen. Der kennt ja nur sein eigenes Netz. Der Befehl wird dir unter "man route" erklärt.
 

cla

Mitglied
Mitglied seit
24.10.2003
Beiträge
2.965
@ThaHammer: dan_f schreibt im Beitrag 11, das XP das ganze routet

@matzetronic: Er schreibt in seinem ersten Post, das Internet auf allen Rechnern schon einwandfrei funktioniert. Deshalb denke ich mal, das die Routen schon passen.

cla
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
ThaHammer schrieb:
Äh? Mal ne blöde Frage!

Aber sollte die WKS wo das WLAN dran hängt nicht einfach als Router ins zweite Netz fungieren? So kann das doch gar nicht gehen, wenn die WKS nicht routet!
Schon gelesen ? :D
 
Oben