safari und mail startet nicht mehr

Dieses Thema im Forum "MacBook" wurde erstellt von cpeyer, 12.12.2004.

  1. cpeyer

    cpeyer Thread Starter MacUser Mitglied

    Beiträge:
    63
    Zustimmungen:
    1
    MacUser seit:
    02.12.2004
    hallo,

    aus unerfindlichen gründen starten safari und mail, sowie die softwareaktualisierung nicht mehr.
    im console.log findet sich folgender eintrag:

    dyld: /Applications/Mail.app/Contents/MacOS/Mail can't open library: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore (No such file or directory, errno = 2)
    dyld: /System/Library/CoreServices/Software Update.app/Contents/MacOS/Software Update can't open library: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore (No such file or directory, errno = 2)
    dyld: /Applications/Safari.app/Contents/MacOS/Safari can't open library: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore (No such file or directory, errno = 2)
    dyld: /System/Library/CoreServices/Software Update.app/Contents/MacOS/Software Update can't open library: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore (No such file or directory, errno = 2)


    als ich dem pfad folgte kam ich bis
    /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/

    keine spur von javascriptcore. kann ich da noch was retten und dieses java zeug irgendwie installieren?
    danke
    chris
     
    Zuletzt bearbeitet: 12.12.2004
  2. vortex1394

    vortex1394 MacUser Mitglied

    Beiträge:
    359
    Zustimmungen:
    4
    MacUser seit:
    05.12.2003
    uiuiuuiuuiuiuiuiuiuiui.............
     
  3. cpeyer

    cpeyer Thread Starter MacUser Mitglied

    Beiträge:
    63
    Zustimmungen:
    1
    MacUser seit:
    02.12.2004
    heisst was?
     
  4. Katana

    Katana MacUser Mitglied

    Beiträge:
    989
    Zustimmungen:
    0
    MacUser seit:
    30.08.2004
    hast du die rechte mal repariert? ich hatte mal einen ähnlichen fall -> onyx hat mir da beste dienste geleistet ...
     
  5. cpeyer

    cpeyer Thread Starter MacUser Mitglied

    Beiträge:
    63
    Zustimmungen:
    1
    MacUser seit:
    02.12.2004
    hab ich gemacht, werde aber nochmal drübergehen. eh mit onyx. muß ich dann die kiste neu starten?
     
  6. Katana

    Katana MacUser Mitglied

    Beiträge:
    989
    Zustimmungen:
    0
    MacUser seit:
    30.08.2004
    sorry, da bin ich mir nicht mehr sicher ... mein problem trat immer nach dem neustart auf, weshalb ich so testen konnte/musste, ob es behoben ist ... aber ich nehme an, dass ein neustart sinnig ist, wenn onyx irgendwelche system-caches "verändert"/"repariert" ...
     
  7. cpeyer

    cpeyer Thread Starter MacUser Mitglied

    Beiträge:
    63
    Zustimmungen:
    1
    MacUser seit:
    02.12.2004
    nach onyx leider keine änderung.
     
  8. babaloo

    babaloo MacUser Mitglied

    Beiträge:
    1.554
    Zustimmungen:
    75
    MacUser seit:
    09.03.2003
    also, die apps wollen ja scheinbar alle auf die gleiche datei zugreifen, können's aber nicht.

    mal gecheckt, ob die datei vorhanden ist? wenn ja, dann liegt entweder ein rechteproblem vor oder die datei ist zerschossen.

    vielleicht hilft das gute alte combo-update. würd ich einfach mal über's system laufen lassen.

    viel glück
    bl
     
  9. Hilarious

    Hilarious MacUser Mitglied

    Beiträge:
    2.184
    Zustimmungen:
    5
    MacUser seit:
    25.11.2004
    Dein Webkit.Framework ist defekt. Um es neu installieren zu können müsstest du es zuvor entfernen, indem Du diesen Ordner
    /System/Library/Frameworks/WebKit.framework
    in den Papierkorb verschiebst (ohne diese zu leeren).

    Nimm den alten MSIE-Browser, wenn Du ihn noch hast, und lade Safari erneut herunter von
    http://www.apple.com/de/safari/download/

    Installieren. Anschließend System neu starten. Wenn alles gut, müsstest Du den Papierkorb mit Deinem Adminpasswort leeren können.

    Hoffe, es hilft!
     
  10. cpeyer

    cpeyer Thread Starter MacUser Mitglied

    Beiträge:
    63
    Zustimmungen:
    1
    MacUser seit:
    02.12.2004
    @Hilarious
    Vielen Dank, hat super funktioniert.
     
Die Seite wird geladen...

Diese Seite empfehlen