Ruhezustand

Gerha

Mitglied
Thread Starter
Mitglied seit
18.11.2007
Beiträge
608
auf meinem MacBook pro ist die Umstellung auf den Ruhezustand sehr zeitverzögert.
Meine Frau nutzt den MacMini und immer, wenn man auf Apfel/Ruhezustand klickt geht das Maschinchen sofort brav in die Heia.

Ganz anders das MacBook pro. Zwar hängt ein 24" LED Bildschirm quasi als Dockingstation dran, aber nach Apfel/ Ruhezustand dauert es etwa 20-30 sec Minimum, bis alles ausgeht und das LED Lämpchen am MacBook pulsierend anzeigt, dass dieser Zustand erreicht ist.

Woran kann das liegen?
Hat jemand eine Idee?
 

bernie313

Aktives Mitglied
Mitglied seit
20.08.2005
Beiträge
23.447
Schau doch in Programme/Dienstprogramme/Konsole, dort in der Seitenleiste "Alle Meldungen" nach, ob dort ein Verzögerer zu erkennen ist.
Bekannte Spassbremsen sind abzumeldende externe Geräte, Dienste die noch beendet werden oder auch andere Ruhezustandeinstellungen.
 

11101001

Mitglied
Mitglied seit
27.03.2011
Beiträge
459
Liegt vermutlich am Hibernate Mode. Mal im Terminal (admin Rechte) "sudo pmset -a hibernatemode 0" eingeben. Dann wird der RAM Inhalt beim Zuklappen nicht auf die HDD gespeichert. Schneller aber unsicherer.

Der Standard Modus bei MBP ist "sudo pmset -a hibernatemode 3"
 

Gerha

Mitglied
Thread Starter
Mitglied seit
18.11.2007
Beiträge
608
das steht unter Konsole/Alle Meldungen zu dieser Zeit:
z.B.
07.05.11 21:51:15 kernel hibernate image path: /var/vm/sleepimage
07.05.11 21:51:15 kernel sizeof(IOHibernateImageHeader) == 512
07.05.11 21:51:15 kernel Opened file /var/vm/sleepimage, size 8589934592, partition base 0xc805000, maxio 400000 ssd 0
07.05.11 21:51:15 kernel hibernate image major 14, minor 2, blocksize 512, pollers 5
07.05.11 21:51:15 kernel hibernate_alloc_pages flags 00000000, gobbling 0 pages
07.05.11 21:51:15 kernel hibernate_setup(0) took 0 ms
07.05.11 21:51:15 kernel NVEthernet::setLinkStatus - Valid but not Active
07.05.11 21:51:15 kernel System SafeSleep
07.05.11 21:51:25 ntpd[28] sendto(17.72.255.12) (fd=26): Network is down
07.05.11 21:51:25 configd[14] setting hostname to "....Pro.local"
07.05.11 21:51:25 configd[14] network configuration changed.
07.05.11 21:51:25 kernel hibernate_page_list_setall start 0x6d554000, 0x6d593000
07.05.11 21:51:25 kernel hibernate_page_list_setall time: 582 ms
07.05.11 21:51:25 kernel pages 1917893, wire 100883, act 163996, inact 520, spec 194, zf 460, throt 0, could discard act 88295 inact 580939 purgeable 16654 spec 965952
07.05.11 21:51:25 kernel hibernate_page_list_setall found pageCount 266053
07.05.11 21:51:25 kernel IOHibernatePollerOpen, ml_get_interrupts_enabled 0
07.05.11 21:51:25 kernel IOHibernatePollerOpen(0)
07.05.11 21:51:25 kernel writing 262882 pages
07.05.11 21:51:25 kernel encryptEnd bf746d0
07.05.11 21:51:25 kernel image1Size 393051648, encryptStart1 0, End1 bf746d0
07.05.11 21:51:25 kernel encryptEnd 29841e50
07.05.11 21:51:25 kernel PMStats: Hibernate write took 8809 ms
07.05.11 21:51:25 kernel all time: 8809 ms, comp time: 2172 ms, deco time: 0 ms,
07.05.11 21:51:25 kernel image 696524800, uncompressed 1477591040 (360740), compressed 684913816 (46%), sum1 13de913b, sum2 f75ee417
07.05.11 21:51:25 kernel wired_pages_encrypted 97785, wired_pages_clear 97785, dirty_pages_encrypted 165170
07.05.11 21:51:25 kernel hibernate_write_image done(0)
07.05.11 21:51:25 kernel sleep
07.05.11 21:51:25 kernel Wake reason = EHC2


Dabei ist mir aufgefallen, dass der Rechner time-machine alle Stunde sucht, obwohl ich ihn doch schlafen gelegt habe. Wacht das system dann deswegen ständig auf?
 

bernie313

Aktives Mitglied
Mitglied seit
20.08.2005
Beiträge
23.447
Ja, er schreibt in das Sleep Image, das verzögert den ShutDown.
Du wirst also auf deinem Rechner den HibernateModus 1 oder wie voreingestellt 3 haben. Bei deiner Frau wird es wahrscheinlich der Modus 0 sein, also ein Ruhezustand ohne SleepImage( Sicherung des RAM Inhaltes auf der Festplatte).
 

Gerha

Mitglied
Thread Starter
Mitglied seit
18.11.2007
Beiträge
608
hier ist sehr schön beschrieben, was man wie einstellen kann.
Bei mir war Mode 3 eingestellt. Dauert wohl etwas länger, ist dafür sicherer.
Hier schön beschrieben: http://www.it-happens.de/2010/05/13/hibernate-modus-auf-dem-mac-einstellen.html

Ich wusste bisher nicht, was das bedeutet und dass es Einstellungsmöglichkeiten gibt.
Scheint also alles in Ordnung zu sein.

Vielen Dank für die Tipps und Ideen.
:)
 
Oben