register_globals is disabled...wie umstellen?

  1. m0mo

    m0mo Thread Starter MacUser Mitglied

    Mitglied seit:
    26.03.2005
    Beiträge:
    476
    Zustimmungen:
    2
    Hallo Leute,
    ich wollte gerade einmal oscommerce beim besten webspaceanbieter, dem localhost zum laufen bringen aber gleich zum anfang kommt diese meldung

    FATAL ERROR: register_globals is disabled in php.ini, please enable it!

    Nun, eine php.ini gibts bei mir nicht, umstellen wuerde ich es trotzdem gerne (naja, eigentlich nicht gerne, weiss jemand ob die globals eigentlich bei gaengigen webhostern eingeschaltet sind? ansonsten bringt der shop ja herzlich wenig :) )

    wie kann ich das bewerkstelligen?

    Danke fuer eure Hilfe!

    mfg
    m0mo
     
    m0mo, 09.11.2005
    #1
  2. bundu

    bundu MacUser Mitglied

    Mitglied seit:
    06.01.2004
    Beiträge:
    986
    Zustimmungen:
    14
    Hi!

    Schreib doch dem Support Deiens Providers eine Mail und bitte ihn, die Register Globals auf "on" zu setzen. Vorausgesetzt, die machen das auch... sollte aber in der Regel kein Problem sein!
     
    bundu, 09.11.2005
    #2
  3. m0mo

    m0mo Thread Starter MacUser Mitglied

    Mitglied seit:
    26.03.2005
    Beiträge:
    476
    Zustimmungen:
    2
    gut, das werde ich machen, ich wuerde den shop aber trotzdem erstmal bei mir zu haus zum laufen bringen wollen?

    und der chef vom lokalhost (glaube ich zumindest) bin noch immer ich :)
    wenn ich mir selber schreiben koennte und auch noch ne antwort bekommen wuerd, da waer ich gluecklich.

    mfg
    m0mo
     
    m0mo, 09.11.2005
    #3
  4. gewoldi

    gewoldi MacUser Mitglied

    Mitglied seit:
    13.07.2005
    Beiträge:
    125
    Zustimmungen:
    0
    es gibt irgendwo (unter /etc glaube ich bei Linux) eine php.ini, da musst du register_globals auf on stellen....

    Mach dir aber vorher klar, was das bedeutet
     
    gewoldi, 09.11.2005
    #4
  5. m0mo

    m0mo Thread Starter MacUser Mitglied

    Mitglied seit:
    26.03.2005
    Beiträge:
    476
    Zustimmungen:
    2
    hey gewoldi,

    also auf meinem mac gibts keine php.ini, das sagt spotlight und meine eigene suche.

    und was das mit den globals auf sich hat, weiss ich schon.
    schoen finde ichc es nicht unbedingt, aber so schlimm ist es auch nicht.


    Weiss noch irgendjemand rat?
    wie ich das vielleicht per console machen kann?

    mfg
    m0mo
     
    m0mo, 09.11.2005
    #5
  6. Ulfrinn

    Ulfrinn MacUser Mitglied

    Mitglied seit:
    30.01.2005
    Beiträge:
    6.684
    Zustimmungen:
    588
    Es hat schon einen Sinn, daß die automatische Registrierung von Parametern als globale Variablen mittlerweile standardmäßig deaktiviert ist: Bei unsauberem Code (oder auch bei sauberem, der aufgrund der Struktur für dieses Problem anfällig ist) kann das ganz schnell zu einer leichten Angreifbarkeit des Netzladens führen. Ich würde an deiner Stelle eher auf eine andere Lösung setzen, wenn oscommerce diese Einstellung erfordert.
     
    Ulfrinn, 09.11.2005
    #6
  7. m0mo

    m0mo Thread Starter MacUser Mitglied

    Mitglied seit:
    26.03.2005
    Beiträge:
    476
    Zustimmungen:
    2
    Ulfrinn, das weiss ich doch alles. Ich hab das ja auch durch, frueher mies gecodet, dann auf nen anderen server gekommen und zack, alles anders :>


    die sache ist die, dass oscommerce eine der besten freeware onlineshop loesungen ist und ich sie gerne fuer mich nutzen wuerde.

    also, bitte: wenn es jemand weiss, tut mir doch den gefallen und sagt mir, wo ich das umstellen kann.

    mfg
    m0mo
     
    m0mo, 09.11.2005
    #7
  8. Ulfrinn

    Ulfrinn MacUser Mitglied

    Mitglied seit:
    30.01.2005
    Beiträge:
    6.684
    Zustimmungen:
    588
    Sie sollte eigentlich in /etc liegen. Im Zweifelsfall mußt du zunächst die /etc/php.ini.default kopieren. In der Datei ist auch die Option „register_globals“.
     
    Ulfrinn, 09.11.2005
    #8
  9. gewoldi

    gewoldi MacUser Mitglied

    Mitglied seit:
    13.07.2005
    Beiträge:
    125
    Zustimmungen:
    0
    Spotlight sucht in den entsprechenden Verzeichnissen vermutlich nicht, ich kann nur sagen, dass es auf meinen Servern /etc/php.ini ist. Aber auf dem Mac hab ich kein php laufen... versuch doch mal im terminal dein Glück..... Sorry dass ich nicht weiter helfen kann....
     
    gewoldi, 10.11.2005
    #9
  10. Ulfrinn

    Ulfrinn MacUser Mitglied

    Mitglied seit:
    30.01.2005
    Beiträge:
    6.684
    Zustimmungen:
    588
    Absurderweise existiert die /etc/php.ini bei mir auch nicht, nur die Vorlage ist vorhanden – PHP stört das aber scheinbar nicht. ;)
     
    Ulfrinn, 10.11.2005
    #10
Die Seite wird geladen...
Ähnliche Themen - register_globals disabled umstellen
  1. Bastian
    Antworten:
    2
    Aufrufe:
    461
    Bastian
    07.07.2005