Probleme mit Xampp!

  1. gäda

    gäda Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2006
    Beiträge:
    142
    Zustimmungen:
    0
    Guten Morgen,

    Habe mir gestern abend xampp fuer mac runtergeladen.
    Habe es dann instaliert.
    Nun wollte ich local host aufrufen aber er zeigt nichts an.
    Ich habe eine hallo.php datei erstellt und in den ordner htdocs eingefuegt.
    wenn ich jetzt http://localhost/hallo.php aufrufe zeigt er mir nichts an.

    Was habe ich falsch gemacht?
     
    gäda, 03.09.2006
  2. mores

    moresMacUser Mitglied

    Mitglied seit:
    23.12.2003
    Beiträge:
    3.557
    Zustimmungen:
    106
    hast du XAMPP auch gestartet?

    bei MAMP ist es so, dass das programm laufen muss und server und datenbank aktiviert werden müssen.
     
    mores, 03.09.2006
  3. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    wie ich in dem "programmieren lernen" thread lese, fängst Du gerade erst an!

    Mit MAMPP machst Du Dir einiges jedoch zunächst schwerer!

    Zum Einen läuft auch ohne MAMPP bei Dir bereits der Apache-Webserver, Du kannst also mit NULL-Aufwand anfangen Web-Seiten zu erstellen

    Zum Zweiten ist PHP bereits im Lieferumfang enthalten. Du mußt es nur in der /etc/httpd.conf aktivieren!

    Zum Dritten verwirrst Du die Dinge für Anfänger nur, wenn Du 2 Apaches betreibst mit 2 PHP-Versionen. Das ist unnötig! Auch brauchst Du zum Lernen keine hochaktuelle PHP-Version. Sobald Dir da die Unterschiede klar sind, kannst Du ein aktuelles PHP leicht nachinstallieren - auch ohne MAMPP

    Zum Vierten ist auch am Anfang eine zusätzliche DB eher mehr Verwirrung als Nutzen! Sobald Du soweit bist und eine benötigst, kannst Du Dir ja z.B. mysql zusätzlich installieren und mit dem vorhandenen Apache/PHP verwenden.

    MAMPP ist ne tolle Lösung um eine Entwicklungs- und Testumgebung zu haben. Meines Erachtens verwirrt die vermeintliche Einfachheit und die Dopplung der Server und conf-Datein nur unnötig! Halte es einfach und fang mit dem an, was Du schon da hast ist mein Tipp!
     
    wegus, 03.09.2006
  4. gäda

    gäda Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2006
    Beiträge:
    142
    Zustimmungen:
    0
    Die angegeben befehle bzw codes gibts dort nicht wenn ich das aktiviren will.
    Ich bin am suchen finde sie aber nicht.
     
    gäda, 03.09.2006
  5. baumeister

    baumeisterMacUser Mitglied

    Mitglied seit:
    31.08.2006
    Beiträge:
    8
    Zustimmungen:
    0
    ich hatte auch schwierigkeiten mit xampp, dann habe ich es gelöscht und mamp installiert, das funktioniert hervorragend.

    http://www.mamp.info/de/home/

    gruß baumeister
     
    baumeister, 05.09.2006
  6. gäda

    gäda Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2006
    Beiträge:
    142
    Zustimmungen:
    0
    ja, habe auch mamp installiert.

    Laeuft hervorragend
     
    gäda, 06.09.2006
Die Seite wird geladen...
Ähnliche Themen - Probleme Xampp
  1. pfannkuchen2001
    Antworten:
    2
    Aufrufe:
    1.028
    pfannkuchen2001
    04.01.2015
  2. Ichliebedich
    Antworten:
    1
    Aufrufe:
    1.033
    falkgottschalk
    10.09.2014
  3. bigB
    Antworten:
    3
    Aufrufe:
    1.159
  4. Stefan27at
    Antworten:
    6
    Aufrufe:
    730
  5. stefan6591
    Antworten:
    2
    Aufrufe:
    1.728
    stefan6591
    21.10.2008