Benutzerdefinierte Suche

Probleme mit PHP bzw. Apache

  1. mec

    mec Thread StarterMacUser Mitglied

    Mitglied seit:
    17.12.2003
    Beiträge:
    369
    Zustimmungen:
    1
    Hallo Leute,
    ich habe Probleme, PHP bzw. Apache zum Laufen zu kriegen. Ich hab PHP5 installiert, hab mich da an die Erklärung unter http://www.macuser.de/forum/showthread.php?t=40353 gehalten, gab auch bei der Installation keine Probleme, aber wenn ich http://localhost/ bei mir im Browser eingebe, kommt immer nur die Fehlermeldung "Safari kann die Seite „http://localhost/“ nicht öffnen, da Safari keine Verbindung zum Server „localhost“ aufbauen konnte.". Woran kann das liegen? Hat jemand einen Tipp? Bitte nachsichtig sein, bin auf dem Gebiet noch nicht so fit...
    Gruß,
    mec
     
  2. falkgottschalk

    falkgottschalkMacUser Mitglied

    Mitglied seit:
    22.08.2005
    Beiträge:
    24.005
    Zustimmungen:
    1.599
    Es wäre hilfreich, wenn du Apache nach der Installation auch starten würdest.
    War es das schon?
     
    falkgottschalk, 29.09.2006
  3. mec

    mec Thread StarterMacUser Mitglied

    Mitglied seit:
    17.12.2003
    Beiträge:
    369
    Zustimmungen:
    1
    Sorry, wie mach ich das?
     
  4. lol

    lolMacUser Mitglied

    Mitglied seit:
    18.01.2006
    Beiträge:
    1.556
    Zustimmungen:
    63
    terminal:
    httpd start
     
  5. mec

    mec Thread StarterMacUser Mitglied

    Mitglied seit:
    17.12.2003
    Beiträge:
    369
    Zustimmungen:
    1
    Ok, hab ich getan, es tritt aber irgend ein Fehler aus. Aus der Anzeige werd ich leider nicht schlau... Kann mir das vielleicht jemand erklären:

    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    [Sat Sep 30 12:08:16 2006] [warn] module mod_php5.c is already added, skipping
    Processing config file: /private/etc/httpd/users/meinbenutzername.conf
    [Sat Sep 30 12:08:26 2006] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    fopen: Permission denied
    httpd: could not open error log file /private/var/log/httpd/error_log.

    Gruß,
    mec
     
  6. moses_78

    moses_78MacUser Mitglied

    Mitglied seit:
    08.04.2005
    Beiträge:
    1.264
    Zustimmungen:
    22
    Code:
    sudo apachectl start
    Du musst lediglich dein Benutzerpasswort eingeben,
    und der Apache sollte starten.
     
    moses_78, 30.09.2006
  7. oDeM

    oDeMMacUser Mitglied

    Mitglied seit:
    15.08.2005
    Beiträge:
    106
    Zustimmungen:
    0
    Und da ich erst gestern selbst Probleme mit dieser entropy version hatte noch ein Tipp. In der php.ini den Parameter short_open_tag auf On stellen.
    Sonst wird PHP-Code der nur mit <? und nicht mit <?php eingeleitet wird nicht interpretiert.

    Die richtige php.ini sollte im etc Verzeichnis der php5 installation liegen.
     
    oDeM, 30.09.2006
  8. mec

    mec Thread StarterMacUser Mitglied

    Mitglied seit:
    17.12.2003
    Beiträge:
    369
    Zustimmungen:
    1
    Hm, hab ich gemacht, funktioniert aber immer noch nicht.
    Irgendwo hängts...

    "httpd could not be started"

    Versteh ich irgendwie nicht... Woran könnte es denn wohl liegen???
    :(
     
  9. oDeM

    oDeMMacUser Mitglied

    Mitglied seit:
    15.08.2005
    Beiträge:
    106
    Zustimmungen:
    0
    Dazu musst du ins error logfile schauen. Da stehts auf jeden Fall drin. Findest du standardmäßig unter /var/log/httpd/
    Ich würde mal spontan auf die config tippen, aber normalerweise bekommt man den Fehler direkt ausgegeben.

    probier mal

    sudo apachectl configtest

    und

    sudo apachectl start
     
    oDeM, 30.09.2006
  10. mec

    mec Thread StarterMacUser Mitglied

    Mitglied seit:
    17.12.2003
    Beiträge:
    369
    Zustimmungen:
    1
    So, hab ich gemacht, Terminal gibt nur aus
    " httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName"

    Das einzige, was das error-logfile ausgibt ist:
    (14)Bad address: mod_rewrite: Could not set permissions on rewrite_log_lock; check User and Group directives
    Configuration Failed


    Also irgendwie hilft mir das auch nicht weiter...
     
Die Seite wird geladen...
Ähnliche Themen - Probleme PHP bzw
  1. Neddi
    Antworten:
    4
    Aufrufe:
    641
  2. keykiller
    Antworten:
    21
    Aufrufe:
    1.834
  3. R.Carlos
    Antworten:
    0
    Aufrufe:
    353
    R.Carlos
    02.11.2007
  4. ben-pen
    Antworten:
    2
    Aufrufe:
    493
    ben-pen
    29.09.2006