Benutzerdefinierte Suche

Probleme mit Linux-Fileserver

  1. Bitchmaster

    Bitchmaster Thread StarterMacUser Mitglied

    Mitglied seit:
    08.03.2005
    Beiträge:
    76
    Zustimmungen:
    0
    Hallo

    Ich habe folgendes Problem: Ich habe einen Fileserver unter Linux laufen. Dieser gibt mit Samba ein Verzeichnis frei. Auf meinem Mac kann ich in der Konsole mit mount_smbfs -o username=xxx,password=yyy //server/volume mnt problemlos das Volume mounten und es erscheint auch logischerweise im Finder.

    NUR: Wenn ich im Finder das Netzwerk absuche und dann per Mausklick auf den Server (Verbinden) klicke, damit der Mac das Volume mountet, kann ich gerade noch eben meinen User und das PW eingeben, danach wartet er sich tot....kein Timeout, garnichts. Er wartet und wartet und wartet..
    Ist das Problem jmd bekannt? Am Linux-Server liegt es vermutlich nicht, da das manuelle Mounten ja geht.

    Danke schonmal und schönen Gruß,
    BM
     
    Bitchmaster, 08.07.2005
  2. jlepthien

    jlepthienMacUser Mitglied

    Mitglied seit:
    05.04.2004
    Beiträge:
    4.858
    Zustimmungen:
    118
    Du kannst auch aus dem Finder heraus mit Appel+K verbinden...geht das?
     
    jlepthien, 08.07.2005
  3. Bitchmaster

    Bitchmaster Thread StarterMacUser Mitglied

    Mitglied seit:
    08.03.2005
    Beiträge:
    76
    Zustimmungen:
    0
    nein, das geht auch nicht. zumindest nicht bei meinem fileserver.
    andere unter windows freigegebene volumes kann ich im finder über "verbinden" problemlos einbinden.
     
    Bitchmaster, 08.07.2005
  4. jlepthien

    jlepthienMacUser Mitglied

    Mitglied seit:
    05.04.2004
    Beiträge:
    4.858
    Zustimmungen:
    118
    Bist du dann sicher das der Fileserver richtig konfiguriert ist? Wenn es doch mit allen anderen geht...
     
    jlepthien, 08.07.2005
  5. Bitchmaster

    Bitchmaster Thread StarterMacUser Mitglied

    Mitglied seit:
    08.03.2005
    Beiträge:
    76
    Zustimmungen:
    0
    Also ich kann lokal auf dem Fileserver mit mount -t smbfs [....] die Freiagbe mounten und auch bereits auf meinem Mac unter der Konsole. Also geh ich mal davon aus dass die Freigabe OK ist. User/PW gebe ich auch genauso ein wie beim Konsolenbefehl. Keine Ahnung was der Finder sich da für Extrawürste leistet beim mounten...Wenn man User/PW-Daten eingibt wird er sich ja wohl hoffentlich nicht als Gast anmelden wollen, am Samba-Server..
     
    Bitchmaster, 08.07.2005
  6. sack

    sackMacUser Mitglied

    Mitglied seit:
    20.09.2004
    Beiträge:
    1.265
    Zustimmungen:
    33
    seit Tiger akzeptiert mein Mac den DNS auf dem Linux-Server nicht mehr, ich kann selbigen nur noch über die IP-Adresse ansprechen. Dadurch funktioniert u.a. das automatische Mounten der Netzlaufwerke auch nicht mehr, wenn z.B. lokale Aliase auf Netzdateien verweisen. Diverse andere Sachen in diese Richtung (und überhaupt, aber das ist ein anderes Thema) funktionieren auch nicht mehr, vielleicht hängt es damit zusammen ?

    Auf Win-Rechner kann ich per Apfel+K nach wie vor per Namen zugreifen, Windows Rechner können Ihrerseits nach wie vor problemlos mit dem Linux-Server via Namen kommunizieren. Das Verbinden mit Servern im Finderfenster wie oben beschrieben hat bei mir unter Panther schon nicht stabil funktioniert, unter Tiger gar nicht mehr.

    Sack
     
    sack, 08.07.2005
  7. Bitchmaster

    Bitchmaster Thread StarterMacUser Mitglied

    Mitglied seit:
    08.03.2005
    Beiträge:
    76
    Zustimmungen:
    0
    Also ich habe meinen Server in der /etc/hosts eingetragen, sollte aber egal sein, weil ich bei Apfel+K immer die IP-Adresse eingebe.
    Auf den Apple-Seiten hab ich bisher auch nichts dazu gefunden
    Da der Fileserver im Dauerbetrieb läuft könnte ich das Volume in der /etc/fstab eintragen oder den Mountbefehl irgendwo in den Startskripten unterbringen, aber es geht eigentlich ja auch ums Prinzip daß sowas auch aus dem Finder funktionieren muß...immerhin ist es eigentlich auf beiden Seiten der gleiche Code - Samba als Sever und die Samba-Bibliotheken als Client.
     
    Bitchmaster, 08.07.2005
  8. Bitchmaster

    Bitchmaster Thread StarterMacUser Mitglied

    Mitglied seit:
    08.03.2005
    Beiträge:
    76
    Zustimmungen:
    0
    Also mit Apfel+K gehts nun. Keine Ahnung was ich vorher falsch gemacht habe. Habe auch testweise mal im Fileserver das verbose logging eingeschaltet und mir das Log angesehen. Wenn ich direkt per Maus im Finder die Verbindung einleite, passiert auf dem Fileserver garnichts. Nur mit Apfel+K gehts...
     
    Bitchmaster, 08.07.2005
  9. jlepthien

    jlepthienMacUser Mitglied

    Mitglied seit:
    05.04.2004
    Beiträge:
    4.858
    Zustimmungen:
    118
    Das ist doch aber auch schon mal gut.
     
    jlepthien, 08.07.2005
Die Seite wird geladen...
Ähnliche Themen - Probleme Linux Fileserver
  1. Ronny84
    Antworten:
    2
    Aufrufe:
    93
  2. gagio
    Antworten:
    3
    Aufrufe:
    173
  3. fabl
    Antworten:
    1
    Aufrufe:
    70
  4. jcs3000

    Passwort Probleme

    jcs3000, 29.06.2017, im Forum: Mac OS
    Antworten:
    5
    Aufrufe:
    164
    rechnerteam
    29.06.2017
  5. Aladin033
    Antworten:
    6
    Aufrufe:
    216
    Aladin033
    31.12.2016