Probleme beim Einrichten von VPN (L2TP/IPSec) bei Synology DS413j

Diskutiere das Thema Probleme beim Einrichten von VPN (L2TP/IPSec) bei Synology DS413j im Forum Netzwerk.

  1. BFBS

    BFBS Thread Starter Mitglied

    Beiträge:
    470
    Zustimmungen:
    16
    Mitglied seit:
    15.07.2006
    Moinsen zusammen,
    ich möchte auf meiner Synology Diskstation DS413j einen L2TP/IPSec VPN Server einrichten. Leider ist das bisher - auch nach Sichtung diverser YouTube Videos - noch nicht wirklich von Erfolg gekrönt. Hoffentlich könnt ihr mir weiterhelfen ...

    Hier erstmal meine bisherigen Einstellungen:

    1) Am Router "Thomson TWG870" (Kabelmodem mit WLAN-Router)

    a) Firewall: Firewall Protection ist auf "low" gestellt - d.h. "No Ports Restricted". (Getestet wurde auch mit deaktivierter Firewall, gleiches Ergebnis)
    b) Port Forwarding: Die Ports 500, 1701 und 4500 sind für TCP/UDP freigeschaltet und auf die statische IP des Diskstation umgeleitet.

    Das Port Forwarding (über Synology DynDNS) funktioniert für den FTP-Port 21 und den SFTP-Port 22 einwandfrei. Daher gehe ich davon aus, dass hier nicht das Problem liegt.

    2) An der Diskstation

    a) VPN Server: Ist installiert und für L2TP/IPSec wurden folgende Einstellungen vorgenommen ...
    Dyn. IP : 10.2.0.0
    Max. Verbindungen: 5
    Identprüfung: MS-CHAP v2
    MTU: 1400
    Manuelle DNS verwenden : Deaktiviert
    Pre-Shared Key: Wurde festgelegt.
    Die Privilegien wurden den einzelnen Nutzern entsprechend verteilt.

    b) Firewall: Die Ports 500, 1701 und 4500 (alle UDP) wurden in der Firewall der Diskstation freigegeben.

    c) Benutzerverwaltung: Den Benutzern wurden die Zugriffsrechte für die jeweiligen gemeinsamen Ordnern zugewiesen.

    3) Am Mac (im gleichen lokalen Netzwerk) bzw. iPhone über LTE
    Unter Systemeinstellungen > Netzwerk wurde die Verbindung "VPN (L2TP über IPSec)" erstellt. Dabei wurde die DDNS des NAS eingegeben sowie Benutzername, Benutzerkennwort und Pre-Shared Key.

    Dennoch wird keine Verbindung per VPN zum NAS aufgebaut. Beim iPhone kommt die Fehlermeldung "Authentifizierung fehlgeschlagen". Beim Mac kommt diese Fehlermeldung "Der L2TP-VPN-Server antwortet nicht. Versuchen Sie erneut, eine Verbindung herzustellen. Wenn das Problem weiterhin besteht, überprüfen Sie die Einstellungen und wenden Sie sich an Ihren Administrator.".

    Momentan weiß ich echt nicht weiter. Was mache ich falsch? Habe ich vergessen irgendwo ein Häkchen zu setzen? Stehe gerade echt ein wenig aufm Schlauch ...


    Mit freundlichen Grüßen
    Stefan
     
  2. beage

    beage Mitglied

    Beiträge:
    2.060
    Zustimmungen:
    273
    Mitglied seit:
    18.01.2012

    Da geht's doch schon los.

    Du weisst, was Du tust, oder bastelst Du?

    Edit: DU bist der "Administrator"
     
  3. BFBS

    BFBS Thread Starter Mitglied

    Beiträge:
    470
    Zustimmungen:
    16
    Mitglied seit:
    15.07.2006
    Moin,

    bei der Dyn. IP handelt es sich laut Synology Dokumentation um eine virtuelle IP-Adresse. Die 10.2.0.0 (10.0.0.0 ist an dieser Stelle ein Tippfehler und wurde in der Beschreibung korrigiert) ist die Standardeinstellung von Synology. Die 0 am Ende ist nicht veränderbar und bedeutet, dass der IP-Adressbereich sich von 10.2.0.1 bis 10.2.0.(max. Anzahl von Verbindungen) erstreckt. Von daher sehe ich an dieser Stelle eigentlich keine Probleme.

    Abgesehen davon, bezweifle ich ernsthaft, dass ich so weit komme. In den Protokollen der Diskstation wird nie erwähnt, dass jemand versucht sich zu connecten und bspw. an der Authentifizierung gescheitert ist.
     
  4. BFBS

    BFBS Thread Starter Mitglied

    Beiträge:
    470
    Zustimmungen:
    16
    Mitglied seit:
    15.07.2006
    So ... habe nochmal ein wenig getestet.

    Richte ich an meinem Mac eine VPN Verbindung mit der lokalen IP der Diskstation ein, so funktioniert die VPN Verbindung einwandfrei. D.h. Passwörter, Firewalleinstellungen und Nutzerberechtigungen müssten passen. Gebe ich die DynDNS Adresse oder die externe IP Adresse ein, funktioniert es nicht.

    Außerdem habe ich versucht mit OpenVPN über den Port 1194 eine Verbindung herzustellen. Auch hier kein Erfolg.

    Bin gerade echt überfragt. Hat jemand noch eine Idee?
     
  5. xentric

    xentric Mitglied

    Beiträge:
    3.978
    Zustimmungen:
    774
    Mitglied seit:
    11.05.2007
    Dann geht der VPN.

    Kann dein Router GRE, VPN, L2TP Pass Through, oder wie auch immer es bei dem heißt? Hast du du aktiviert?
     
  6. BFBS

    BFBS Thread Starter Mitglied

    Beiträge:
    470
    Zustimmungen:
    16
    Mitglied seit:
    15.07.2006
    Jepp ... L2TP Pass Through ist aktiviert.
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite weitersurfst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...