Problem mit MAMP - Apache startet plötzlich nicht mehr

tunixMAC

Mitglied
Thread Starter
Mitglied seit
16.03.2008
Beiträge
71
Hallo Forum,
ich habe schon die Suchfunktion bemüht aber nix passendes gefunden.

Ich verwende MAMP 1.7.1 seit langem ohen Probleme. Heute wollte ich (nach längerer Pause) den Server wieder starten aber die "Apache Ampel" bleibt rot. MySQL startet wie gewohnt, der Apache leider nicht. Ins apache_error_log wird NICHTS hineingeschrieben. Ich habe schon die httpd.conf gelöscht und ersetzt, das hat aber auch nichts gebracht.

Hat jemand noch einen Tipp?


danke schonmal und gruß
tunix
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
ist web-Sharing aus (Systemeinstellungen) ? sonst läuft nämlich der OS X eigene Apache und ggf. versucht der MAMP-Apache auf dem selben Port zu starten ( kann man bei MAMP einstellen)
 

tunixMAC

Mitglied
Thread Starter
Mitglied seit
16.03.2008
Beiträge
71
hi wegus,
da, das web-sharing ist aus. bei MAMP steht der apache auf port 8888.
hm, ich versteh's nicht. ich hab keien ahnung, was ich in der zwischnezit geändert haben sollte - eigentlich nämlich gar nix! :(
 
D

dms

Ich würd einfach die Datenbanken und htdocs sichern und eine aktuelle Version von MAMP drüberspielen.
 

tunixMAC

Mitglied
Thread Starter
Mitglied seit
16.03.2008
Beiträge
71
Ich würd einfach die Datenbanken und htdocs sichern und eine aktuelle Version von MAMP drüberspielen.
hab ich gemacht - es funktioniert wieder :)
tja, werd ich wohl abhaken unter "muss man nicht verstehen" hehe


vielen dank für die tipps und gruß
tunix
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
der nächste Schritt wäre ein error.log kontrollieren gewesen. Aber so läuft es ja auch wieder!
 

wegus

Moderator
Mitglied seit
13.09.2004
Beiträge
17.375
dann wär der nächste Schritt ein manueller Start i Terminal ;)
 

Jakob

Aktives Mitglied
Mitglied seit
05.01.2004
Beiträge
1.070
Guter Trick für zickige MAMP-Server (z.B. ist die Ampel grün, aber der Server läuft nicht wirklich): In die Preferences gehen und mit „Ok“ wieder rausgehen. Funktioniert jedes Mal.
 
Oben