Problem mit iframe und externer seite

  1. EvilElvis666

    EvilElvis666 Thread StarterMacUser Mitglied

    Mitglied seit:
    10.08.2004
    Beiträge:
    236
    Zustimmungen:
    9
    hi leute,
    hab hier ein kleines (oder grosses) problem mit der iframe-geschichte.
    habe eine externe seite über einen iframe in meine seite eingebunden.
    hat auch wunderbar geklappt, die seite wurde angezeigt.
    nach ner weile wollte ich entsprechende seite wieder aufrufen, nur
    anstatt die externe seite zu laden, kam folgende fehlermeldung:

    Microsoft VBScript runtime error '800a01a8'

    Object required: 'Session(...)'

    /sports/handball/info/ergebnisse/uebersicht.asp, line 17

    Also: Was tun?

    gruß
    Elvis
     
    EvilElvis666, 05.04.2006
  2. Galanos

    GalanosMacUser Mitglied

    Mitglied seit:
    19.12.2005
    Beiträge:
    624
    Zustimmungen:
    23
    Das wird wohl kaum am iframe liegen. Schaut so aus, als ob ein Fehler im Code der externen Seite ist.
    Kommt derselbe Fehler auch, wenn du auf dem ueblichen Weg zu dieser Seite browst, um dir die Handballergebnisse(?) anzuschauen?
     
    Galanos, 06.04.2006
  3. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Code:
    Object required: 'Session(...)'
    Da keimt doch irgendwie der Verdacht auf, dass die nicht wollen, dass die Seite auf fremden Webseiten unerlaubt eingebunden wird ;).
     
    maceis, 06.04.2006
  4. Galanos

    GalanosMacUser Mitglied

    Mitglied seit:
    19.12.2005
    Beiträge:
    624
    Zustimmungen:
    23
    Klang fuer mich auch so, aber nach ein bisschen Googeln bin ich zu dem Schluss gekommen, dass irgendwelche ASP-Module nicht aktiviert sein muessten. Kann ich aber auch falsch verstanden haben.
     
    Galanos, 06.04.2006
  5. EvilElvis666

    EvilElvis666 Thread StarterMacUser Mitglied

    Mitglied seit:
    10.08.2004
    Beiträge:
    236
    Zustimmungen:
    9
    tja, wenn man die seite direkt betrachtet, tritt der fehler nicht auf.
    wird wohl dran liegen, dass das ding serverseitig irgendwas zu laden
    versucht, was bei der einbindung in den iframe auf der strecke bleibt.
    leider hab ich auch nach ausgiebigem googeln keine gescheite erklärung,
    geschweige denn lösung gefunden.

    wird bei 'asp' seiten ein cookie o.ä. hinterlegt?

    @maceis: die einbindung is mit dem betreiber der seite abgeklärt!!

    Oh - Tadaaa! mein 100ster beitrag cake
     
    EvilElvis666, 07.04.2006
  6. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Die verwenden möglicherweise ein vorgefertigtes Skript, dass die Einbindung unterbindet (evtl. ohne dass sie das wissen).
    "Session required" hört sich jedenfalls so an, als ob die mit Sessions arbeiten, die Voraussetzung sind, dass bestimmte Seiten funktionieren.

    Lösen könnte man das wohl mit einen CGI Skript, das sich mit der Quellwebseite verbindet, den gewünschten Inhalt "abholt" und auf Deiner Seite mit ausgibt.
    In Perl könnte man so etwas z.B. mit den Moduenl LWP oder LWP::Mechanize umsetzen. Einbinden könntest Du das in Deine Seite dann mit SSI oder Du lässt gleich dieganze Seite von dem cgi Skript erstellen.

    Es geht aber bestimmt auch mit PHP.
    Die Frage ist, was Du bei Deinem Hoster einsetzen kannst und womit Du besser klarkommst.

    HTH
     
    maceis, 07.04.2006
Die Seite wird geladen...
Ähnliche Themen - Problem iframe externer
  1. simusch
    Antworten:
    2
    Aufrufe:
    187
    simusch
    04.05.2017
  2. melesch
    Antworten:
    3
    Aufrufe:
    976
    falkgottschalk
    19.05.2014
  3. flohaase
    Antworten:
    2
    Aufrufe:
    967
    flohaase
    26.09.2013
  4. kraftwerk
    Antworten:
    9
    Aufrufe:
    1.721
  5. Tehes
    Antworten:
    4
    Aufrufe:
    991