Problem bei X11 während ./configure

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von McOdysseus, 15.08.2006.

  1. McOdysseus

    McOdysseus Thread Starter MacUser Mitglied

    Beiträge:
    6.235
    Medien:
    1
    Zustimmungen:
    823
    MacUser seit:
    31.12.2003
    Hi zusammen!!

    Ich mußte mir X11 auf meinen Rechner schrauben, da ich eine bestimmmte bioinformatische Software (EMBOSS) brauche.

    Gesagt, getan.

    Gebe ich jedoch ./configure ein (Wie in der Dokumentation angegeben), erscheint folgende Fehlermeldung:

    cyprinus:~/EMBOSS-4.0.0 christian$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... no
    checking for nawk... no
    checking for awk... awk
    checking whether make sets $(MAKE)... no
    checking for gawk... (cached) awk
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH

    Kann mir jemand verraten, was nun zu tun ist?
    Kann ich einen Compiler nachinstallieren?

    Sorry für die vielleicht blöde Frage, ich bin absolut unerfahren auf diesem Gebiet!

    Danke schon mal für die Hilfe
    McO
     
  2. santaclaws

    santaclaws MacUser Mitglied

    Beiträge:
    3.587
    Zustimmungen:
    257
    MacUser seit:
    09.04.2006
    Salut,

    Vielleicht hilft Dir der Link ein bisschen weiter.
     
  3. anti85

    anti85 MacUser Mitglied

    Beiträge:
    254
    Zustimmungen:
    6
    MacUser seit:
    18.01.2006
    es gibt doch x11 als vorcompiliertes packet fuer macosx, nimm doch das.ist glaub ich sogar auf den installations dvds
     
  4. dpr

    dpr MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    04.04.2006
    Nicht X11, sondern eine Software names EMBOSS soll kompiliert werden.

    Das Problem scheint auch bereits gelöst zu sein: http://www.macuser.de/forum/showthread.php?t=193954
     
  5. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    47.155
    Zustimmungen:
    3.681
    MacUser seit:
    23.11.2004
    wie wäre es mit xcode installieren? ;)
    du hast einfach keinen gcc installiert...
     
  6. McOdysseus

    McOdysseus Thread Starter MacUser Mitglied

    Beiträge:
    6.235
    Medien:
    1
    Zustimmungen:
    823
    MacUser seit:
    31.12.2003
    Dank dir! :)
    …ich habe - wie gesagt - mal wieder schneller gepostet, als ich gedacht habe… ;)
     
Die Seite wird geladen...

Diese Seite empfehlen